(www/emacs-w3m-snapshot) Fix build, add buildlink3 of semi, and new patch for load-path
This commit is contained in:
parent
91005c5552
commit
f44d1189b4
3 changed files with 27 additions and 2 deletions
|
@ -1,4 +1,4 @@
|
|||
# $NetBSD: Makefile,v 1.15 2019/10/21 23:47:07 mef Exp $
|
||||
# $NetBSD: Makefile,v 1.16 2019/10/31 22:41:44 mef Exp $
|
||||
|
||||
VERSION= 1.4.632
|
||||
DATE_TIME= 20190920.1116
|
||||
|
@ -39,6 +39,7 @@ BUILD_DEFS+= GAMEDATAMODE
|
|||
|
||||
.include "../../devel/apel/buildlink3.mk"
|
||||
.include "../../devel/flim/buildlink3.mk"
|
||||
.include "../../devel/semi/buildlink3.mk"
|
||||
.include "../../editors/mule-ucs/buildlink3.mk"
|
||||
|
||||
pre-configure:
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: distinfo,v 1.12 2019/10/21 23:47:07 mef Exp $
|
||||
$NetBSD: distinfo,v 1.13 2019/10/31 22:41:44 mef Exp $
|
||||
|
||||
SHA1 (w3m-el-snapshot_1.4.632+0.20190920.1116.c9cdb7e.orig.tar.gz) = 30b6373819a34000d96d3a81c0260ecf523d2827
|
||||
RMD160 (w3m-el-snapshot_1.4.632+0.20190920.1116.c9cdb7e.orig.tar.gz) = 986ad61041e8f66519a8a72c5664743dd365acf0
|
||||
|
@ -6,3 +6,4 @@ SHA512 (w3m-el-snapshot_1.4.632+0.20190920.1116.c9cdb7e.orig.tar.gz) = 34dbf0d83
|
|||
Size (w3m-el-snapshot_1.4.632+0.20190920.1116.c9cdb7e.orig.tar.gz) = 1061974 bytes
|
||||
SHA1 (patch-Makefile.in) = 5e3c1d6335c72c2644f3b6136dace3358a6ba347
|
||||
SHA1 (patch-w3m.el) = a4c14deed274e984f854255513ce49dbd320eb83
|
||||
SHA1 (patch-w3mhack.el) = 074487089804e8685d53f7cf5918843945990710
|
||||
|
|
23
www/emacs-w3m-snapshot/patches/patch-w3mhack.el
Normal file
23
www/emacs-w3m-snapshot/patches/patch-w3mhack.el
Normal file
|
@ -0,0 +1,23 @@
|
|||
$NetBSD: patch-w3mhack.el,v 1.3 2019/10/31 22:41:44 mef Exp $
|
||||
|
||||
CF-SX2# cd /tmp/www/emacs-w3m-snapshot/work/emacs-w3m-emacs-w3m-c9cdb7e/
|
||||
|
||||
CF-SX2# emacs -batch -f batch-byte-compile mime-w3m.el
|
||||
In toplevel form:
|
||||
mime-w3m.el:37:1:Error: Cannot open load file: No such file or directory, mime-view
|
||||
mime-w3m.el:38:1:Error: Cannot open load file: No such file or directory, w3m
|
||||
|
||||
|
||||
--- emacs-w3m-emacs-w3m-c9cdb7e/w3mhack.el.orig 2019-09-20 20:16:36.000000000 +0900
|
||||
+++ w3mhack.el 2019-10-30 21:16:09.444149861 +0900
|
||||
@@ -256,6 +256,10@@ There seems to be no shell command which
|
||||
(push (file-name-directory x) paths))
|
||||
(if (setq x (locate-library "gnus"))
|
||||
(push (file-name-directory x) paths))
|
||||
+ (if (setq x (locate-library "mime-view"))
|
||||
+ (push (file-name-directory x) paths))
|
||||
+ (if (setq x (locate-library "w3m"))
|
||||
+ (push (file-name-directory x) paths))
|
||||
(let (print-level print-length)
|
||||
(princ (mapconcat
|
||||
(function directory-file-name)
|
Loading…
Reference in a new issue