Updating devel/p5-Module-Build from 0.36010 to 0.36030

pkgsrc changes:
- Remove upstream applied fix

Upstream changes:
0.3603 - Mon Jan 18 22:28:59 EST 2010

(Oops, I released the last one before I realized this should have been
fixed along with it.)

 Bug fixes:

 - Module::Build::Compat would croak on distibutions that set requires
   'perl' to a dotted decimal like '5.6.2'.  We now skip that key
   since it doesn't go into PREREQ_PM and we numify it properly for
   'use 5.006002' in the generated Makefile.PL (RT#53409)
   [David Golden, adapted from patch by G. Allen Morris III]

0.3602 - Mon Jan 18 22:09:54 EST 2010

 Bug fixes:

 - Fix failures in t/properties/needs_compiler.t when $ENV{CC} is set
   (RT#53296) [David Golden, adapted from patch by Jens Rehsack]
This commit is contained in:
sno 2010-01-23 13:24:05 +00:00
parent 263a7ec8be
commit f450d344b7
3 changed files with 6 additions and 28 deletions

View file

@ -1,6 +1,6 @@
# $NetBSD: Makefile,v 1.26 2010/01/17 17:38:17 sno Exp $
# $NetBSD: Makefile,v 1.27 2010/01/23 13:24:05 sno Exp $
DISTNAME= Module-Build-0.3601
DISTNAME= Module-Build-0.3603
PKGNAME= p5-${DISTNAME}0
SVR4_PKGNAME= p5mob
CATEGORIES= devel perl5

View file

@ -1,6 +1,5 @@
$NetBSD: distinfo,v 1.17 2010/01/17 17:38:17 sno Exp $
$NetBSD: distinfo,v 1.18 2010/01/23 13:24:05 sno Exp $
SHA1 (Module-Build-0.3601.tar.gz) = 12cae96fa2bc62bb554fe9086d69cc9deecfd1aa
RMD160 (Module-Build-0.3601.tar.gz) = 92864d75e90e2e457903c273291baee0b07513fe
Size (Module-Build-0.3601.tar.gz) = 296085 bytes
SHA1 (patch-aa) = ecb95c0d24593787401e9d0776d95ba261975a72
SHA1 (Module-Build-0.3603.tar.gz) = 772250ecde4022089063c4b07b7a05319b5cfcea
RMD160 (Module-Build-0.3603.tar.gz) = fa75e511f0c4ba36472528fd3a51189bf11d8375
Size (Module-Build-0.3603.tar.gz) = 296553 bytes

View file

@ -1,21 +0,0 @@
$NetBSD: patch-aa,v 1.5 2010/01/17 17:38:17 sno Exp $
--- t/properties/needs_compiler.t.orig 2009-12-21 19:45:39.000000000 +0000
+++ t/properties/needs_compiler.t
@@ -106,6 +106,8 @@ is( $mb->build_requires->{'ExtUtils::CBu
# falsify compiler and test error handling
#--------------------------------------------------------------------------#
+my $oldcc = $ENV{CC};
+undef $ENV{CC};
my $err = stderr_of( sub {
$mb = $dist->new_from_context( config => { cc => "adfasdfadjdjk" } )
});
@@ -117,6 +119,6 @@ eval { $mb->dispatch('build') };
like( $@, qr/no compiler detected/,
"hidden compiler resulted in fatal message during Build"
);
-
+$ENV{CC} = $oldcc;
# vim:ts=2:sw=2:et:sta:sts=2