py-cssselect2: updated to 0.4.1
Version 0.4.1 Fix PyPI description and various links. Version 0.4.0 Drop support of Python 3.5, add support of Python 3.9. Don’t crash on empty :not() selectors. New code structure, new packaging, new documentation. Version 0.3.0 Drop Python2 support. Improve packaging and testing.
This commit is contained in:
parent
86674e176f
commit
f46cce78b2
4 changed files with 30 additions and 24 deletions
|
@ -1,6 +1,6 @@
|
|||
# $NetBSD: Makefile,v 1.5 2019/09/12 15:22:36 adam Exp $
|
||||
# $NetBSD: Makefile,v 1.6 2021/04/28 08:52:17 adam Exp $
|
||||
|
||||
DISTNAME= cssselect2-0.2.2
|
||||
DISTNAME= cssselect2-0.4.1
|
||||
PKGNAME= ${PYPKGPREFIX}-${DISTNAME}
|
||||
CATEGORIES= textproc python
|
||||
MASTER_SITES= ${MASTER_SITE_PYPI:=c/cssselect2/}
|
||||
|
@ -11,6 +11,7 @@ COMMENT= CSS selectors for Python ElementTree
|
|||
LICENSE= modified-bsd
|
||||
|
||||
DEPENDS+= ${PYPKGPREFIX}-tinycss2-[0-9]*:../../textproc/py-tinycss2
|
||||
DEPENDS+= ${PYPKGPREFIX}-webencodings-[0-9]*:../../textproc/py-webencodings
|
||||
TEST_DEPENDS+= ${PYPKGPREFIX}-test-cov-[0-9]*:../../devel/py-test-cov
|
||||
TEST_DEPENDS+= ${PYPKGPREFIX}-test-flake8-[0-9]*:../../devel/py-test-flake8
|
||||
TEST_DEPENDS+= ${PYPKGPREFIX}-test-isort-[0-9]*:../../devel/py-test-isort
|
||||
|
@ -18,5 +19,10 @@ TEST_DEPENDS+= ${PYPKGPREFIX}-test-runner-[0-9]*:../../devel/py-test-runner
|
|||
|
||||
USE_LANGUAGES= # none
|
||||
|
||||
PYTHON_VERSIONS_INCOMPATIBLE= 27
|
||||
|
||||
do-test:
|
||||
cd ${WRKSRC} && ${SETENV} ${TEST_ENV} pytest-${PYVERSSUFFIX} tests
|
||||
|
||||
.include "../../lang/python/egg.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
@comment $NetBSD: PLIST,v 1.1 2017/09/02 14:58:45 kleink Exp $
|
||||
@comment $NetBSD: PLIST,v 1.2 2021/04/28 08:52:17 adam Exp $
|
||||
${PYSITELIB}/${EGG_INFODIR}/PKG-INFO
|
||||
${PYSITELIB}/${EGG_INFODIR}/SOURCES.txt
|
||||
${PYSITELIB}/${EGG_INFODIR}/dependency_links.txt
|
||||
|
@ -7,28 +7,12 @@ ${PYSITELIB}/${EGG_INFODIR}/top_level.txt
|
|||
${PYSITELIB}/cssselect2/__init__.py
|
||||
${PYSITELIB}/cssselect2/__init__.pyc
|
||||
${PYSITELIB}/cssselect2/__init__.pyo
|
||||
${PYSITELIB}/cssselect2/_compat.py
|
||||
${PYSITELIB}/cssselect2/_compat.pyc
|
||||
${PYSITELIB}/cssselect2/_compat.pyo
|
||||
${PYSITELIB}/cssselect2/compiler.py
|
||||
${PYSITELIB}/cssselect2/compiler.pyc
|
||||
${PYSITELIB}/cssselect2/compiler.pyo
|
||||
${PYSITELIB}/cssselect2/parser.py
|
||||
${PYSITELIB}/cssselect2/parser.pyc
|
||||
${PYSITELIB}/cssselect2/parser.pyo
|
||||
${PYSITELIB}/cssselect2/tests/LICENSE
|
||||
${PYSITELIB}/cssselect2/tests/__init__.py
|
||||
${PYSITELIB}/cssselect2/tests/__init__.pyc
|
||||
${PYSITELIB}/cssselect2/tests/__init__.pyo
|
||||
${PYSITELIB}/cssselect2/tests/content.xhtml
|
||||
${PYSITELIB}/cssselect2/tests/ids.html
|
||||
${PYSITELIB}/cssselect2/tests/invalid_selectors.json
|
||||
${PYSITELIB}/cssselect2/tests/make_valid_selectors_json.sh
|
||||
${PYSITELIB}/cssselect2/tests/shakespeare.html
|
||||
${PYSITELIB}/cssselect2/tests/test_cssselect2.py
|
||||
${PYSITELIB}/cssselect2/tests/test_cssselect2.pyc
|
||||
${PYSITELIB}/cssselect2/tests/test_cssselect2.pyo
|
||||
${PYSITELIB}/cssselect2/tests/valid_selectors.json
|
||||
${PYSITELIB}/cssselect2/tree.py
|
||||
${PYSITELIB}/cssselect2/tree.pyc
|
||||
${PYSITELIB}/cssselect2/tree.pyo
|
||||
|
|
|
@ -1,6 +1,7 @@
|
|||
$NetBSD: distinfo,v 1.3 2019/09/12 15:22:36 adam Exp $
|
||||
$NetBSD: distinfo,v 1.4 2021/04/28 08:52:17 adam Exp $
|
||||
|
||||
SHA1 (cssselect2-0.2.2.tar.gz) = 13b61c17b5fbd5215c0711fd5b5904c842623565
|
||||
RMD160 (cssselect2-0.2.2.tar.gz) = 5ff084628a84c85e3aef56dddbd9a1455adc9dc6
|
||||
SHA512 (cssselect2-0.2.2.tar.gz) = 1f11077c6e28f52a1c370c1f3d5fa1156f74b390298323889230304ede6c23a2f2b78c63026f5d84e67518a21fc8df3484577bc77fcf19cb97a84c2a7f28d355
|
||||
Size (cssselect2-0.2.2.tar.gz) = 31764 bytes
|
||||
SHA1 (cssselect2-0.4.1.tar.gz) = c3b2eb50fbab39ab3887ff246a7fbdb7bbfa5ffe
|
||||
RMD160 (cssselect2-0.4.1.tar.gz) = 530efcdcd5c6ca5ebe359807557a9f1ca496aef7
|
||||
SHA512 (cssselect2-0.4.1.tar.gz) = feafeec3dbe3157ee452d94cd391a09cfcb48ca8bd1563c117c77c9ceb01102c4989611ede39e433ec25d3ddda98a94c4589ccb290b79c729683e673763b42ac
|
||||
Size (cssselect2-0.4.1.tar.gz) = 32756 bytes
|
||||
SHA1 (patch-setup.py) = 4a5a26801f3ebc2bfb1b87be7fcd76d9d31ab2fc
|
||||
|
|
15
textproc/py-cssselect2/patches/patch-setup.py
Normal file
15
textproc/py-cssselect2/patches/patch-setup.py
Normal file
|
@ -0,0 +1,15 @@
|
|||
$NetBSD: patch-setup.py,v 1.1 2021/04/28 08:52:17 adam Exp $
|
||||
|
||||
Use setuptools.
|
||||
|
||||
--- setup.py.orig 2021-04-28 08:48:09.000000000 +0000
|
||||
+++ setup.py
|
||||
@@ -1,7 +1,7 @@
|
||||
#!/usr/bin/env python
|
||||
# setup.py generated by flit for tools that don't yet use PEP 517
|
||||
|
||||
-from distutils.core import setup
|
||||
+from setuptools import setup
|
||||
|
||||
packages = \
|
||||
['cssselect2']
|
Loading…
Reference in a new issue