include "config.h" in debug.cc so that ifdef HAVE_VASPRINTF actually works.

fixes a compile problem on macppc (where it attempts va_list assignment
otherwise.)
This commit is contained in:
mrg 2004-04-04 06:45:00 +00:00
parent be4d58b714
commit f48d35d92c
2 changed files with 14 additions and 1 deletions

View file

@ -1,7 +1,8 @@
$NetBSD: distinfo,v 1.21 2004/03/09 11:11:15 markd Exp $
$NetBSD: distinfo,v 1.22 2004/04/04 06:45:00 mrg Exp $
SHA1 (arts-1.2.1.tar.bz2) = 8a81234dd2122bee981cc4df08ad0f3f591699f2
Size (arts-1.2.1.tar.bz2) = 1039479 bytes
SHA1 (patch-aa) = ff582ade3d9913440cd20d92b342a5357991f555
SHA1 (patch-ab) = 73c4ec5360ce671f69b6de4e226cda9478d098ee
SHA1 (patch-ac) = de22843493a184f4aa8c20e011aa2a73ad794728
SHA1 (patch-af) = 9a130ccd7f56656bb55e2c5edf223c38c69be591

View file

@ -0,0 +1,12 @@
$NetBSD: patch-aa,v 1.5 2004/04/04 06:45:00 mrg Exp $
--- mcop/debug.cc.orig 2003-10-14 05:59:41.000000000 +1000
+++ mcop/debug.cc 2004-04-04 16:22:41.000000000 +1000
@@ -24,6 +24,7 @@
*/
#include "debug.h"
+#include "config.h"
#include <stdlib.h>
#include <stdarg.h>
#include <stdio.h>