Fix build on (at least RHEL 5.6). Tested (and no change) on NetBSD 5.99.51
This commit is contained in:
parent
34fd7e7c69
commit
f48db337a9
5 changed files with 39 additions and 22 deletions
|
@ -1,4 +1,4 @@
|
|||
# $NetBSD: Makefile.common,v 1.2 2011/04/27 08:48:59 adam Exp $
|
||||
# $NetBSD: Makefile.common,v 1.3 2011/05/06 16:21:25 abs Exp $
|
||||
#
|
||||
# used by databases/mysql55-client/Makefile
|
||||
# used by databases/mysql55-server/Makefile
|
||||
|
@ -66,6 +66,7 @@ CMAKE_ARGS+= -DWITH_LIBEDIT=OFF
|
|||
CMAKE_ARGS+= -DWITH_READLINE=OFF
|
||||
CMAKE_ARGS+= -DDEFAULT_CHARSET=${MYSQL_CHARSET:Q}
|
||||
CMAKE_ARGS+= -DWITH_EXTRA_CHARSETS=${MYSQL_EXTRA_CHARSET:Q}
|
||||
BROKEN_READLINE_DETECTION= yes # At least on RHEL 5.6
|
||||
|
||||
# MySQL 5 depends on builtin functions enabled with i486 and later with GCC.
|
||||
.if ${OPSYS} == "NetBSD" && !empty(MACHINE_ARCH:Mi386)
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
# $NetBSD: Makefile,v 1.1.1.1 2011/04/25 21:12:13 adam Exp $
|
||||
# $NetBSD: Makefile,v 1.2 2011/05/06 16:21:16 abs Exp $
|
||||
|
||||
PKGNAME= ${DISTNAME:S/-/-server-/}
|
||||
SVR4_PKGNAME= mysqs
|
||||
|
@ -28,7 +28,11 @@ PLIST.embedded= yes
|
|||
#PLIST.ndb= yes
|
||||
#.endif
|
||||
|
||||
PLIST_VARS+= embedded ndb
|
||||
PLIST_VARS+= embedded ndb auth_socket
|
||||
|
||||
.if ${OPSYS} == "Linux"
|
||||
PLIST.auth_socket= yes
|
||||
.endif
|
||||
|
||||
PTHREAD_OPTS+= require
|
||||
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
@comment $NetBSD: PLIST,v 1.1.1.1 2011/04/25 21:12:15 adam Exp $
|
||||
@comment $NetBSD: PLIST,v 1.2 2011/05/06 16:21:16 abs Exp $
|
||||
bin/innochecksum
|
||||
bin/my_print_defaults
|
||||
bin/myisam_ftdump
|
||||
|
@ -18,6 +18,7 @@ info/mysql.info
|
|||
lib/libmysqlservices.a
|
||||
lib/mysql/plugin/adt_null.so
|
||||
lib/mysql/plugin/auth.so
|
||||
${PLIST.auth_socket}lib/mysql/plugin/auth_socket.so
|
||||
lib/mysql/plugin/auth_test_plugin.so
|
||||
lib/mysql/plugin/ha_archive.so
|
||||
lib/mysql/plugin/ha_blackhole.so
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: distinfo,v 1.3 2011/03/28 16:00:07 drochner Exp $
|
||||
$NetBSD: distinfo,v 1.4 2011/05/06 16:27:04 abs Exp $
|
||||
|
||||
SHA1 (Python-2.7.1.tar.bz2) = fbe1894322ff91b80726e269c97454f4129fc2a3
|
||||
RMD160 (Python-2.7.1.tar.bz2) = 3ce59305f6cd3fb320a53771d0ea01ec0687005f
|
||||
|
@ -9,7 +9,7 @@ SHA1 (patch-ad) = de730b9f5a5efb56afa8bed05824b5f6579242ec
|
|||
SHA1 (patch-ae) = ff6d8c6164fe3c6dc4fb33d88eb8a49d5c5442f6
|
||||
SHA1 (patch-ah) = 8e9ee44c7a054f1387b6d8ef8dbe9c1b8dc8d891
|
||||
SHA1 (patch-al) = 2c6a578b62dfba45b2ba01a6b004f1d8feee0fe2
|
||||
SHA1 (patch-am) = c0a72af7c9827a9107fb7d1862febd487b9b5c83
|
||||
SHA1 (patch-am) = 760ed52308b31043bbf28528adf2a99f2420d85b
|
||||
SHA1 (patch-an) = 6098fbf0fc31422196cc40d3a227934523db11ca
|
||||
SHA1 (patch-ao) = 2061473e5e672b4cc38d91c5d8f885cb361a35b3
|
||||
SHA1 (patch-au) = 700dc128833af755f3ea08c4db79c127453b12e6
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: patch-am,v 1.1.1.1 2011/02/22 08:52:01 obache Exp $
|
||||
$NetBSD: patch-am,v 1.2 2011/05/06 16:27:04 abs Exp $
|
||||
|
||||
Disabled modules for normal build:
|
||||
bsddb
|
||||
|
@ -19,7 +19,7 @@ headers and libraries from the system.
|
|||
|
||||
Build the 1.85 compat module all the time against the BDB version of choice.
|
||||
|
||||
--- setup.py.orig 2010-06-27 12:36:16.000000000 +0000
|
||||
--- setup.py.orig 2010-10-31 16:40:21.000000000 +0000
|
||||
+++ setup.py
|
||||
@@ -21,7 +21,7 @@ from distutils.spawn import find_executa
|
||||
COMPILED_WITH_PYDEBUG = hasattr(sys, 'gettotalrefcount')
|
||||
|
@ -49,7 +49,7 @@ Build the 1.85 compat module all the time against the BDB version of choice.
|
|||
|
||||
# Add paths specified in the environment variables LDFLAGS and
|
||||
# CPPFLAGS for header and library files.
|
||||
@@ -681,9 +687,7 @@ class PyBuildExt(build_ext):
|
||||
@@ -692,9 +698,7 @@ class PyBuildExt(build_ext):
|
||||
if krb5_h:
|
||||
ssl_incs += krb5_h
|
||||
ssl_libs = find_library_file(self.compiler, 'ssl',lib_dirs,
|
||||
|
@ -60,7 +60,7 @@ Build the 1.85 compat module all the time against the BDB version of choice.
|
|||
|
||||
if (ssl_incs is not None and
|
||||
ssl_libs is not None):
|
||||
@@ -798,172 +802,6 @@ class PyBuildExt(build_ext):
|
||||
@@ -809,172 +813,6 @@ class PyBuildExt(build_ext):
|
||||
else:
|
||||
raise ValueError("unknown major BerkeleyDB version", major)
|
||||
|
||||
|
@ -233,7 +233,7 @@ Build the 1.85 compat module all the time against the BDB version of choice.
|
|||
# The sqlite interface
|
||||
sqlite_setup_debug = False # verbose debug prints from this script?
|
||||
|
||||
@@ -1079,31 +917,12 @@ class PyBuildExt(build_ext):
|
||||
@@ -1090,31 +928,12 @@ class PyBuildExt(build_ext):
|
||||
# we do not build this one. Otherwise this build will pick up
|
||||
# the more recent berkeleydb's db.h file first in the include path
|
||||
# when attempting to compile and it will fail.
|
||||
|
@ -270,23 +270,34 @@ Build the 1.85 compat module all the time against the BDB version of choice.
|
|||
|
||||
dbm_order = ['gdbm']
|
||||
# The standard Unix dbm module:
|
||||
@@ -1162,14 +981,11 @@ class PyBuildExt(build_ext):
|
||||
if db_incs is not None:
|
||||
print "building dbm using bdb"
|
||||
dbmext = Extension('dbm', ['dbmmodule.c'],
|
||||
@@ -1170,18 +989,14 @@ class PyBuildExt(build_ext):
|
||||
libraries = gdbm_libs)
|
||||
break
|
||||
elif cand == "bdb":
|
||||
- if db_incs is not None:
|
||||
- print "building dbm using bdb"
|
||||
- dbmext = Extension('dbm', ['dbmmodule.c'],
|
||||
- library_dirs=dblib_dir,
|
||||
- runtime_library_dirs=dblib_dir,
|
||||
- include_dirs=db_incs,
|
||||
define_macros=[
|
||||
('HAVE_BERKDB_H', None),
|
||||
('DB_DBM_HSEARCH', None),
|
||||
],
|
||||
- define_macros=[
|
||||
- ('HAVE_BERKDB_H', None),
|
||||
- ('DB_DBM_HSEARCH', None),
|
||||
- ],
|
||||
- libraries=dblibs)
|
||||
+ libraries=["db"])
|
||||
break
|
||||
- break
|
||||
+ print "building dbm using bdb"
|
||||
+ dbmext = Extension('dbm', ['dbmmodule.c'],
|
||||
+ define_macros=[
|
||||
+ ('HAVE_BERKDB_H', None),
|
||||
+ ('DB_DBM_HSEARCH', None),
|
||||
+ ],
|
||||
+ libraries=["db"])
|
||||
+ break
|
||||
if dbmext is not None:
|
||||
exts.append(dbmext)
|
||||
@@ -2032,9 +1848,9 @@ def main():
|
||||
else:
|
||||
@@ -2043,9 +1858,9 @@ def main():
|
||||
ext_modules=[Extension('_struct', ['_struct.c'])],
|
||||
|
||||
# Scripts to install
|
||||
|
|
Loading…
Reference in a new issue