Update to 1.3.0, provided by Antoine Reilles in PR 28993:

* Changes since 1.3.0-rc2-beta2
** new format option %f
This options displays the frame number the window is in or a space if
it is not in a window.

** Super modifier changed from S to s. S is now the shift modifier

* Changes since 1.3.0-rc2-beta1
** New command 'set'
set replaces the def* commands. For example 'defwinliststyle column'
is now 'set winliststyle column'.

The old def* commands now alias to their 'set' version.

* Changes since 1.3.0-rc1
** Top level keymap
The keymap named 'top' is now a top level keymap. No prefix key need
be pressed to access its bindings. In fact, the prefix key is now a
binding in the 'top' keymap.

** hsplit and vsplit switched
To be compatible with emacs these command names have been
switched. The bindings are the same but custom scripts and aliases
will have to make the switch.

** new command defframesels
Allow you to customize the keys used to select frames with fselect.

** Xinerama support
Each xinerama screen is handled as X11 screens normally are. The only
different is that each xinerama screen can select from all the
managed windows.

** focuslast finds the last focused frame among all screens

** fselect selects from frames in all screens

** new command-line option --file
Used to specify an alternate configuration file.

* Changes since 1.3.0-beta3
** new configure option --disable-history

** new commands readkey, newkmap, delkmap, definekey
These commands operate on the new feature: keymaps. They allow you to
have nested keymaps.

* Changes since 1.3.0-beta2
** new command gdelete
Delete a group.

** contrib/allwindows.sh script
A script that lists all groups and the windows in each group.

* Changes since 1.2.2
** Workspace script
rpws is an installed script that adds workspaces to ratpoison. Look at
contrib/rpws for instructions on how to use it.

** new commands addhook and remhook
There are now hooks for various operations.

** Completions
You can now type Tab and get completions on window names, group names,
and colon commands.

** Line editing capabilities
You can now go forward a word, backward a char, delete a word, etc.

** New commands gnewbg, gselect, groups, gmove, and gmerge
These commands allow further manipulation of window groups.

** shell commands return status
If a command the user executed (with the exec command) returns with a
non-zero exit status, the command and exit status are reported in a
message.

** new commands gnew, gnext, gprev
Window are now part of groups. There can be more than one group.
This commit is contained in:
wiz 2005-03-19 15:24:31 +00:00
parent 09463f695a
commit f546a465a8
4 changed files with 55 additions and 9 deletions

View file

@ -1,18 +1,20 @@
# $NetBSD: Makefile,v 1.13 2004/04/17 20:46:28 zuntum Exp $
# $NetBSD: Makefile,v 1.14 2005/03/19 15:24:31 wiz Exp $
#
DISTNAME= ratpoison-1.2.2
DISTNAME= ratpoison-1.3.0
CATEGORIES= wm
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=ratpoison/}
MASTER_SITES= http://savannah.nongnu.org/download/ratpoison/
MAINTAINER= tech-pkg@NetBSD.org
HOMEPAGE= http://ratpoison.sourceforge.net/
HOMEPAGE= http://www.nongnu.org/ratpoison/
COMMENT= Simple window manager with no fat library dependencies
USE_BUILDLINK3= YES
USE_X11= YES
GNU_CONFIGURE= YES
USE_GNU_READLINE= YES
INFO_FILES= ratpoison.info
.include "../../devel/readline/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

View file

@ -1,13 +1,18 @@
@comment $NetBSD: PLIST,v 1.5 2004/03/11 14:23:49 seb Exp $
@comment $NetBSD: PLIST,v 1.6 2005/03/19 15:24:31 wiz Exp $
bin/ratpoison
bin/rpws
man/man1/ratpoison.1
share/doc/ratpoison/AUTHORS
share/doc/ratpoison/COPYING
share/doc/ratpoison/ChangeLog
share/doc/ratpoison/NEWS
share/doc/ratpoison/README
share/ratpoison/allwindows.sh
share/ratpoison/clickframe.pl
share/ratpoison/genrpbindings
share/ratpoison/ratpoison.el
share/ratpoison/rpshowall.sh
share/ratpoison/rpws
share/ratpoison/split.sh
@dirrm share/ratpoison
@dirrm share/doc/ratpoison

View file

@ -1,5 +1,6 @@
$NetBSD: distinfo,v 1.6 2005/02/23 18:43:55 wiz Exp $
$NetBSD: distinfo,v 1.7 2005/03/19 15:24:31 wiz Exp $
SHA1 (ratpoison-1.2.2.tar.gz) = 67a62739448fe5015af4a3fd8bf9e6e62674ccd7
RMD160 (ratpoison-1.2.2.tar.gz) = 2bc558f4575f2a77f308e13f3f3d236e09b6a416
Size (ratpoison-1.2.2.tar.gz) = 271298 bytes
SHA1 (ratpoison-1.3.0.tar.gz) = 410a95d853fcd9f8ad55e83bf2324dcd6bf13a27
RMD160 (ratpoison-1.3.0.tar.gz) = 386f600abbf80b83e221b75c51b5fa0b9dc88f7a
Size (ratpoison-1.3.0.tar.gz) = 309754 bytes
SHA1 (patch-aa) = bde514f93185a6f0dc3a32f64408f8efe562c08a

View file

@ -0,0 +1,38 @@
$NetBSD: patch-aa,v 1.1 2005/03/19 15:24:31 wiz Exp $
--- contrib/rpws.orig 2005-01-28 17:32:12.000000000 +0100
+++ contrib/rpws 2005-01-28 17:32:22.000000000 +0100
@@ -1,4 +1,4 @@
-#!/bin/bash
+#!/bin/sh
#
# Workspaces for ratpoison
# Copyright (C) 2003 Shawn Betts
@@ -80,7 +80,7 @@
ws_restore ()
{
ws_save
- if [ $1 == 1 ]; then
+ if [ $1 = 1 ]; then
rp_call gselect default
else
rp_call gselect ws$1
@@ -104,15 +104,15 @@
echo boom >/tmp/boom
-if [ -z $@ ]; then
+if test $# -ne 1; then
echo "Usage:"
echo "$0 -i -- initialize the workspaces"
echo "$0 -b -- setup some key bindings"
echo "$0 <n> -- Switch to workspace n"
else
- if [ $1 == -i ]; then
+ if test $1 = -i ; then
ws_init
- elif [ $1 == -b ]; then
+ elif test $1 = -b ; then
ws_bindings
else
ws_restore $1