Changes 0.5.0:

- Allow /redirect-to to work with multiple methods
- Allow MD5 or SHA-256 to be chosen as algorithms for HTTP Digest Auth
- Set a 10MB limit on /drip
This commit is contained in:
adam 2017-05-31 08:36:33 +00:00
parent 345b8a0514
commit f547ab3f7f
3 changed files with 13 additions and 13 deletions

View file

@ -1,12 +1,12 @@
# $NetBSD: Makefile,v 1.1 2016/01/02 10:45:30 wiz Exp $
# $NetBSD: Makefile,v 1.2 2017/05/31 08:36:33 adam Exp $
DISTNAME= httpbin-0.4.0
DISTNAME= httpbin-0.5.0
PKGNAME= ${PYPKGPREFIX}-${DISTNAME}
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_PYPI:=h/httpbin/}
MAINTAINER= pkgsrc-users@NetBSD.org
HOMEPAGE= https://pypi.python.org/pypi/httpbin
HOMEPAGE= https://github.com/Runscope/httpbin/
COMMENT= HTTP Request and Response Service
LICENSE= mit

View file

@ -1,7 +1,7 @@
$NetBSD: distinfo,v 1.1 2016/01/02 10:45:30 wiz Exp $
$NetBSD: distinfo,v 1.2 2017/05/31 08:36:33 adam Exp $
SHA1 (httpbin-0.4.0.tar.gz) = 2415bec07d808de14a51777ef2495176872a4bcb
RMD160 (httpbin-0.4.0.tar.gz) = 51586401656539904d7ab34ba6df84f7de19585e
SHA512 (httpbin-0.4.0.tar.gz) = ce239c7c2a7715dce340f04aab417b0c73773e9ff6b33edb81540abc63be9c861c4386d1310e9ae46dcdeeff24a6b71b7b93d9b2120cb1533e7da2c10f177830
Size (httpbin-0.4.0.tar.gz) = 88000 bytes
SHA1 (patch-README.rst) = 858c6885424c8111448a68d8bd7e1159f79c8d96
SHA1 (httpbin-0.5.0.tar.gz) = e434179b0e3fda9d89f5b18d97a6ce06fd2339f2
RMD160 (httpbin-0.5.0.tar.gz) = 270d1c43b67f74968f09e09fa1fee97a9ae3ebc6
SHA512 (httpbin-0.5.0.tar.gz) = 1e13db87058b056b2ab228bbb67a835d1ac999efb8fbbcdc07f07f6e55e82ec5fe731f177210e107759f4d87d64f7e5e2219a1fb89bf17d2cda331c6b91490b8
Size (httpbin-0.5.0.tar.gz) = 88698 bytes
SHA1 (patch-README.rst) = 2fbfd9d70d8fd7c97d51412043548bd9d4527ae2

View file

@ -1,11 +1,11 @@
$NetBSD: patch-README.rst,v 1.1 2016/01/02 10:45:30 wiz Exp $
$NetBSD: patch-README.rst,v 1.2 2017/05/31 08:36:33 adam Exp $
Avoid UTF-8 characters to let setup.py run in ASCII locale.
https://github.com/Runscope/httpbin/issues/269
--- README.rst.orig 2015-10-22 19:02:45.000000000 +0000
--- README.rst.orig 2016-08-15 11:29:46.000000000 +0000
+++ README.rst
@@ -40,8 +40,8 @@ Endpoint
@@ -41,8 +41,8 @@ Endpoint
`/basic-auth/:user/:passwd`_ Challenges HTTPBasic Auth.
`/hidden-basic-auth/:user/:passwd`_ 404'd BasicAuth.
`/digest-auth/:qop/:user/:passwd`_ Challenges HTTP Digest Auth.
@ -13,6 +13,6 @@ https://github.com/Runscope/httpbin/issues/269
-`/delay/:n`_ Delays responding for *n* 10 seconds.
+`/stream/:n`_ Streams *n* -- 100 lines.
+`/delay/:n`_ Delays responding for *n* -- 10 seconds.
`/drip`_ Drips data over a duration after an optional initial delay, then (optionally) returns with the given status code.
`/drip`_ Drips up to 10MB data over a duration after an optional initial delay, then (optionally) returns with the given status code.
`/range/:n`_ Streams *n* bytes, and allows specifying a *Range* header to select a subset of the data. Accepts a *chunk\_size* and request *duration* parameter.
`/html`_ Renders an HTML Page.