Oops, not user-destdir support.
* switch to simply depend on wish. * instead of replaceing prefix with subst, pass to install script. * then avoid intaractive installation.
This commit is contained in:
parent
d0da6bc70e
commit
f56b1862ef
3 changed files with 8 additions and 37 deletions
|
@ -1,4 +1,4 @@
|
|||
# $NetBSD: Makefile,v 1.12 2010/09/26 08:47:59 obache Exp $
|
||||
# $NetBSD: Makefile,v 1.13 2010/09/26 09:31:13 obache Exp $
|
||||
#
|
||||
|
||||
DISTNAME= zircon-1.18.245
|
||||
|
@ -11,27 +11,16 @@ HOMEPAGE= http://catless.ncl.ac.uk/Programs/Zircon/
|
|||
COMMENT= X11 interface to Internet Relay Chat
|
||||
LICENSE= original-bsd
|
||||
|
||||
DEPENDS+= tk>=8.3.2:../../x11/tk
|
||||
|
||||
PKG_DESTDIR_SUPPORT= user-destdir
|
||||
|
||||
INTERACTIVE_STAGE= install
|
||||
NO_CONFIGURE= yes
|
||||
NO_BUILD= yes
|
||||
|
||||
SUBST_CLASSES+= prefix
|
||||
SUBST_STAGE.prefix= post-patch
|
||||
SUBST_FILES.prefix= installer/unix.tcl
|
||||
SUBST_VARS.prefix= PREFIX
|
||||
USE_TOOLS+= wish:run
|
||||
|
||||
do-install:
|
||||
@${ECHO} ""
|
||||
@${ECHO} "Please just click <Install> and <Quit> to ensure proper installation."
|
||||
@${ECHO} ""
|
||||
@( cd ${WRKSRC} && ./installZircon )
|
||||
@${INSTALL_DATA_DIR} ${PREFIX}/share/doc/zircon
|
||||
@( cd ${WRKSRC} && ./installZircon -b ${PREFIX}/bin -l ${PREFIX}/share/zircon -w ${WISH} -g)
|
||||
@${INSTALL_DATA_DIR} ${DESTDIR}${PREFIX}/share/doc/zircon
|
||||
.for file in BUGS COPYRIGHT FAQ MANUAL MIRRORS README.ONS README.load README.look README.prefs TODO
|
||||
@${INSTALL_DATA} ${WRKSRC}/doc/${file} ${PREFIX}/share/doc/zircon
|
||||
@${INSTALL_DATA} ${WRKSRC}/doc/${file} ${DESTDIR}${PREFIX}/share/doc/zircon
|
||||
.endfor
|
||||
|
||||
.include "../../mk/bsd.pkg.mk"
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
$NetBSD: distinfo,v 1.4 2010/09/26 08:47:59 obache Exp $
|
||||
$NetBSD: distinfo,v 1.5 2010/09/26 09:31:13 obache Exp $
|
||||
|
||||
SHA1 (zircon-1.18.245.tar.gz) = 3e6ce951111e7a71b6c2fcfba2cd40405a632386
|
||||
RMD160 (zircon-1.18.245.tar.gz) = aac489bff6b0834eaa984b632f89141b915d1a8f
|
||||
Size (zircon-1.18.245.tar.gz) = 326469 bytes
|
||||
SHA1 (patch-aa) = 4e0ce6d30338fbd23e6e24c59db0df9cb3279b40
|
||||
SHA1 (patch-aa) = 1f7c108a66906636d76bd200eb39207591bac4dc
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: patch-aa,v 1.2 2010/09/26 08:48:00 obache Exp $
|
||||
$NetBSD: patch-aa,v 1.3 2010/09/26 09:31:13 obache Exp $
|
||||
|
||||
--- installer/unix.tcl-orig Wed Mar 25 11:36:03 1998
|
||||
+++ installer/unix.tcl Sat Sep 5 20:42:47 1998
|
||||
|
@ -27,21 +27,3 @@ $NetBSD: patch-aa,v 1.2 2010/09/26 08:48:00 obache Exp $
|
|||
SCO {-G}
|
||||
OSF1 {-shared -expect_unresolved}
|
||||
Linux {-shared}
|
||||
@@ -149,7 +151,7 @@
|
||||
#
|
||||
proc getLib {} {
|
||||
global Lib
|
||||
- switch {} $Lib {set Lib /usr/local/lib/zircon}
|
||||
+ switch {} $Lib {set Lib @PREFIX@/share/zircon}
|
||||
}
|
||||
#
|
||||
proc getWish {} {
|
||||
@@ -175,7 +177,7 @@
|
||||
return
|
||||
}
|
||||
}
|
||||
- set Bin /usr/local/bin
|
||||
+ set Bin @PREFIX@/bin
|
||||
}
|
||||
#
|
||||
proc getCC {} {
|
||||
|
|
Loading…
Reference in a new issue