Remove calls to LWP::Debug as they have been deprecated in p5-libwww.
Bump PKGREVISION.
This commit is contained in:
parent
ffcecb7abe
commit
f57323cff3
3 changed files with 51 additions and 3 deletions
|
@ -1,8 +1,8 @@
|
|||
# $NetBSD: Makefile,v 1.3 2008/10/19 19:19:17 he Exp $
|
||||
# $NetBSD: Makefile,v 1.4 2009/02/24 10:53:02 markd Exp $
|
||||
|
||||
DISTNAME= LWP-Authen-Negotiate-0.06
|
||||
PKGNAME= p5-${DISTNAME}
|
||||
PKGREVISION= 1
|
||||
PKGREVISION= 2
|
||||
CATEGORIES= perl5 www
|
||||
MASTER_SITES= ${MASTER_SITE_PERL_CPAN:=LWP/}
|
||||
|
||||
|
|
|
@ -1,5 +1,6 @@
|
|||
$NetBSD: distinfo,v 1.1.1.1 2006/05/15 12:02:34 markd Exp $
|
||||
$NetBSD: distinfo,v 1.2 2009/02/24 10:53:02 markd Exp $
|
||||
|
||||
SHA1 (LWP-Authen-Negotiate-0.06.tar.gz) = 1fed13477279b70148816c26a286071c0df68ba8
|
||||
RMD160 (LWP-Authen-Negotiate-0.06.tar.gz) = 1b1aff09c01e39749f8fdbeec8cc01e6414c0105
|
||||
Size (LWP-Authen-Negotiate-0.06.tar.gz) = 4701 bytes
|
||||
SHA1 (patch-aa) = 555448adef31ac665bf34525a00699967b7b0ada
|
||||
|
|
47
www/p5-LWP-Authen-Negotiate/patches/patch-aa
Normal file
47
www/p5-LWP-Authen-Negotiate/patches/patch-aa
Normal file
|
@ -0,0 +1,47 @@
|
|||
$NetBSD: patch-aa,v 1.1 2009/02/24 10:53:02 markd Exp $
|
||||
|
||||
Remove LWP::Debug calls as they have been deprecated
|
||||
|
||||
--- lib/LWP/Authen/Negotiate.pm.orig 2006-03-08 09:09:25.000000000 +1300
|
||||
+++ lib/LWP/Authen/Negotiate.pm
|
||||
@@ -34,7 +34,6 @@ use GSSAPI 0.18;
|
||||
|
||||
sub authenticate
|
||||
{
|
||||
- LWP::Debug::debug("authenticate() version $VERSION called");
|
||||
my ($class,$ua,$proxy,$auth_param,$response,$request,$arg,$size) = @_;
|
||||
|
||||
my $uri = URI->new($request->uri);
|
||||
@@ -50,7 +49,6 @@ sub authenticate
|
||||
# in case of broken DNS or /etc/hosts
|
||||
# or missing Kerberosprincipal for target system
|
||||
#
|
||||
- LWP::Debug::debug("target hostname $targethost");
|
||||
$status = GSSAPI::Name->import(
|
||||
$target,
|
||||
join( '@', 'HTTP', $targethost ),
|
||||
@@ -60,7 +58,6 @@ sub authenticate
|
||||
$status = $target->display( $tname );
|
||||
last TRY if ( $status->major != GSS_S_COMPLETE );
|
||||
|
||||
- LWP::Debug::debug("GSSAPI servicename $tname");
|
||||
my $auth_header = $proxy ? 'Proxy-Authorization'
|
||||
: 'Authorization';
|
||||
|
||||
@@ -92,7 +89,6 @@ sub authenticate
|
||||
undef, $otoken, undef, undef);
|
||||
if ( $status->major == GSS_S_COMPLETE
|
||||
or $status->major == GSS_S_CONTINUE_NEEDED ) {
|
||||
- LWP::Debug::debug( 'successfull $ctx->init()');
|
||||
my $referral = $request->clone;
|
||||
$referral->header( $auth_header => "Negotiate ".encode_base64($otoken,""));
|
||||
return $ua->request( $referral, $arg, $size, $response );
|
||||
@@ -102,8 +98,6 @@ sub authenticate
|
||||
# this is the errorhandler,
|
||||
# the try block is normally leaved via return
|
||||
#
|
||||
- LWP::Debug::debug( $status->generic_message());
|
||||
- LWP::Debug::debug( $status->specific_message() );
|
||||
return $response;
|
||||
|
||||
}
|
Loading…
Reference in a new issue