Initial import of gramofile-1.6 into the Packages Collection. With
thanks to Steve Woodford for the nudge. GramoFile is able to record hours of CD quality music, split long sound files in separate tracks, and remove ticks and pops from recordings. It can be used for ripping audio from vinyl LPs. + Integrated sound recording and playback (with customized versions of brec(1) and bplay(1) by David Monro); + Handling of large sound files up to a few GB; + Signal peak level meter during recording; + Playback of user-specifiable parts of sound files; + Signal processing through application of `filters'; + Nine filters (filter types, actually) are supplied, new ones can be added fairly easily; + Multiple filters can be used, in random order, in one single run - even multiple instances of the same filter; + Most filters can be fine-tuned through a number of parameters (independent of each filter instance); + A large sound file containing an entire side of a gramophone record can be split into separate sound files, one for each track; + Signal processing and track splitting are performed simultaneously; + Text mode user interface with a windows-like look and `feel'; + Sound files of the familiar .wav type are used
This commit is contained in:
parent
32a3078990
commit
f5977d58bd
5 changed files with 89 additions and 0 deletions
21
audio/gramofile/DESCR
Normal file
21
audio/gramofile/DESCR
Normal file
|
@ -0,0 +1,21 @@
|
|||
GramoFile is able to record hours of CD quality music, split long
|
||||
sound files in separate tracks, and remove ticks and pops from
|
||||
recordings. It can be used for ripping audio from vinyl LPs.
|
||||
|
||||
+ Integrated sound recording and playback (with customized versions of
|
||||
brec(1) and bplay(1) by David Monro);
|
||||
+ Handling of large sound files up to a few GB;
|
||||
+ Signal peak level meter during recording;
|
||||
+ Playback of user-specifiable parts of sound files;
|
||||
+ Signal processing through application of `filters';
|
||||
+ Nine filters (filter types, actually) are supplied, new ones can be
|
||||
added fairly easily;
|
||||
+ Multiple filters can be used, in random order, in one single run - even
|
||||
multiple instances of the same filter;
|
||||
+ Most filters can be fine-tuned through a number of parameters
|
||||
(independent of each filter instance);
|
||||
+ A large sound file containing an entire side of a gramophone record can
|
||||
be split into separate sound files, one for each track;
|
||||
+ Signal processing and track splitting are performed simultaneously;
|
||||
+ Text mode user interface with a windows-like look and `feel';
|
||||
+ Sound files of the familiar .wav type are used
|
18
audio/gramofile/Makefile
Normal file
18
audio/gramofile/Makefile
Normal file
|
@ -0,0 +1,18 @@
|
|||
# $NetBSD: Makefile,v 1.1.1.1 2004/07/04 22:35:40 agc Exp $
|
||||
#
|
||||
|
||||
DISTNAME= gramofile-1.6
|
||||
CATEGORIES= audio
|
||||
MASTER_SITES= http://panic.et.tudelft.nl/~costar/gramofile/
|
||||
|
||||
MAINTAINER= tech-pkg@NetBSD.org
|
||||
HOMEPAGE= http://panic.et.tudelft.nl/~costar/gramofile/
|
||||
COMMENT= Tool for ripping audio from vinyl
|
||||
|
||||
ALL_TARGET= gramofile
|
||||
|
||||
USE_BUILDLINK3= yes
|
||||
USE_GNU_TOOLS+= make
|
||||
|
||||
.include "../../mk/curses.buildlink3.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
1
audio/gramofile/PLIST
Normal file
1
audio/gramofile/PLIST
Normal file
|
@ -0,0 +1 @@
|
|||
@comment $NetBSD: PLIST,v 1.1.1.1 2004/07/04 22:35:40 agc Exp $
|
5
audio/gramofile/distinfo
Normal file
5
audio/gramofile/distinfo
Normal file
|
@ -0,0 +1,5 @@
|
|||
$NetBSD: distinfo,v 1.1.1.1 2004/07/04 22:35:40 agc Exp $
|
||||
|
||||
SHA1 (gramofile-1.6.tar.gz) = 6e5365d9e04801725be694fefcff5fc10ea2f912
|
||||
Size (gramofile-1.6.tar.gz) = 108596 bytes
|
||||
SHA1 (patch-aa) = 204d1879eca0d2ae9a8426d3f06f8b4f2a97b213
|
44
audio/gramofile/patches/patch-aa
Normal file
44
audio/gramofile/patches/patch-aa
Normal file
|
@ -0,0 +1,44 @@
|
|||
$NetBSD: patch-aa,v 1.1.1.1 2004/07/04 22:35:40 agc Exp $
|
||||
|
||||
--- Makefile 2004/07/02 20:20:40 1.1
|
||||
+++ Makefile 2004/07/02 20:24:26
|
||||
@@ -18,23 +18,29 @@
|
||||
|
||||
########## CHOOSE YOUR ARCHITECTURE: (NOTE: also see bplaysrc/Makefile!)
|
||||
|
||||
+OS= $(shell uname -s)
|
||||
+
|
||||
+ifeq ($(OS), "Linux")
|
||||
# For Linux (and maybe others), use these:
|
||||
CFLAGS = -Wall -O2 -DTURBO_MEDIAN -DTURBO_BUFFER
|
||||
DEPS = $(OBJS) makebplay
|
||||
LIBS = -lncurses -lm
|
||||
COPY_A = -a
|
||||
-
|
||||
+else
|
||||
+ifeq ($(OS), "NetBSD")
|
||||
# For FreeBSD (and maybe others), use these:
|
||||
-#CFLAGS = -Wall -O2 -DTURBO_MEDIAN -DTURBO_BUFFER
|
||||
-#DEPS = $(OBJS) makebplay
|
||||
-#LIBS = -lncurses -lm
|
||||
-#COPY_A = -p
|
||||
-
|
||||
+CFLAGS = -Wall -O2 -DTURBO_MEDIAN -DTURBO_BUFFER
|
||||
+DEPS = $(OBJS) makebplay
|
||||
+LIBS = -lncurses -lm
|
||||
+COPY_A = -p
|
||||
+else
|
||||
# For IRIX (and maybe others), use these:
|
||||
-#CFLAGS = -Wall -O2 -DTURBO_MEDIAN -DTURBO_BUFFER -DSWAP_ENDIAN -DOLD_CURSES
|
||||
-#DEPS = $(OBJS)
|
||||
-#LIBS = -lcurses -lm
|
||||
-#COPY_A = -a
|
||||
+CFLAGS = -Wall -O2 -DTURBO_MEDIAN -DTURBO_BUFFER -DSWAP_ENDIAN -DOLD_CURSES
|
||||
+DEPS = $(OBJS)
|
||||
+LIBS = -lcurses -lm
|
||||
+COPY_A = -a
|
||||
+endif
|
||||
+endif
|
||||
|
||||
##########
|
||||
|
Loading…
Reference in a new issue