Replaced by vorbis-tools & friends.

This commit is contained in:
wiz 2001-03-16 10:13:06 +00:00
parent 0f0bccfe17
commit f59b346776
11 changed files with 0 additions and 153 deletions

View file

@ -1,35 +0,0 @@
# $NetBSD: Makefile,v 1.8 2001/03/15 21:04:44 wiz Exp $
#
DISTNAME= vorbis_nightly_cvs-20000818
PKGNAME= vorbis-20000818
CATEGORIES= audio
# daily snapshot (vorbis-nightly-cvs.tgz) is copied into "LOCAL_PORTS"
# so that we can get a version of certain date
MASTER_SITES= ${MASTER_SITE_LOCAL}
#MASTER_SITES= http://www.xiph.org/ogg/vorbis/download/
EXTRACT_SUFX= .tgz
MAINTAINER= packages@netbsd.org
HOMEPAGE= http://www.vorbis.com/
COMMENT= Encoder/decoder for Ogg Vorbis audio coding format
.if !exists(/usr/include/getopt.h)
DEPENDS+= libgetopt>=1.3:../../devel/libgetopt
LDFLAGS+= -Wl,-R${LOCALBASE}/lib -L${LOCALBASE}/lib -lgetopt
.endif
CONFLICTS= vorbis-tools-*
WRKSRC= ${WRKDIR}/vorbis
GNU_CONFIGURE= YES
CFLAGS+= -I${LOCALBASE}/include
CONFIGURE_ENV+= LIBS="${LDFLAGS} ${LIBS} -lossaudio"
post-build:
(cd ${WRKSRC}/vorbis-tools; ${MAKE})
do-install:
(cd ${WRKSRC}/vorbis-tools; ${MAKE} ${INSTALL_TARGET})
.include "../../mk/bsd.pkg.mk"

View file

@ -1,3 +0,0 @@
$NetBSD: md5,v 1.1.1.1 2000/08/17 16:56:18 itojun Exp $
MD5 (vorbis_nightly_cvs-20000818.tgz) = 04529d6cecda5af99d779bf7c95d3f8e

View file

@ -1,8 +0,0 @@
$NetBSD: patch-sum,v 1.4 2000/08/19 07:50:01 itojun Exp $
MD5 (patch-aa) = 5e7630fde5544c3b338f06f1eada4d2b
MD5 (patch-ab) = 6aab3996a1f1d4ce5ba98adbd598b006
MD5 (patch-ac) = 29233001e06a15c473019089b16a0a86
MD5 (patch-ae) = 9f19ec346c10bbc7918bbbf7caedce18
MD5 (patch-af) = 8629ab5dfe631b255bcd7a0e3dc9bcf9
MD5 (patch-ag) = 518115aa1615ed810d33f8a27e81a641

View file

@ -1,8 +0,0 @@
$NetBSD: patch-aa,v 1.1.1.1 2000/08/17 16:56:18 itojun Exp $
--- vorbis-tools/libao/configure.in- Fri Aug 18 01:32:17 2000
+++ vorbis-tools/libao/configure.in Fri Aug 18 01:32:31 2000
@@ -97,3 +97,3 @@
case $host in
- *-*-linux*|*-openbsd*|*-freebsd*)
+ *-*-linux*|*-openbsd*|*-freebsd*|*-netbsd*)
LIBAO_OBJS="$LIBAO_OBJS ao_oss.o"

View file

@ -1,8 +0,0 @@
$NetBSD: patch-ab,v 1.1.1.1 2000/08/17 16:56:18 itojun Exp $
--- vorbis-tools/libao/configure- Fri Aug 18 01:32:43 2000
+++ vorbis-tools/libao/configure Fri Aug 18 01:32:51 2000
@@ -1301,3 +1301,3 @@
case $host in
- *-*-linux*|*-openbsd*|*-freebsd*)
+ *-*-linux*|*-openbsd*|*-freebsd*|*-netbsd*)
LIBAO_OBJS="$LIBAO_OBJS ao_oss.o"

View file

@ -1,19 +0,0 @@
$NetBSD: patch-ac,v 1.2 2000/08/19 07:50:02 itojun Exp $
--- vorbis-tools/libao/ao_oss.c.orig Sat Jul 22 10:57:05 2000
+++ vorbis-tools/libao/ao_oss.c Sat Aug 19 11:27:04 2000
@@ -32,3 +32,3 @@
#include <math.h>
-#if defined(__OpenBSD__)
+#if defined(__OpenBSD__) || defined(__NetBSD__)
#include <soundcard.h>
@@ -70,4 +70,9 @@
- if (state->dev == NULL)
+ if (state->dev == NULL) {
+#ifdef __NetBSD__
+ state->dev = strdup("/dev/audio");
+#else
state->dev = strdup("/dev/dsp");
+#endif
+ }
}

View file

@ -1,16 +0,0 @@
$NetBSD: patch-ae,v 1.2 2000/08/18 16:31:24 itojun Exp $
--- configure.in.orig Tue Aug 15 18:09:31 2000
+++ configure.in Sat Aug 19 01:27:39 2000
@@ -36,5 +36,5 @@
#not everyone uses libm (eg, BeOS)
-#AC_CHECK_LIB(m, cos, LIBS="-lm"; AC_DEFINE(HAVE_LIBM), LIBS="")
+#AC_CHECK_LIB(m, cos, LIBS="$LIBS -lm"; AC_DEFINE(HAVE_LIBM))
# We no longer use config.h
-AC_CHECK_LIB(m, cos, LIBS="-lm", LIBS="")
+AC_CHECK_LIB(m, cos, LIBS="$LIBS -lm")
@@ -120,3 +120,3 @@
-CFLAGS=""
+#CFLAGS=""

View file

@ -1,21 +0,0 @@
$NetBSD: patch-af,v 1.2 2000/08/18 16:31:24 itojun Exp $
--- configure.orig Sat Jul 22 11:03:45 2000
+++ configure Sat Aug 19 01:27:56 2000
@@ -1030,3 +1030,3 @@
#not everyone uses libm (eg, BeOS)
-#AC_CHECK_LIB(m, cos, LIBS="-lm"; AC_DEFINE(HAVE_LIBM), LIBS="")
+#AC_CHECK_LIB(m, cos, LIBS="$LIBS -lm"; AC_DEFINE(HAVE_LIBM))
# We no longer use config.h
@@ -1067,6 +1067,5 @@
echo "$ac_t""yes" 1>&6
- LIBS="-lm"
+ LIBS="$LIBS -lm"
else
echo "$ac_t""no" 1>&6
-LIBS=""
fi
@@ -1286,3 +1285,3 @@
-CFLAGS=""
+#CFLAGS=""

View file

@ -1,12 +0,0 @@
$NetBSD: patch-ag,v 1.1 2000/08/19 07:50:02 itojun Exp $
--- vorbis-tools/mp3tovorbis.orig Thu Jun 15 08:07:47 2000
+++ vorbis-tools/mp3tovorbis Sat Aug 19 11:28:06 2000
@@ -1,2 +1,2 @@
-#!/bin/bash
+#! /bin/sh
@@ -42,3 +42,3 @@
echo "Encoding Ogg Vorbis stream using Vorbize..."
-$VORBIZE -w "$2" --artist "$ARTIST" --album "$ALBUM" --track "$TRACK" "$TEMPFILE"
+$VORBIZE -w "$2" --artist "$ARTIST" --album "$ALBUM" --title "$TRACK" "$TEMPFILE"

View file

@ -1,14 +0,0 @@
Vorbis is a general purpose audio and music encoding format
contemporary to MPEG-4's AAC and TwinVQ, the next generation beyond
MPEG audio layer 3. Unlike the MPEG sponsored formats (and other
proprietary formats such as RealAudio G2 and Windows' flavor of the
month), the Vorbis CODEC specification belongs to the public domain.
All the technical details are published and documented, and any
software entity may make full use of the format without royalty or
patent concerns.
This package contains libvorbis, an LGPLed software implementation of
the Vorbis specification by the Xiphophorus company
(http://www.xiph.org/), vorbisfile, an LGPLed convenience library
built on Vorbis designed to simplify common uses and a number of GPL
example programs, utilities and player plugins.

View file

@ -1,9 +0,0 @@
@comment $NetBSD: PLIST,v 1.1.1.1 2000/08/17 16:56:18 itojun Exp $
bin/vorbize
bin/mp3tovorbis
bin/ogg123
bin/vorbiscomment
bin/oggenc
man/man1/ogg123.1
man/man1/vorbize.1
man/man1/oggenc.1