Fix return types.
This commit is contained in:
parent
fbb70041d0
commit
f5ab4339c1
3 changed files with 56 additions and 8 deletions
|
@ -1,12 +1,12 @@
|
|||
$NetBSD: distinfo,v 1.9 2005/12/04 01:10:33 joerg Exp $
|
||||
$NetBSD: distinfo,v 1.10 2013/02/26 10:20:17 joerg Exp $
|
||||
|
||||
SHA1 (hanterm-3.1.6.tar.gz) = df2ff9ca8ddcee41baeaa8544a9983a1534e8b30
|
||||
RMD160 (hanterm-3.1.6.tar.gz) = 9d9c6c1d2eca9ad338140f1d8c418ed5e0e9548b
|
||||
Size (hanterm-3.1.6.tar.gz) = 323736 bytes
|
||||
SHA1 (patch-aa) = fc4be22d26913c4235e132a0282f910c2e5d616f
|
||||
SHA1 (patch-aa) = 3f7f1797c5d8425ff146692e9127b2bfe2c21a5f
|
||||
SHA1 (patch-ab) = 8b861979eeffc3e9763f4a2162c0e007c61f1a6c
|
||||
SHA1 (patch-ac) = 4c6b6efc12f2e1fba6eb577c65c94d701574353b
|
||||
SHA1 (patch-ad) = 50d6c38ab197e02a15b73bc7cfea476d22eaf961
|
||||
SHA1 (patch-ae) = 677db306b1f0d340d130194155a25458c3fd69c5
|
||||
SHA1 (patch-ae) = 14596ad1ae796679a6fcc9184df95df57f0beba6
|
||||
SHA1 (patch-af) = 7306a141331bbbe1e4ee4e46549834be2ae2cfa1
|
||||
SHA1 (patch-ag) = 50a7a71b7075ac57735189f43fd7e770ec9de81d
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: patch-aa,v 1.5 2005/12/04 01:10:33 joerg Exp $
|
||||
$NetBSD: patch-aa,v 1.6 2013/02/26 10:20:17 joerg Exp $
|
||||
|
||||
--- misc.c.orig 2002-01-09 00:41:11.000000000 +0000
|
||||
+++ misc.c
|
||||
|
@ -11,7 +11,17 @@ $NetBSD: patch-aa,v 1.5 2005/12/04 01:10:33 joerg Exp $
|
|||
#include <sys/param.h>
|
||||
#endif
|
||||
|
||||
@@ -913,7 +913,6 @@ char *SysErrorMsg (n)
|
||||
@@ -584,8 +584,7 @@ register TScreen *screen;
|
||||
update_logging();
|
||||
}
|
||||
|
||||
-CloseLog(screen)
|
||||
-register TScreen *screen;
|
||||
+void CloseLog(TScreen *screen)
|
||||
{
|
||||
if(!screen->logging || (screen->inhibit & I_LOG))
|
||||
return;
|
||||
@@ -913,7 +912,6 @@ char *SysErrorMsg (n)
|
||||
extern char *sys_errlist[];
|
||||
#endif
|
||||
#endif
|
||||
|
|
|
@ -1,8 +1,26 @@
|
|||
$NetBSD: patch-ae,v 1.2 2005/12/04 01:10:33 joerg Exp $
|
||||
$NetBSD: patch-ae,v 1.3 2013/02/26 10:20:17 joerg Exp $
|
||||
|
||||
--- main.c.orig 2002-01-09 00:41:11.000000000 +0000
|
||||
+++ main.c
|
||||
@@ -1527,7 +1527,8 @@ char **argv;
|
||||
@@ -583,6 +583,8 @@ static int tslot;
|
||||
#endif /* USE_SYSV_UTMP */
|
||||
static jmp_buf env;
|
||||
|
||||
+static void spawn (void);
|
||||
+
|
||||
char *ProgramName;
|
||||
Boolean sunFunctionKeys;
|
||||
|
||||
@@ -806,7 +808,7 @@ static char *message[] = {
|
||||
NULL};
|
||||
|
||||
#ifndef USE_TERMIOS
|
||||
-static remove_termcap_entry ();
|
||||
+static void remove_termcap_entry (char *, const char *);
|
||||
#endif
|
||||
|
||||
static int abbrev (tst, cmp)
|
||||
@@ -1527,7 +1529,8 @@ char **argv;
|
||||
if (ioctl (pty, FIONBIO, (char *)&mode) == -1) SysError (ERROR_FIONBIO);
|
||||
#endif /* USE_SYSV_TERMIO */
|
||||
|
||||
|
@ -12,7 +30,16 @@ $NetBSD: patch-ae,v 1.2 2005/12/04 01:10:33 joerg Exp $
|
|||
pty_mask = pty;
|
||||
X_mask = Xsocket;
|
||||
FD_ZERO(&Select_mask);
|
||||
@@ -3332,7 +3333,6 @@ static SIGNAL_T reapchild (n)
|
||||
@@ -1854,7 +1857,7 @@ void first_map_occurred ()
|
||||
#endif /* USE_HANDSHAKE else !USE_HANDSHAKE */
|
||||
|
||||
|
||||
-spawn ()
|
||||
+static void spawn (void)
|
||||
/*
|
||||
* Inits pty and tty and forks a login process.
|
||||
* Does not close fd Xsocket.
|
||||
@@ -3332,7 +3335,6 @@ static SIGNAL_T reapchild (n)
|
||||
consolepr(fmt,x0,x1,x2,x3,x4,x5,x6,x7,x8,x9)
|
||||
char *fmt;
|
||||
{
|
||||
|
@ -20,3 +47,14 @@ $NetBSD: patch-ae,v 1.2 2005/12/04 01:10:33 joerg Exp $
|
|||
extern char *SysErrorMsg();
|
||||
int oerrno;
|
||||
int f;
|
||||
@@ -3357,9 +3359,7 @@ char *fmt;
|
||||
|
||||
|
||||
#ifndef USE_TERMIOS
|
||||
-static remove_termcap_entry (buf, str)
|
||||
- char *buf;
|
||||
- char *str;
|
||||
+static void remove_termcap_entry (char *buf, const char *str)
|
||||
{
|
||||
register char *strinbuf;
|
||||
|
||||
|
|
Loading…
Reference in a new issue