fix glx option for amd64, and make it build without private patches

to *proto pkgs, from Blair Sadewitz
This commit is contained in:
drochner 2007-03-02 11:51:49 +00:00
parent 09ef0c0461
commit f5d0e6a3c8
4 changed files with 62 additions and 5 deletions

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.7 2007/02/26 17:51:16 drochner Exp $
# $NetBSD: Makefile,v 1.8 2007/03/02 11:51:49 drochner Exp $
DISTNAME= xorg-server-1.2.0
PKGREVISION= 1
@ -30,10 +30,18 @@ PKG_OPTIONS_VAR= PKG_OPTIONS.xorg-server
DISTFILES= ${DISTNAME}${EXTRACT_SUFX}
DISTFILES+= MesaLib-6.5.2.tar.bz2
SITES.MesaLib-6.5.2.tar.bz2= ${MASTER_SITE_SOURCEFORGE:=mesa3d/}
MESA_SRC= ${WRKDIR}/Mesa-6.5.2
CONFIGURE_ARGS+= --enable-glx
CONFIGURE_ARGS+= --with-mesa-source=${WRKDIR}/Mesa-6.5.2
BUILDLINK_API_DEPENDS.glproto+= glproto>=1.4.8nb1
BUILDLINK_API_DEPENDS.xf86driproto+= xf86driproto>=2.0.3nb1
CONFIGURE_ARGS+= --with-mesa-source=${MESA_SRC}
GLX_DEFINES+= -D__GLX_ALIGN64
CONFIGURE_ENV+= GLX_DEFINES=${GLX_DEFINES:M*:Q}
# glcore.h and dri_interface.h shipped with *proto are older than
# those in Mesa-6.5.2. Either patch them or trick the build into using
# the newer ones.
#BUILDLINK_API_DEPENDS.glproto+= glproto>=1.4.8nb1
#BUILDLINK_API_DEPENDS.xf86driproto+= xf86driproto>=2.0.3nb1
post-extract:
${LN} -s ${MESA_SRC:Q}/include/GL ${WRKSRC:Q}/GL/glx/GL
PLIST_SUBST+= GLX=""
.else
CONFIGURE_ARGS+= --disable-glx

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.7 2007/02/26 17:51:16 drochner Exp $
$NetBSD: distinfo,v 1.8 2007/03/02 11:51:49 drochner Exp $
SHA1 (MesaLib-6.5.2.tar.bz2) = ba860bb6ee57c02202342dfd5927464a068ea18f
RMD160 (MesaLib-6.5.2.tar.bz2) = 9a92d69110c066ae6734bcaafb78f222ac2df6d3
@ -6,9 +6,11 @@ Size (MesaLib-6.5.2.tar.bz2) = 3295166 bytes
SHA1 (xorg-server-1.2.0.tar.bz2) = 85fa0e8fa7d6bea6f1a73c66a57488ea68dffa17
RMD160 (xorg-server-1.2.0.tar.bz2) = 0bbc5ccb5cbbe7627b4f09f17848b188e8be2a50
Size (xorg-server-1.2.0.tar.bz2) = 6014596 bytes
SHA1 (patch-aa) = f72780165c9ecd3e9ab31d03c1b2d777290d09e2
SHA1 (patch-ab) = 115905eba320f294c68783bb704359d824460469
SHA1 (patch-ad) = 752235269f10daade0bf60665cccde39d1583064
SHA1 (patch-ae) = 84a9100ebd88c77022b4739dfa0a961fea78df2b
SHA1 (patch-af) = 6c58872798a30b31154dd7b167c84bf20ac417be
SHA1 (patch-da) = 73faacda1088304025c5e05f3d58edaf9ae1145f
SHA1 (patch-db) = 28913a094c8499536a71c8d4d7ca57a5efb25b39
SHA1 (patch-dc) = 75df6f37b1cbc9574adb5ee66cb84d0f5ebac853

View file

@ -0,0 +1,31 @@
$NetBSD: patch-aa,v 1.3 2007/03/02 11:51:49 drochner Exp $
--- hw/xfree86/os-support/bsd/bsd_init.c.orig 2007-01-23 00:39:16.000000000 -0500
+++ hw/xfree86/os-support/bsd/bsd_init.c
@@ -160,7 +160,9 @@ xf86OpenConsole()
xf86ConsOpen_t *driver;
#if defined (SYSCONS_SUPPORT) || defined (PCVT_SUPPORT)
int result;
+#ifdef __FreeBSD__
struct utsname uts;
+#endif
vtmode_t vtmode;
#endif
@@ -251,6 +253,7 @@ xf86OpenConsole()
#endif
/* otherwise fall through */
case PCVT:
+#if !(defined(__NetBSD__) && (__NetBSD_Version__ >= 200000000))
/*
* First activate the #1 VT. This is a hack to allow a server
* to be started while another one is active. There should be
@@ -265,7 +268,7 @@ xf86OpenConsole()
}
sleep(1);
}
-
+#endif
acquire_vt:
/*
* now get the VT

View file

@ -0,0 +1,16 @@
$NetBSD: patch-af,v 1.1 2007/03/02 11:51:49 drochner Exp $
--- hw/xfree86/os-support/bsd/i386_video.c.orig 2007-01-23 00:39:16.000000000 -0500
+++ hw/xfree86/os-support/bsd/i386_video.c
@@ -50,6 +50,11 @@
#include <machine/mtrr.h>
#include <machine/sysarch.h>
#include <sys/queue.h>
+#ifdef __x86_64__
+#define i386_set_mtrr x86_64_set_mtrr
+#define i386_get_mtrr x86_64_get_mtrr
+#define i386_iopl x86_64_iopl
+#endif
#endif
#if defined(__OpenBSD__) && defined(__amd64__)