lang/compiler-rt: llvm update
This commit is contained in:
parent
27ef7a761f
commit
f5d6858c44
4 changed files with 36 additions and 19 deletions
|
@ -1,7 +1,8 @@
|
|||
$NetBSD: distinfo,v 1.16 2022/02/03 20:38:39 adam Exp $
|
||||
$NetBSD: distinfo,v 1.17 2022/08/12 08:58:41 pin Exp $
|
||||
|
||||
BLAKE2s (compiler-rt-13.0.1.src.tar.xz) = f97d407951a05cdcffb43c4ec3c4dcfa3db117d1c79964c660697442e1e9bb9d
|
||||
SHA512 (compiler-rt-13.0.1.src.tar.xz) = 2cdc3d5cfe5fcf7eba497912ccaadcf33dbd2dd029840fbd54c861b24927e5f4dd494b1ecee1c6c8abbd21e1adf08c217448f408d75346147bac15000fe9ec29
|
||||
Size (compiler-rt-13.0.1.src.tar.xz) = 2290068 bytes
|
||||
SHA1 (patch-cmake_config-ix.cmake) = 50e38807363e9d4f18106bb2ff71f5247a24d764
|
||||
SHA1 (patch-lib_sanitizer__common_sanitizer__platform__limits__netbsd.cpp) = 8a09da1e6e4476f50cfd5e8034060c6a87bfa92c
|
||||
BLAKE2s (compiler-rt-14.0.6.src.tar.xz) = d2c279dadc7d3cd7f8c2999e918d410eaf7c74cfd16095c3db16bcdc83c30fb8
|
||||
SHA512 (compiler-rt-14.0.6.src.tar.xz) = c0e63071cb99bca837b83fd0e3597cf45cc635f73ab88a1ec48e863a1633f42bd402ea7c5130e8fa0f550b9574c1ecac1799b92b789565e4ead955cf60060907
|
||||
Size (compiler-rt-14.0.6.src.tar.xz) = 2327352 bytes
|
||||
SHA1 (patch-cmake_config-ix.cmake) = 40ee86393c0f9e26eeaa493c5312d2cabf4c2a58
|
||||
SHA1 (patch-lib_asan_CMakeLists.txt) = f91335b88c8c28a25d7dfada85769f799660f82a
|
||||
SHA1 (patch-lib_sanitizer__common_sanitizer__platform__limits__netbsd.cpp) = 8d9b35c02f0c8c10d7e7d3bf9935bd0ca3f5f448
|
||||
|
|
|
@ -1,10 +1,10 @@
|
|||
$NetBSD: patch-cmake_config-ix.cmake,v 1.4 2021/07/12 18:46:07 adam Exp $
|
||||
$NetBSD: patch-cmake_config-ix.cmake,v 1.5 2022/08/12 08:58:41 pin Exp $
|
||||
|
||||
Disable components that aren't ready for SunOS yet.
|
||||
|
||||
--- cmake/config-ix.cmake.orig 2021-04-06 16:38:18.000000000 +0000
|
||||
--- cmake/config-ix.cmake.orig 2022-06-22 16:46:24.000000000 +0000
|
||||
+++ cmake/config-ix.cmake
|
||||
@@ -646,7 +646,7 @@ set(COMPILER_RT_SANITIZERS_TO_BUILD all
|
||||
@@ -668,7 +668,7 @@ set(COMPILER_RT_SANITIZERS_TO_BUILD all
|
||||
list_replace(COMPILER_RT_SANITIZERS_TO_BUILD all "${ALL_SANITIZERS}")
|
||||
|
||||
if (SANITIZER_COMMON_SUPPORTED_ARCH AND NOT LLVM_USE_SANITIZER AND
|
||||
|
@ -13,7 +13,7 @@ Disable components that aren't ready for SunOS yet.
|
|||
(OS_NAME MATCHES "Windows" AND NOT CYGWIN AND
|
||||
(NOT MINGW OR CMAKE_CXX_COMPILER_ID MATCHES "Clang"))))
|
||||
set(COMPILER_RT_HAS_SANITIZER_COMMON TRUE)
|
||||
@@ -666,7 +666,7 @@ else()
|
||||
@@ -688,7 +688,7 @@ else()
|
||||
set(COMPILER_RT_HAS_ASAN FALSE)
|
||||
endif()
|
||||
|
||||
|
@ -22,7 +22,7 @@ Disable components that aren't ready for SunOS yet.
|
|||
set(COMPILER_RT_ASAN_HAS_STATIC_RUNTIME TRUE)
|
||||
else()
|
||||
set(COMPILER_RT_ASAN_HAS_STATIC_RUNTIME FALSE)
|
||||
@@ -716,7 +716,7 @@ else()
|
||||
@@ -738,7 +738,7 @@ else()
|
||||
endif()
|
||||
|
||||
if (PROFILE_SUPPORTED_ARCH AND NOT LLVM_USE_SANITIZER AND
|
||||
|
@ -31,7 +31,7 @@ Disable components that aren't ready for SunOS yet.
|
|||
set(COMPILER_RT_HAS_PROFILE TRUE)
|
||||
else()
|
||||
set(COMPILER_RT_HAS_PROFILE FALSE)
|
||||
@@ -730,7 +730,7 @@ else()
|
||||
@@ -763,7 +763,7 @@ else()
|
||||
endif()
|
||||
|
||||
if (COMPILER_RT_HAS_SANITIZER_COMMON AND UBSAN_SUPPORTED_ARCH AND
|
||||
|
|
16
lang/compiler-rt/patches/patch-lib_asan_CMakeLists.txt
Normal file
16
lang/compiler-rt/patches/patch-lib_asan_CMakeLists.txt
Normal file
|
@ -0,0 +1,16 @@
|
|||
$NetBSD: patch-lib_asan_CMakeLists.txt,v 1.1 2022/08/12 08:58:41 pin Exp $
|
||||
|
||||
Only use optimized asan code on Linux.
|
||||
https://github.com/llvm/llvm-project/issues/57086
|
||||
|
||||
--- lib/asan/CMakeLists.txt.orig 2022-06-22 16:46:24.000000000 +0000
|
||||
+++ lib/asan/CMakeLists.txt
|
||||
@@ -46,7 +46,7 @@ set(ASAN_STATIC_SOURCES
|
||||
asan_rtl_static.cpp
|
||||
)
|
||||
|
||||
-if (NOT WIN32 AND NOT APPLE)
|
||||
+if (LINUX)
|
||||
list(APPEND ASAN_STATIC_SOURCES
|
||||
asan_rtl_x86_64.S
|
||||
)
|
|
@ -1,10 +1,10 @@
|
|||
$NetBSD: patch-lib_sanitizer__common_sanitizer__platform__limits__netbsd.cpp,v 1.3 2021/07/12 18:46:07 adam Exp $
|
||||
$NetBSD: patch-lib_sanitizer__common_sanitizer__platform__limits__netbsd.cpp,v 1.4 2022/08/12 08:58:41 pin Exp $
|
||||
|
||||
urio and smb have been removed from NetBSD.
|
||||
|
||||
--- lib/sanitizer_common/sanitizer_platform_limits_netbsd.cpp.orig 2020-10-07 10:10:48.000000000 +0000
|
||||
--- lib/sanitizer_common/sanitizer_platform_limits_netbsd.cpp.orig 2022-06-22 16:46:24.000000000 +0000
|
||||
+++ lib/sanitizer_common/sanitizer_platform_limits_netbsd.cpp
|
||||
@@ -803,12 +803,14 @@ unsigned struct_session_op_sz = sizeof(s
|
||||
@@ -957,12 +957,14 @@ unsigned struct_session_op_sz = sizeof(s
|
||||
unsigned struct_sgttyb_sz = sizeof(sgttyb);
|
||||
unsigned struct_sioc_sg_req_sz = sizeof(sioc_sg_req);
|
||||
unsigned struct_sioc_vif_req_sz = sizeof(sioc_vif_req);
|
||||
|
@ -19,7 +19,7 @@ urio and smb have been removed from NetBSD.
|
|||
unsigned struct_spppauthcfg_sz = sizeof(spppauthcfg);
|
||||
unsigned struct_spppauthfailuresettings_sz = sizeof(spppauthfailuresettings);
|
||||
unsigned struct_spppauthfailurestats_sz = sizeof(spppauthfailurestats);
|
||||
@@ -833,7 +835,9 @@ unsigned struct_twe_drivecommand_sz = si
|
||||
@@ -987,7 +989,9 @@ unsigned struct_twe_drivecommand_sz = si
|
||||
unsigned struct_twe_paramcommand_sz = sizeof(twe_paramcommand);
|
||||
unsigned struct_twe_usercommand_sz = sizeof(twe_usercommand);
|
||||
unsigned struct_ukyopon_identify_sz = sizeof(ukyopon_identify);
|
||||
|
@ -29,7 +29,7 @@ urio and smb have been removed from NetBSD.
|
|||
unsigned struct_usb_alt_interface_sz = sizeof(usb_alt_interface);
|
||||
unsigned struct_usb_bulk_ra_wb_opt_sz = sizeof(usb_bulk_ra_wb_opt);
|
||||
unsigned struct_usb_config_desc_sz = sizeof(usb_config_desc);
|
||||
@@ -1422,8 +1426,10 @@ unsigned IOCTL_STICIO_RESET = STICIO_RES
|
||||
@@ -1576,8 +1580,10 @@ unsigned IOCTL_STICIO_RESET = STICIO_RES
|
||||
unsigned IOCTL_STICIO_STARTQ = STICIO_STARTQ;
|
||||
unsigned IOCTL_STICIO_STOPQ = STICIO_STOPQ;
|
||||
unsigned IOCTL_UKYOPON_IDENTIFY = UKYOPON_IDENTIFY;
|
||||
|
@ -40,7 +40,7 @@ urio and smb have been removed from NetBSD.
|
|||
unsigned IOCTL_USB_REQUEST = USB_REQUEST;
|
||||
unsigned IOCTL_USB_SETDEBUG = USB_SETDEBUG;
|
||||
unsigned IOCTL_USB_DISCOVER = USB_DISCOVER;
|
||||
@@ -1808,6 +1814,7 @@ unsigned IOCTL_SIOCCONNECTXDEL = SIOCCON
|
||||
@@ -1962,6 +1968,7 @@ unsigned IOCTL_SIOCCONNECTXDEL = SIOCCON
|
||||
unsigned IOCTL_SIOCSIFINFO_FLAGS = SIOCSIFINFO_FLAGS;
|
||||
unsigned IOCTL_SIOCAADDRCTL_POLICY = SIOCAADDRCTL_POLICY;
|
||||
unsigned IOCTL_SIOCDADDRCTL_POLICY = SIOCDADDRCTL_POLICY;
|
||||
|
@ -48,7 +48,7 @@ urio and smb have been removed from NetBSD.
|
|||
unsigned IOCTL_SMBIOC_OPENSESSION = SMBIOC_OPENSESSION;
|
||||
unsigned IOCTL_SMBIOC_OPENSHARE = SMBIOC_OPENSHARE;
|
||||
unsigned IOCTL_SMBIOC_REQUEST = SMBIOC_REQUEST;
|
||||
@@ -1815,6 +1822,7 @@ unsigned IOCTL_SMBIOC_SETFLAGS = SMBIOC_
|
||||
@@ -1969,6 +1976,7 @@ unsigned IOCTL_SMBIOC_SETFLAGS = SMBIOC_
|
||||
unsigned IOCTL_SMBIOC_LOOKUP = SMBIOC_LOOKUP;
|
||||
unsigned IOCTL_SMBIOC_READ = SMBIOC_READ;
|
||||
unsigned IOCTL_SMBIOC_WRITE = SMBIOC_WRITE;
|
||||
|
|
Loading…
Reference in a new issue