Update kscope to 1.6.0.

Changes since 1.5.0:
* Improved: Updated the documentation
* Improved: Implemented multiple-call nodes in the call-graph
* Improved: Workspace toolbar buttons re-arranged
* Improved: Hitting Enter in the "Open Project" dialogue's list of
  recent projects opens the selected project
* Bug fix: Handle file extensions correctly in the file list
* Bug fix: Avoid hanging status bar messages when a project is closed
* Bug fix: Prevent infinite loops in the file finder in the presence of
  recursive symbolic links
* Bug fix: Child windows should not disappear when dialogues are invoked
* Bug fix: Added padding to the call graph, to avoid chopped-off drawing
  of nodes close to the borders
* Bug fix: Honour the preferred font when drawing the graph
* Bug fix: Delete temporary dot files used for drawing graphs
* Bug fix: Save call-tree files when a project is closed
* Bug fix: Clean-up a project's directory name after it is created

Maintainer update by Martijn van Buul via PR 37701.
This commit is contained in:
rillig 2008-01-05 23:29:42 +00:00
parent e6e8900e3b
commit f5eab73fba
4 changed files with 17 additions and 23 deletions

View file

@ -1,8 +1,7 @@
# $NetBSD: Makefile,v 1.15 2007/11/30 21:55:05 wiz Exp $
# $NetBSD: Makefile,v 1.16 2008/01/05 23:29:42 rillig Exp $
#
DISTNAME= kscope-1.5.0
PKGREVISION= 2
DISTNAME= kscope-1.6.0
CATEGORIES= devel kde
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=kscope/}
@ -20,7 +19,7 @@ USE_LIBTOOL= yes
USE_LANGUAGES= c c++
post-build:
@${SED} -e "s,@LOCALBASE@,${LOCALBASE},g" \
sed -e "s,@LOCALBASE@,${LOCALBASE},g" \
${FILESDIR}/kscoperc > ${WRKDIR}/kscoperc
pre-install:
@ -34,4 +33,3 @@ pre-install:
.include "../../x11/kdelibs3/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

View file

@ -1,7 +1,9 @@
@comment $NetBSD: PLIST,v 1.5 2007/08/15 03:52:16 markd Exp $
@comment $NetBSD: PLIST,v 1.6 2008/01/05 23:29:42 rillig Exp $
bin/kscope
share/doc/kde/HTML/en/kscope/about.docbook
share/doc/kde/HTML/en/kscope/autocomp_dlg.png
share/doc/kde/HTML/en/kscope/bookmarks.docbook
share/doc/kde/HTML/en/kscope/bookmarks.png
share/doc/kde/HTML/en/kscope/call_graph.png
share/doc/kde/HTML/en/kscope/call_tree.png
share/doc/kde/HTML/en/kscope/common
@ -19,6 +21,7 @@ share/doc/kde/HTML/en/kscope/pref_opts.png
share/doc/kde/HTML/en/kscope/pref_progs.png
share/doc/kde/HTML/en/kscope/project_details.png
share/doc/kde/HTML/en/kscope/project_files.png
share/doc/kde/HTML/en/kscope/project_make.png
share/doc/kde/HTML/en/kscope/project_open.png
share/doc/kde/HTML/en/kscope/project_opts.png
share/doc/kde/HTML/en/kscope/project_types.png
@ -45,9 +48,15 @@ share/kde/apps/kscope/pics/query_locked.png
share/kde/apps/kscope/pics/query_unlocked.png
share/kde/apps/kscope/pics/tab_list.png
share/kde/config/kscoperc
@comment in kde: @dirrm share/kde/config
@dirrm share/kde/apps/kscope/pics
@dirrm share/kde/apps/kscope
@comment in kde: @dirrm share/kde/apps
@comment in kde: @dirrm share/kde/applnk/Development
@comment in kde: @dirrm share/icons/locolor/32x32/apps
@comment in kde: @dirrm share/icons/locolor/16x16/apps
@comment in hicolor-icon-theme: @dirrm share/icons/hicolor/32x32/apps
@comment in hicolor-icon-theme: @dirrm share/icons/hicolor/16x16/apps
@comment in hicolor-icon-theme: @dirrm share/icons/hicolor
@dirrm share/doc/kde/HTML/en/kscope
@comment in kde: @dirrm share/doc/kde/HTML/en

View file

@ -1,6 +1,5 @@
$NetBSD: distinfo,v 1.6 2007/08/30 19:49:00 joerg Exp $
$NetBSD: distinfo,v 1.7 2008/01/05 23:29:42 rillig Exp $
SHA1 (kscope-1.5.0.tar.gz) = 05f80c5bb7201aa8e4b40e6f068ed8b392012a54
RMD160 (kscope-1.5.0.tar.gz) = 7808ea0514efc0500259c97d0126fb7373041538
Size (kscope-1.5.0.tar.gz) = 1267274 bytes
SHA1 (patch-aa) = 7d398bc1d9e05f2670721bd02e8b479e6c3f3210
SHA1 (kscope-1.6.0.tar.gz) = 72e342243f475e69ccb46b40a28594c5ef0ea1ab
RMD160 (kscope-1.6.0.tar.gz) = bd9986a321504fbbc9f5613cf3af3f2c99569f49
Size (kscope-1.6.0.tar.gz) = 1988221 bytes

View file

@ -1,12 +0,0 @@
$NetBSD: patch-aa,v 1.1 2007/08/30 19:49:00 joerg Exp $
--- src/filesemaphore.cpp.orig 2007-08-30 19:18:52.000000000 +0000
+++ src/filesemaphore.cpp
@@ -29,6 +29,7 @@
#include <fcntl.h>
#include <errno.h>
#include <sys/mman.h>
+#include <sys/stat.h>
#include <qfileinfo.h>
#include "filesemaphore.h"