adapt to netbsd build. use /etc/trafshow, not ${PREFIX}/etc/trafshow for
systemwide config file.
This commit is contained in:
parent
368af1e917
commit
f602807cc5
6 changed files with 21 additions and 31 deletions
|
@ -1,36 +1,27 @@
|
|||
# New ports collection makefile for: trafshow
|
||||
# Date created: 25 September 1996
|
||||
# Whom: igor@zynaps.ru
|
||||
#
|
||||
# $NetBSD: Makefile,v 1.2 2000/08/11 05:42:15 itojun Exp $
|
||||
# $FreeBSD: ports/net/trafshow/Makefile,v 1.14 2000/06/28 12:53:15 alex Exp $
|
||||
#
|
||||
|
||||
PORTNAME= trafshow
|
||||
PORTVERSION= 3.1
|
||||
DISTNAME= trafshow-3.1
|
||||
CATEGORIES= net
|
||||
MASTER_SITES= ftp://ftp.nsk.su/pub/RinetSoftware/
|
||||
EXTRACT_SUFX= .tgz
|
||||
|
||||
MAINTAINER= jseger@FreeBSD.org
|
||||
MAINTAINER= packages@netbsd.org
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
.if ${OSVERSION} < 400010
|
||||
LIB_DEPENDS= ncurses.4:${PORTSDIR}/devel/ncurses
|
||||
.endif
|
||||
BUILD_DEPENDS+= autoreconf:../../devel/autoconf
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include/ncurses -I${LOCALBASE}/include" \
|
||||
LIBS="-L${LOCALBASE}/lib"
|
||||
ALL_TARGET= trafshow
|
||||
|
||||
MAN1= trafshow.1
|
||||
|
||||
post-patch:
|
||||
@${PERL} -pi -e "s|%%PREFIX%%|${PREFIX}|g" ${WRKSRC}/*.c
|
||||
pre-configure:
|
||||
cd ${WRKSRC} && autoreconf
|
||||
|
||||
do-install:
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/trafshow ${PREFIX}/bin
|
||||
${INSTALL_MAN} ${WRKSRC}/trafshow.1 ${PREFIX}/man/man1
|
||||
${INSTALL_DATA} ${WRKSRC}/.trafshow ${PREFIX}/etc/trafshow
|
||||
${MKDIR} ${PREFIX}/share/examples/trafshow
|
||||
${INSTALL_DATA} ${WRKSRC}/.trafshow \
|
||||
${PREFIX}/share/examples/trafshow/trafshow
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
.include "../../mk/bsd.pkg.mk"
|
||||
|
|
|
@ -1 +1,3 @@
|
|||
$NetBSD: md5,v 1.2 2000/08/11 05:42:17 itojun Exp $
|
||||
|
||||
MD5 (trafshow-3.1.tgz) = 085b99f160002a269b358aab1c5004f0
|
||||
|
|
4
net/trafshow/files/patch-sum
Normal file
4
net/trafshow/files/patch-sum
Normal file
|
@ -0,0 +1,4 @@
|
|||
$NetBSD: patch-sum,v 1.1 2000/08/11 05:42:17 itojun Exp $
|
||||
|
||||
MD5 (patch-af) = 87eb1ae01c745f4aa2e85cbcb506226b
|
||||
MD5 (patch-ag) = c62acae00e4d96231b3fbcddd5a15b42
|
|
@ -1,11 +0,0 @@
|
|||
--- color.c.orig Mon Jan 24 10:59:01 2000
|
||||
+++ color.c Mon Jan 24 10:57:36 2000
|
||||
@@ -336,7 +336,7 @@
|
||||
error(1, "init_color_mask: getpwuid");
|
||||
(void) sprintf(buf, "%s/.%s", pw->pw_dir, program_name);
|
||||
if ((fp = fopen(buf, "r")) == NULL) {
|
||||
- (void) strcpy(buf, "/etc/");
|
||||
+ (void) strcpy(buf, "%%PREFIX%%/etc/");
|
||||
(void) strcat(buf, program_name);
|
||||
if ((fp = fopen(buf, "r")) == NULL) return 0;
|
||||
}
|
|
@ -1,3 +1,5 @@
|
|||
$NetBSD: patch-af,v 1.2 2000/08/11 05:42:18 itojun Exp $
|
||||
|
||||
--- Makefile.in.orig Mon Aug 24 13:54:16 1998
|
||||
+++ Makefile.in Tue May 2 00:51:47 2000
|
||||
@@ -28,8 +28,8 @@
|
||||
|
|
|
@ -1,2 +1,4 @@
|
|||
bin/trafshow
|
||||
etc/trafshow
|
||||
man/man1/trafshow.1
|
||||
share/examples/trafshow/trafshow
|
||||
@dirrm share/examples/trafshow
|
||||
|
|
Loading…
Reference in a new issue