Updated lopster to 1.0.1

* new startup logo
* new button to remove transfers of offline users
* searches are now sent through the "unimportant" queue
  like sharing files.
* changed channel limit/level gui.
* made winmx queuing emulation configurable in preferences
* fixed bug that allowed users to bypass upload limit.
* fixed topic bug.
* Search history list now detachable, also some bugfixes in detach code.
* added support for napigator proxy info to be stored in config file
* added code to use the napigator proxy info from the config file
* new: subscription system
* userinfo is now saved to disk.
* access list is now viewable by user
* reduced hotlist tab to two columns
* now at max <per_user_limit> downloads are remotely queued per user
* new entry in user menu: Transfer Info
* support for Opera as browser
* bugfix in connection stuff
* GUI support for channel mode/limit/level
* changed search fields layout.
* added whois output to chat window.
* etc.
This commit is contained in:
martti 2002-01-18 13:39:03 +00:00
parent c34aa86bf7
commit f66bce88ff
7 changed files with 42 additions and 44 deletions

View file

@ -1,7 +1,7 @@
# $NetBSD: Makefile,v 1.3 2001/03/28 02:35:37 hubertf Exp $
# $NetBSD: Makefile,v 1.4 2002/01/18 13:39:03 martti Exp $
#
DISTNAME= lopster-0.9.8
DISTNAME= lopster-1.0.1
CATEGORIES= net
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=lopster/}

View file

@ -1,35 +1,41 @@
@comment $NetBSD: PLIST,v 1.1 2001/10/31 22:56:08 zuntum Exp $
@comment $NetBSD: PLIST,v 1.2 2002/01/18 13:39:03 martti Exp $
bin/lopster
lib/locale/de/LC_MESSAGES/lopster.mo
lib/locale/fr/LC_MESSAGES/lopster.mo
share/lopster/pixmaps/arrowd.xpm
share/lopster/pixmaps/arrowl.xpm
share/lopster/pixmaps/arrowr.xpm
share/lopster/pixmaps/arrowu.xpm
share/lopster/pixmaps/bug16b.xpm
share/lopster/pixmaps/book1.xpm
share/lopster/pixmaps/book2.xpm
share/lopster/pixmaps/bug.xpm
share/lopster/pixmaps/chat.xpm
share/lopster/pixmaps/d16x16.xpm
share/lopster/pixmaps/download.xpm
share/lopster/pixmaps/email.xpm
share/lopster/pixmaps/enemy.xpm
share/lopster/pixmaps/enemy2.xpm
share/lopster/pixmaps/folder.xpm
share/lopster/pixmaps/folder_blue.xpm
share/lopster/pixmaps/folder_open.xpm
share/lopster/pixmaps/forum.xpm
share/lopster/pixmaps/friend.xpm
share/lopster/pixmaps/home16b.xpm
share/lopster/pixmaps/hotlist.xpm
share/lopster/pixmaps/ignore.xpm
share/lopster/pixmaps/info.xpm
share/lopster/pixmaps/kfind.xpm
share/lopster/pixmaps/logo.jpg
share/lopster/pixmaps/library.xpm
share/lopster/pixmaps/logo.xpm
share/lopster/pixmaps/logo1.xpm
share/lopster/pixmaps/mail16b.xpm
share/lopster/pixmaps/mini-folder.xpm
share/lopster/pixmaps/notes16.xpm
share/lopster/pixmaps/project.xpm
share/lopster/pixmaps/search.xpm
share/lopster/pixmaps/server.xpm
share/lopster/pixmaps/speedgray.xpm
share/lopster/pixmaps/speedgreen.xpm
share/lopster/pixmaps/speedred.xpm
share/lopster/pixmaps/speedyellow.xpm
share/lopster/pixmaps/statistic.xpm
share/lopster/pixmaps/transfer.xpm
share/lopster/pixmaps/user.xpm
share/lopster/pixmaps/user1.xpm
share/lopster/pixmaps/user2.xpm
@dirrm share/lopster/pixmaps

View file

@ -1,8 +1,7 @@
$NetBSD: distinfo,v 1.2 2001/04/21 11:23:21 wiz Exp $
$NetBSD: distinfo,v 1.3 2002/01/18 13:39:04 martti Exp $
SHA1 (lopster-0.9.8.tar.gz) = 3e244d7b2aaccc32d296ca9c28ecadc24f71cf10
Size (lopster-0.9.8.tar.gz) = 434461 bytes
SHA1 (patch-aa) = af5318b45a71c703d54cafba457c0249abbe8653
SHA1 (patch-ab) = 7a33ce153f5cecc10e7899241d24c3c66f5f2d4a
SHA1 (patch-ac) = 08204be9c9d8279148a36c175763bf360587bc81
SHA1 (patch-ad) = 0ffba4b3a04ff6cf471158920165aac2bcaef65e
SHA1 (lopster-1.0.1.tar.gz) = 9e755607520b30dba823a53e5de66e9b980ebcbe
Size (lopster-1.0.1.tar.gz) = 554722 bytes
SHA1 (patch-ab) = 1bf060a5da4d24d07f114c9d548a6ba2a70b5870
SHA1 (patch-ac) = 018aceddd1fd21787854f5a6800164ee4997a166
SHA1 (patch-ad) = 65adaefcad366c6f18b024619570f5a0851ded7b

View file

@ -1,13 +0,0 @@
$NetBSD: patch-aa,v 1.2 2001/03/28 02:35:38 hubertf Exp $
--- src/resume.c.orig Tue Feb 13 22:03:14 2001
+++ src/resume.c
@@ -391,7 +391,7 @@
if (stat(resume->filename, &st) < 0) {
strcpy(text, _("not existent"));
} else {
- sprintf(text, "%lu", st.st_size);
+ sprintf(text, "%lu", (u_long)st.st_size);
}
gtk_ctree_node_set_text(ctree, node, 2, text);

View file

@ -1,8 +1,11 @@
$NetBSD: patch-ab,v 1.1 2001/03/28 02:35:38 hubertf Exp $
$NetBSD: patch-ab,v 1.2 2002/01/18 13:39:05 martti Exp $
--- src/handler.c.orig Tue Feb 13 17:14:20 2001
+++ src/handler.c
@@ -1,3 +1,6 @@
--- src/handler.c.orig Sun Nov 4 19:30:19 2001
+++ src/handler.c Fri Jan 18 14:21:12 2002
@@ -6,6 +6,9 @@
# include <config.h>
#endif
#include <sys/types.h>
+#ifdef __NetBSD__
+#include <sys/types.h>
+#endif

View file

@ -1,11 +1,14 @@
$NetBSD: patch-ac,v 1.1 2001/03/28 02:35:38 hubertf Exp $
$NetBSD: patch-ac,v 1.2 2002/01/18 13:39:05 martti Exp $
--- src/browse.c.orig Mon Feb 12 21:50:55 2001
+++ src/browse.c
@@ -1,3 +1,6 @@
--- src/browse.c.orig Wed Oct 31 19:52:26 2001
+++ src/browse.c Fri Jan 18 14:21:34 2002
@@ -4,6 +4,9 @@
#ifdef HAVE_CONFIG_H
# include <config.h>
+#ifndef __NetBSD_
+#include <sys/types.h>
+#endif
#include <sys/socket.h>
#endif
#include <sys/types.h>
#include <stdio.h>
#include <sys/socket.h>

View file

@ -1,8 +1,8 @@
$NetBSD: patch-ad,v 1.1 2001/03/28 02:35:38 hubertf Exp $
$NetBSD: patch-ad,v 1.2 2002/01/18 13:39:05 martti Exp $
--- Makefile.in.orig Tue Feb 13 23:58:32 2001
+++ Makefile.in
@@ -86,7 +86,7 @@
--- Makefile.in.orig Sun Nov 4 19:33:45 2001
+++ Makefile.in Fri Jan 18 14:21:55 2002
@@ -87,7 +87,7 @@
VERSION = @VERSION@
l = @l@