Update to unbound-1.0.2. Beside some minor bugfixes, this brings even
stricter filtering to defeat some additional DNS attacks and support for source address randomisation and optional capitalisation support. The former can be configured when multiple public IPs are present, the latter is considered experimental as a small number of servers doesn't support it.
This commit is contained in:
parent
b83afe4c29
commit
f6762be4b3
5 changed files with 19 additions and 43 deletions
|
@ -1,6 +1,6 @@
|
|||
# $NetBSD: Makefile,v 1.1.1.1 2008/05/26 22:36:56 joerg Exp $
|
||||
# $NetBSD: Makefile,v 1.2 2008/10/09 01:31:35 joerg Exp $
|
||||
|
||||
DISTNAME= unbound-1.0.0
|
||||
DISTNAME= unbound-1.0.2
|
||||
CATEGORIES= net
|
||||
MASTER_SITES= http://www.unbound.net/downloads/
|
||||
|
||||
|
@ -10,6 +10,10 @@ COMMENT= DNS resolver and recursive server
|
|||
|
||||
PKG_DESTDIR_SUPPORT= user-destdir
|
||||
|
||||
# Strictly speaking this is tar in gzip in gzip, but using bsdtar is
|
||||
# the easiest workaround.
|
||||
EXTRACT_USING= bsdtar
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
USE_LIBTOOL= yes
|
||||
USE_TOOLS+= gmake
|
||||
|
|
|
@ -1,8 +1,6 @@
|
|||
$NetBSD: distinfo,v 1.1.1.1 2008/05/26 22:36:56 joerg Exp $
|
||||
$NetBSD: distinfo,v 1.2 2008/10/09 01:31:35 joerg Exp $
|
||||
|
||||
SHA1 (unbound-1.0.0.tar.gz) = a837407d866f0918547c6122f8f654c219b4b51f
|
||||
RMD160 (unbound-1.0.0.tar.gz) = a08aff793c115f2fe285c6d1557bcca98e0c4dba
|
||||
Size (unbound-1.0.0.tar.gz) = 3554571 bytes
|
||||
SHA1 (patch-aa) = eb2e923f1970a0fafad44885619a0ea28a0aa155
|
||||
SHA1 (patch-ab) = baa658962ffa72efd11507f391f5ee4543266bc4
|
||||
SHA1 (patch-ac) = 11664d40b93f8cfb15f96e010b243f9909e5de5a
|
||||
SHA1 (unbound-1.0.2.tar.gz) = 93faa7b76cf7681b8c7b0c5187aaf84c36b6670b
|
||||
RMD160 (unbound-1.0.2.tar.gz) = 1e942505468f6ae4061b208914e9b7feed6ecff1
|
||||
Size (unbound-1.0.2.tar.gz) = 3597275 bytes
|
||||
SHA1 (patch-ac) = 05e1b84d9093ea6b2a5648117522fc288c611ba9
|
||||
|
|
|
@ -1,13 +0,0 @@
|
|||
$NetBSD: patch-aa,v 1.1.1.1 2008/05/26 22:36:56 joerg Exp $
|
||||
|
||||
--- configure.ac.orig 2008-05-26 22:39:40.000000000 +0200
|
||||
+++ configure.ac
|
||||
@@ -556,7 +556,7 @@ AC_SEARCH_LIBS([socket], [socket])
|
||||
AC_ARG_WITH(libevent, AC_HELP_STRING([--with-libevent=pathname],
|
||||
[use libevent (will check /usr/local /opt/local /usr/lib /usr/pkg /usr/sfw /usr or you can specify an explicit path). Slower, but allows use of large outgoing port ranges.]),
|
||||
[ ],[ withval="no" ])
|
||||
-if test x_$withval == x_yes -o x_$withval != x_no; then
|
||||
+if test x_$withval = x_yes -o x_$withval != x_no; then
|
||||
AC_MSG_CHECKING(for libevent)
|
||||
if test x_$withval = x_ -o x_$withval = x_yes; then
|
||||
withval="/usr/local /opt/local /usr/lib /usr/pkg /usr/sfw /usr"
|
|
@ -1,13 +0,0 @@
|
|||
$NetBSD: patch-ab,v 1.1.1.1 2008/05/26 22:36:56 joerg Exp $
|
||||
|
||||
--- configure.orig 2008-05-26 22:39:38.000000000 +0200
|
||||
+++ configure
|
||||
@@ -22125,7 +22125,7 @@ else
|
||||
withval="no"
|
||||
fi
|
||||
|
||||
-if test x_$withval == x_yes -o x_$withval != x_no; then
|
||||
+if test x_$withval = x_yes -o x_$withval != x_no; then
|
||||
{ echo "$as_me:$LINENO: checking for libevent" >&5
|
||||
echo $ECHO_N "checking for libevent... $ECHO_C" >&6; }
|
||||
if test x_$withval = x_ -o x_$withval = x_yes; then
|
|
@ -1,21 +1,21 @@
|
|||
$NetBSD: patch-ac,v 1.1.1.1 2008/05/26 22:36:56 joerg Exp $
|
||||
$NetBSD: patch-ac,v 1.2 2008/10/09 01:31:35 joerg Exp $
|
||||
|
||||
--- Makefile.in.orig 2008-05-14 09:34:02.000000000 +0200
|
||||
--- Makefile.in.orig 2008-07-17 10:45:12.000000000 +0200
|
||||
+++ Makefile.in
|
||||
@@ -70,10 +70,9 @@ UNITTEST_SRC=$(patsubst $(srcdir)/%,%, \
|
||||
@@ -71,10 +71,9 @@ UNITTEST_SRC=$(patsubst $(srcdir)/%,%, \
|
||||
testcode/readhex.c testcode/ldns-testpkts.c smallapp/worker_cb.c \
|
||||
$(COMMON_SRC)
|
||||
UNITTEST_OBJ=$(addprefix $(BUILD),$(UNITTEST_SRC:.c=.o)) $(COMPAT_OBJ)
|
||||
UNITTEST_OBJ=$(addprefix $(BUILD),$(UNITTEST_SRC:.c=.lo)) $(COMPAT_OBJ)
|
||||
-DAEMON_SRC=$(patsubst $(srcdir)/%,%, $(wildcard $(srcdir)/daemon/*.c)) \
|
||||
- $(COMMON_SRC)
|
||||
+DAEMON_SRC=$(patsubst $(srcdir)/%,%, $(wildcard $(srcdir)/daemon/*.c))
|
||||
DAEMON_OBJ=$(addprefix $(BUILD),$(DAEMON_SRC:.c=.o)) $(COMPAT_OBJ)
|
||||
DAEMON_OBJ=$(addprefix $(BUILD),$(DAEMON_SRC:.c=.lo)) $(COMPAT_OBJ)
|
||||
-CHECKCONF_SRC=smallapp/unbound-checkconf.c smallapp/worker_cb.c $(COMMON_SRC)
|
||||
+CHECKCONF_SRC=smallapp/unbound-checkconf.c smallapp/worker_cb.c
|
||||
CHECKCONF_OBJ=$(addprefix $(BUILD),$(CHECKCONF_SRC:.c=.o)) $(COMPAT_OBJ)
|
||||
CHECKCONF_OBJ=$(addprefix $(BUILD),$(CHECKCONF_SRC:.c=.lo)) $(COMPAT_OBJ)
|
||||
HOST_SRC=smallapp/unbound-host.c
|
||||
HOST_OBJ=$(addprefix $(BUILD),$(HOST_SRC:.c=.o)) $(COMPAT_OBJ)
|
||||
@@ -148,17 +147,17 @@ else
|
||||
HOST_OBJ=$(addprefix $(BUILD),$(HOST_SRC:.c=.lo)) $(COMPAT_OBJ)
|
||||
@@ -149,17 +148,17 @@ else
|
||||
ldnslib=
|
||||
endif
|
||||
|
||||
|
|
Loading…
Reference in a new issue