Ensure a version of grep is used which can handle the -F argument.

This commit is contained in:
sketch 2003-12-16 11:33:44 +00:00
parent 285f3a5771
commit f6c197ca04
4 changed files with 30 additions and 2 deletions

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.10 2003/12/04 04:35:25 jschauma Exp $
# $NetBSD: Makefile,v 1.11 2003/12/16 11:33:44 sketch Exp $
#
DISTNAME= xmlcatmgr-1.1
@ -16,6 +16,7 @@ USE_GNU_TOOLS= awk
MAKEFILE= Makefile.boot
MAKE_ENV+= BT_PREFIX="${PREFIX}"
MAKE_ENV+= BT_PROG_AWK="${AWK}"
MAKE_ENV+= BT_PROG_GREP="${GREP}"
MAKE_ENV+= BT_PROG_SH="${SH}"
MAKE_ENV+= BT_DIR_CATALOG="${PKG_SYSCONFDIR}/xml"
MAKE_ENV+= BT_INSTALL_DIR="${INSTALL_DATA_DIR}"

View file

@ -1,4 +1,6 @@
$NetBSD: distinfo,v 1.4 2003/10/13 12:12:57 jmmv Exp $
$NetBSD: distinfo,v 1.5 2003/12/16 11:33:44 sketch Exp $
SHA1 (xmlcatmgr-1.1.tar.gz) = 5dcc314b0d7fb3e385556f6da7236851883a931f
Size (xmlcatmgr-1.1.tar.gz) = 8142 bytes
SHA1 (patch-aa) = 5f04254791bb028020c36c0733964dbd386a935f
SHA1 (patch-ab) = 8430d53929e5df3e0d8c48e3b8123c00322f85b1

View file

@ -0,0 +1,13 @@
$NetBSD: patch-aa,v 1.1 2003/12/16 11:33:44 sketch Exp $
--- bin/sgml.sh.in.orig 2003-12-15 16:59:15.038448999 +0000
+++ bin/sgml.sh.in 2003-12-15 16:59:36.695886970 +0000
@@ -45,7 +45,7 @@
return
fi
- if grep -F \"$action_arg2\" $catalog >/dev/null; then
+ if @BT_PROG_GREP@ -F \"$action_arg2\" $catalog >/dev/null; then
err "entry already exists"
fi

View file

@ -0,0 +1,12 @@
$NetBSD: patch-ab,v 1.1 2003/12/16 11:33:44 sketch Exp $
--- Makefile.boot.orig 2003-12-15 17:08:29.900198509 +0000
+++ Makefile.boot 2003-12-15 17:09:18.226048672 +0000
@@ -17,6 +17,7 @@
SUBSTS= -e "s|@BT_PKG_NAME@|${BT_PKG_NAME}|g"
SUBSTS+= -e "s|@BT_PKG_VERSION@|${BT_PKG_VERSION}|g"
SUBSTS+= -e "s|@BT_PROG_AWK@|${BT_PROG_AWK}|g"
+SUBSTS+= -e "s|@BT_PROG_GREP@|${BT_PROG_GREP}|g"
SUBSTS+= -e "s|@BT_PROG_SH@|${BT_PROG_SH}|g"
SUBSTS+= -e "s|@BT_DIR_CATALOG@|${BT_DIR_CATALOG}|g"