Update to 0.7.0:

Overview of changes in libgpod 0.7.0
====================================

* support for iPod Nano 4th generation

This includes support for cover art.
Please note that this release DOES NOT support iPhones and iPod Touch
with firmware 2.x

* support for "sparse artwork" writing

This lets us write more compact artwork files to the iPod, which in turn makes
the UI more responsive (and saves disk space on the iPod).

* jump table support

These are the big letters that show up in the album/artist list when someone
quickly scrolls through them. Thanks a lot to Ian Stewart for implementing it.

* chapter data support

Chapter data allows large files (movies, audio books, podcasts) to be divided
into smaller sections.  Thanks to Michael Tiffany for this feature.

* improved timezone handling

This should now work up to 5G iPods, for newer iPods, libgpod will assume
timestamps are in UTC.

* translation updates

Thanks to all of our translators :)

* much more complete API doc

All of the public API is now documented with gtk-doc.

* simplification of the cover art handling API

The API for artwork for developers using libgpod should be more
straightforward, if things are missing, don't hesitate to get in touch
with us ;)

* extensive plist parser

In libgpod 0.6.0, libgpod got a very basic parser for the SysInfoExtended file
(which is a XML plist description). This parser was rewritten for this release
to parse the whole file. This parser depends on libxml2 but its compilation
will be disabled if libxml2 and its development headers can't be found.

* add mapping from iPod serial numbers to iPod models

The iPod serial number can be obtained programmatically, and its last 3 digits
are characteristic of an iPod (type, generation, color, capacity). libgpod
can now find out an iPod model using this serial number.

* portability improvements to windows and macosx

This is probably not perfect yet, but the goal is to improve it as much as
possible so don't hesitate to send bug reports if some things are still not
working. Thanks to the songbird project and Éric Lassauge.

* reworked handling of artwork formats

libgpod can now automatically use the artwork formats described in
SysInfoExtended even if the iPod model is unknown, this should make it possible
for libgpod to support artwork on newly released iPod models without the need
to upgrade.

* python bindings are more consistent with other python container objects

This enables testing whether a key exists in an object (e.g. "'title' in track")
as well as iterating over a Track or Photo object's keys, values, or items.

* bug fixes and code cleanup all over the place
This commit is contained in:
wiz 2009-01-25 11:40:39 +00:00
parent 723004231b
commit f6e611675c
4 changed files with 10 additions and 49 deletions

View file

@ -1,7 +1,6 @@
# $NetBSD: Makefile,v 1.7 2008/08/07 12:53:46 wiz Exp $
# $NetBSD: Makefile,v 1.8 2009/01/25 11:40:39 wiz Exp $
DISTNAME= libgpod-0.6.0
PKGREVISION= 1
DISTNAME= libgpod-0.7.0
CATEGORIES= audio
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=gtkpod/}
@ -21,6 +20,7 @@ USE_LIBTOOL= yes
BUILDLINK_API_DEPENDS.glib2+= glib2>=2.8.0
.include "../../devel/glib2/buildlink3.mk"
.include "../../devel/gettext-lib/buildlink3.mk"
.include "../../textproc/libxml2/buildlink3.mk"
.include "../../x11/gtk2/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

View file

@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.4 2007/11/29 18:47:28 wiz Exp $
@comment $NetBSD: PLIST,v 1.5 2009/01/25 11:40:39 wiz Exp $
include/gpod-1.0/gpod/itdb.h
lib/libgpod.la
lib/pkgconfig/libgpod-1.0.pc
@ -9,6 +9,7 @@ share/gtk-doc/html/libgpod/index.sgml
share/gtk-doc/html/libgpod/itunesdb.html
share/gtk-doc/html/libgpod/left.png
share/gtk-doc/html/libgpod/libgpod-Artwork.html
share/gtk-doc/html/libgpod/libgpod-Chapter-Data.html
share/gtk-doc/html/libgpod/libgpod-Device.html
share/gtk-doc/html/libgpod/libgpod-File-handling-functions.html
share/gtk-doc/html/libgpod/libgpod-Low-level-functions.html
@ -32,6 +33,7 @@ share/locale/it/LC_MESSAGES/libgpod.mo
share/locale/ja/LC_MESSAGES/libgpod.mo
share/locale/ro/LC_MESSAGES/libgpod.mo
share/locale/sv/LC_MESSAGES/libgpod.mo
share/locale/zh_CN/LC_MESSAGES/libgpod.mo
@dirrm share/gtk-doc/html/libgpod
@dirrm include/gpod-1.0/gpod
@dirrm include/gpod-1.0

View file

@ -1,6 +1,5 @@
$NetBSD: distinfo,v 1.5 2007/11/29 18:47:28 wiz Exp $
$NetBSD: distinfo,v 1.6 2009/01/25 11:40:39 wiz Exp $
SHA1 (libgpod-0.6.0.tar.gz) = 09b660324785cec122b5df62f1825ebd595c4ecc
RMD160 (libgpod-0.6.0.tar.gz) = 684ea4276cd2c1fbe4c415a8ac931d8777e8c2fb
Size (libgpod-0.6.0.tar.gz) = 843097 bytes
SHA1 (patch-aa) = 1b9bc0a84875d7aaf52a6e49ce9024fa4096250c
SHA1 (libgpod-0.7.0.tar.gz) = c8ed26ed81a85acf230b5e2065399b038ac00046
RMD160 (libgpod-0.7.0.tar.gz) = 0d0b0961231aa257767e11ba1e51f4eeea01f764
Size (libgpod-0.7.0.tar.gz) = 949630 bytes

View file

@ -1,40 +0,0 @@
$NetBSD: patch-aa,v 1.3 2007/11/29 18:47:28 wiz Exp $
--- configure.orig 2007-11-10 11:16:17.000000000 +0000
+++ configure
@@ -20379,7 +20379,7 @@ echo "$as_me: error: HAL support explici
{ (exit 1); exit 1; }; }
fi
- if test "x$enable_hal" == "xyes"; then
+ if test "x$enable_hal" = "xyes"; then
cat >>confdefs.h <<\_ACEOF
#define HAVE_HAL 1
@@ -22370,7 +22370,7 @@ echo $ECHO_N "checking whether to build
{ echo "$as_me:$LINENO: result: $with_python" >&5
echo "${ECHO_T}$with_python" >&6; }
- if test "X$with_python" == Xyes; then
+ if test "X$with_python" = Xyes; then
if test -z "$PYTHON"; then
# Extract the first word of "python", so it can be a program name with args.
set dummy python; ac_word=$2
@@ -22653,7 +22653,7 @@ rm -f conftest.err conftest.$ac_ext
CPPFLAGS="$save_CPPFLAGS"
- if test "X$with_python" == Xyes; then
+ if test "X$with_python" = Xyes; then
if test `uname` = Darwin; then
PYTHON_LDFLAGS="-Wl,-F. -Wl,-F. -bundle"
if $PYTHON -c 'import sys, string; sys.exit(string.find(sys.prefix,"Framework")+1)'; then
@@ -22713,7 +22713,7 @@ fi
- if test "X$with_python" == Xyes; then
+ if test "X$with_python" = Xyes; then
# Extract the first word of "swig", so it can be a program name with args.
set dummy swig; ac_word=$2