Initial import of loco.
Loco is a Perl script which gives the messages file (usually /var/log/messages) some color, so the output is easier to read. It uses a Perl module called Term::ANSIColor to produce the colors. The Perl script is very readable and customizable.
This commit is contained in:
parent
26905f8e67
commit
f6f88922e4
6 changed files with 89 additions and 0 deletions
23
misc/loco/Makefile
Normal file
23
misc/loco/Makefile
Normal file
|
@ -0,0 +1,23 @@
|
|||
# $NetBSD: Makefile,v 1.1.1.1 2001/03/12 10:08:25 zuntum Exp $
|
||||
#
|
||||
|
||||
DISTNAME= loco-0.32
|
||||
CATEGORIES= misc
|
||||
MASTER_SITES= http://zjuul.net/~jules/loco/
|
||||
|
||||
MAINTAINER= zuntum@eik.pl
|
||||
HOMEPAGE= http://zjuul.net/~jules/loco/
|
||||
COMMENT= Colorize file or standard input and print on the standard output
|
||||
|
||||
MAKE_ENV+= "PREFIX=${PREFIX}"
|
||||
|
||||
USE_PERL5= YES
|
||||
|
||||
ALL_TARGET= # defined
|
||||
|
||||
post-patch:
|
||||
${SED} "s,/usr/bin/perl,${LOCALBASE}/bin/perl,g" \
|
||||
${WRKSRC}/loco > ${WRKSRC}/loco.done
|
||||
${MV} ${WRKSRC}/loco.done ${WRKSRC}/loco
|
||||
|
||||
.include "../../mk/bsd.pkg.mk"
|
3
misc/loco/files/md5
Normal file
3
misc/loco/files/md5
Normal file
|
@ -0,0 +1,3 @@
|
|||
$NetBSD: md5,v 1.1.1.1 2001/03/12 10:08:25 zuntum Exp $
|
||||
|
||||
SHA1 (loco-0.32.tar.gz) = b582820fcc6b7ff264c4df2ceb6fe17c286af1bb
|
3
misc/loco/files/patch-sum
Normal file
3
misc/loco/files/patch-sum
Normal file
|
@ -0,0 +1,3 @@
|
|||
$NetBSD: patch-sum,v 1.1.1.1 2001/03/12 10:08:25 zuntum Exp $
|
||||
|
||||
SHA1 (patch-aa) = dd7924b9589ed84802fd90ac0b7475c9cfe39780
|
49
misc/loco/patches/patch-aa
Normal file
49
misc/loco/patches/patch-aa
Normal file
|
@ -0,0 +1,49 @@
|
|||
$NetBSD: patch-aa,v 1.1.1.1 2001/03/12 10:08:25 zuntum Exp $
|
||||
|
||||
--- Makefile.orig Thu Jan 4 22:22:16 2001
|
||||
+++ Makefile
|
||||
@@ -1,13 +1,12 @@
|
||||
PACKAGE=loco
|
||||
VERSION=0.32
|
||||
-PREFIX=/usr/local
|
||||
MANDIR=$(PREFIX)/man/man1
|
||||
-DOCDIR=$(PREFIX)/doc/$(PACKAGE)-$(VERSION)
|
||||
+DOCDIR=$(PREFIX)/share/doc/$(PACKAGE)
|
||||
|
||||
check:
|
||||
- perl -e 'eval "use Term::ANSIColor; 1" || die "Module not found!\n";'
|
||||
- pod2html $(PACKAGE) > $(PACKAGE).html
|
||||
- pod2man $(PACKAGE) | gzip - > $(PACKAGE).1.gz
|
||||
+ ${LOCALBASE}/bin/perl -e 'eval "use Term::ANSIColor; 1" || die "Module not found!\n";'
|
||||
+ ${LOCALBASE}/bin/pod2html $(PACKAGE) > $(PACKAGE).html
|
||||
+ ${LOCALBASE}/bin/pod2man $(PACKAGE) > $(PACKAGE).1
|
||||
#
|
||||
# Checks finished. Everything looks fine
|
||||
#
|
||||
@@ -15,18 +14,18 @@
|
||||
install: installdoc installman installprogram
|
||||
|
||||
installdoc:
|
||||
- install -m 755 -d $(DOCDIR)
|
||||
- install -m 644 $(PACKAGE).html $(DOCDIR)
|
||||
- install -m 644 README $(DOCDIR)
|
||||
- install -m 644 COPYRIGHT $(DOCDIR)
|
||||
+ $(BSD_INSTALL_DATA_DIR) $(DOCDIR)
|
||||
+ $(BSD_INSTALL_DATA) $(PACKAGE).html $(DOCDIR)
|
||||
+ $(BSD_INSTALL_DATA) README $(DOCDIR)
|
||||
+ $(BSD_INSTALL_DATA) COPYRIGHT $(DOCDIR)
|
||||
|
||||
installman:
|
||||
- install -m 755 -d $(MANDIR)
|
||||
- install -m 644 $(PACKAGE).1.gz $(MANDIR)
|
||||
+ $(BSD_INSTALL_MAN_DIR) $(MANDIR)
|
||||
+ $(BSD_INSTALL_MAN) $(PACKAGE).1 $(MANDIR)
|
||||
|
||||
installprogram:
|
||||
- install -m 755 -d $(PREFIX)/bin
|
||||
- install -m 755 $(PACKAGE) $(PREFIX)/bin
|
||||
+ $(BSD_INSTALL_SCRIPT_DIR) $(PREFIX)/bin
|
||||
+ $(BSD_INSTALL_SCRIPT) $(PACKAGE) $(PREFIX)/bin
|
||||
|
||||
clean:
|
||||
rm -f *~ $(PACKAGE).1.gz $(PACKAGE).html pod2html-*
|
4
misc/loco/pkg/DESCR
Normal file
4
misc/loco/pkg/DESCR
Normal file
|
@ -0,0 +1,4 @@
|
|||
Loco is a Perl script which gives the messages file (usually /var/log/messages)
|
||||
some color, so the output is easier to read. It uses a Perl module called
|
||||
Term::ANSIColor to produce the colors. The Perl script is very readable
|
||||
and customizable.
|
7
misc/loco/pkg/PLIST
Normal file
7
misc/loco/pkg/PLIST
Normal file
|
@ -0,0 +1,7 @@
|
|||
@comment $NetBSD: PLIST,v 1.1.1.1 2001/03/12 10:08:25 zuntum Exp $
|
||||
bin/loco
|
||||
man/man1/loco.1
|
||||
share/doc/loco/COPYRIGHT
|
||||
share/doc/loco/README
|
||||
share/doc/loco/loco.html
|
||||
@dirrm share/doc/loco
|
Loading…
Reference in a new issue