Don't include libstdc++ extension that isn't really used.

Don't declare a function void if it returns values. Fix template lookup.
Always use correct C++ syntax. Add missing header.
This commit is contained in:
joerg 2013-06-27 15:51:49 +00:00
parent 216712fc70
commit f70be0776d
5 changed files with 69 additions and 1 deletions

View file

@ -1,8 +1,12 @@
$NetBSD: distinfo,v 1.10 2013/06/23 19:00:14 dholland Exp $
$NetBSD: distinfo,v 1.11 2013/06/27 15:51:49 joerg Exp $
SHA1 (hugin-2010.4.0.tar.bz2) = 47f25c0a8b97c27108e567bcd22203c87f268d07
RMD160 (hugin-2010.4.0.tar.bz2) = f97b8d37470443eb81c3e915e5f5efa91227b135
Size (hugin-2010.4.0.tar.bz2) = 11009978 bytes
SHA1 (patch-ab) = 54f574d677b37569d4269efda5f0f2c6ab23432a
SHA1 (patch-ac) = aac60aa6d3b99a632fce03749660e10ea82ad028
SHA1 (patch-src_celeste_Utilities.cpp) = e25f3f971745be18d4752523529a96146d1dc259
SHA1 (patch-src_foreign_vigra_vigra__impex_png_cxx) = 43ee756664ca8232b3006b76f12fb8ef55711575
SHA1 (patch-src_foreign_vigra_vigra_cachedfileimage.hxx) = 0cf622fd8e0bc4dbaa32df5afd92a8b55f311439
SHA1 (patch-src_foreign_zthread_include_zthread_Guard.h) = ad6ebe3c0ca9b8cc659a70848b6449036c4ef0d2
SHA1 (patch-src_hugin1_icpfind_AutoCtrlPointCreator.cpp) = 7df1c978ef81f4d3fae46cc12aaa4d5917c4cb04

View file

@ -0,0 +1,12 @@
$NetBSD: patch-src_celeste_Utilities.cpp,v 1.1 2013/06/27 15:51:49 joerg Exp $
--- src/celeste/Utilities.cpp.orig 2013-06-25 21:55:54.000000000 +0000
+++ src/celeste/Utilities.cpp
@@ -27,6 +27,7 @@ Copyright (c) 2002-3 Adriaan Tijsseling
#include <math.h>
#include <stdlib.h>
+#include <unistd.h>
#include "Utilities.h"
using namespace std;

View file

@ -0,0 +1,16 @@
$NetBSD: patch-src_foreign_vigra_vigra_cachedfileimage.hxx,v 1.1 2013/06/27 15:51:49 joerg Exp $
--- src/foreign/vigra/vigra/cachedfileimage.hxx.orig 2013-06-25 21:58:48.000000000 +0000
+++ src/foreign/vigra/vigra/cachedfileimage.hxx
@@ -554,11 +554,7 @@ class NotifyingDirectionSelector;
template <class T, class Notify>
class NotifyingDirectionSelector<UnstridedArrayTag, T, Notify>
{
-#ifdef __GNUC__
-friend class Notify::self_type;
-#else
friend typename Notify::self_type;
-#endif
protected:
NotifyingDirectionSelector(T base = 0) : current_(base), notify_(NULL) {}
NotifyingDirectionSelector(NotifyingDirectionSelector const & rhs) : current_(rhs.current_), notify_(NULL) {}

View file

@ -0,0 +1,22 @@
$NetBSD: patch-src_foreign_zthread_include_zthread_Guard.h,v 1.1 2013/06/27 15:51:49 joerg Exp $
--- src/foreign/zthread/include/zthread/Guard.h.orig 2013-06-25 21:56:26.000000000 +0000
+++ src/foreign/zthread/include/zthread/Guard.h
@@ -108,7 +108,7 @@ class CompoundScope {
}
template <class LockType>
- static void createScope(LockHolder<LockType>& l, unsigned long ms) {
+ static bool createScope(LockHolder<LockType>& l, unsigned long ms) {
if(Scope1::createScope(l, ms))
if(!Scope2::createScope(l, ms)) {
@@ -428,7 +428,7 @@ public:
template <class U, class V>
Guard(Guard<U, V>& g) : LockHolder<LockType>(g) {
- LockingPolicy::shareScope(*this, extract(g));
+ LockingPolicy::shareScope(*this, this->extract(g));
}

View file

@ -0,0 +1,14 @@
$NetBSD: patch-src_hugin1_icpfind_AutoCtrlPointCreator.cpp,v 1.1 2013/06/27 15:51:49 joerg Exp $
--- src/hugin1/icpfind/AutoCtrlPointCreator.cpp.orig 2013-06-25 22:01:10.000000000 +0000
+++ src/hugin1/icpfind/AutoCtrlPointCreator.cpp
@@ -28,9 +28,6 @@
#include "panoinc.h"
#include <fstream>
-#ifdef __GNUC__
-#include <ext/stdio_filebuf.h>
-#endif
#include "PT/Panorama.h"
#include "PT/ImageGraph.h"