postgresql1*: updated to 16.2, 15.6, 14.11, 13.14, 12.18

Security Issues

CVE-2024-0985: PostgreSQL non-owner REFRESH MATERIALIZED VIEW CONCURRENTLY executes arbitrary SQL

Bug Fixes and Improvements

This update fixes over 65 bugs that were reported in the last several months. The issues listed below affect PostgreSQL 16. Some of these issues may also affect other supported versions of PostgreSQL.

Fix memory leak when performing JIT inlining that could lead to out-of-memory conditions.
Several query planner fixes.
Align MERGE behavior with UPDATE when updating a partition key column and skip firing AFTER UPDATE ROW trigger and other post-update actions.
Fix problems with duplicate token names in ALTER TEXT SEARCH CONFIGURATION ... MAPPING commands.
Fix DROP ROLE with duplicate role names.
Properly lock the associated table during DROP STATISTICS to prevent errors if ANALYZE is running concurrently.
Fix function volatility checking for GENERATED and DEFAULT expressions.
Ensure collation matches when matching an existing index to a new partitioned index.
Avoid failure if a child index is dropped concurrently with REINDEX INDEX on a partitioned index.
Fix for locking during cleanup of GIN indexes. For this case, if multiple processes tried to clean the same GIN index page, there was a chance of index corruption. If you believe you were affected by this issue, reindex your GIN indexes after installing this update.
Avoid failure with partitioned SP-GiST indexes.
Several ownership fixes for large objects.
In EXPLAIN (BUFFERS), change name of I/O timing data "shared/local" to "shared".
Ensure durability of the CREATE DATABASE command if a system crash occurred during or shortly after execution.
Add more logging messages when starting and ending recovery from a backup.
Revert a change that made the walreceiver process unresponsive to SIGTERM while waiting for a replication connection to be established.
Several fixes for logical replication.
Fix incompatibility with OpenSSL 3.2.
Fix PL/pgSQL to allow CREATE FUNCTION/CREATE PROCEDURE SQL commands that use SQL-standard function bodies.
Fix for error handling in libpq pipeline mode.
Ensure initdb always uncomments postgresql.conf entries for the lc_ family of parameters.
In pg_dump, don't dump RLS policies or security labels for extension member objects.
This commit is contained in:
adam 2024-02-09 08:33:12 +00:00
parent 0f0cdfe042
commit f72f3c3bf7
34 changed files with 122 additions and 241 deletions

View File

@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.18 2023/11/13 20:22:05 adam Exp $
@comment $NetBSD: PLIST,v 1.19 2024/02/09 08:33:12 adam Exp $
man/man1/clusterdb.1
man/man1/createdb.1
man/man1/createuser.1
@ -971,6 +971,7 @@ share/doc/postgresql/html/release-12-14.html
share/doc/postgresql/html/release-12-15.html
share/doc/postgresql/html/release-12-16.html
share/doc/postgresql/html/release-12-17.html
share/doc/postgresql/html/release-12-18.html
share/doc/postgresql/html/release-12-2.html
share/doc/postgresql/html/release-12-3.html
share/doc/postgresql/html/release-12-4.html

View File

@ -1,6 +1,7 @@
@comment $NetBSD: PLIST,v 1.3 2020/05/15 09:45:00 adam Exp $
@comment $NetBSD: PLIST,v 1.4 2024/02/09 08:33:12 adam Exp $
include/postgresql/server/plperl.h
include/postgresql/server/plperl_helpers.h
include/postgresql/server/plperl_system.h
include/postgresql/server/ppport.h
lib/postgresql/plperl.so
${PLIST.nls}share/locale/cs/LC_MESSAGES/plperl-12.mo

View File

@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.2 2019/10/24 07:57:14 triaxx Exp $
@comment $NetBSD: PLIST,v 1.3 2024/02/09 08:33:13 adam Exp $
include/postgresql/server/plpy_cursorobject.h
include/postgresql/server/plpy_elog.h
include/postgresql/server/plpy_exec.h
@ -12,6 +12,7 @@ include/postgresql/server/plpy_subxactobject.h
include/postgresql/server/plpy_typeio.h
include/postgresql/server/plpy_util.h
include/postgresql/server/plpython.h
include/postgresql/server/plpython_system.h
${PLIST.llvm}lib/postgresql/bitcode/hstore_plpython3.index.bc
${PLIST.llvm}lib/postgresql/bitcode/hstore_plpython3/hstore_plpython.bc
${PLIST.py2x}lib/postgresql/hstore_plpython2.so

View File

@ -1,6 +1,6 @@
#!@RCD_SCRIPTS_SHELL@
#
# $NetBSD: pgsql.sh,v 1.1 2019/10/07 19:21:49 adam Exp $
# $NetBSD: pgsql.sh,v 1.2 2024/02/09 08:33:13 adam Exp $
#
# PostgreSQL database rc.d control script
#
@ -18,8 +18,8 @@
# pgsql_home="/path/to/home" # path to pgsql database directory
# See postmaster(1) for possible options.
if [ -f /etc/rc.subr ]; then
. /etc/rc.subr
if [ -f @SYSCONFBASE@/rc.subr ]; then
. @SYSCONFBASE@/rc.subr
fi
name="pgsql"
@ -30,6 +30,7 @@ procname="@PREFIX@/bin/postgres"
: ${pgsql_group:=@PGGROUP@}
: ${pgsql_home:=@PGHOME@}
pgsql_nfiles=4096
extra_commands="initdb reload"
initdb_cmd="pgsql_initdb"
start_precmd="pgsql_precmd"
@ -39,22 +40,25 @@ restart_cmd="pgsql_restart"
stop_cmd="pgsql_stop"
reload_cmd="pgsql_reload"
if [ -f /etc/rc.subr -a -d /etc/rc.d -a -f /etc/rc.d/DAEMON ]; then
if [ -f @SYSCONFBASE@/rc.subr ] && \
[ -d @SYSCONFBASE@/rc.d ] && \
[ -f @SYSCONFBASE@/rc.d/DAEMON ]; then
load_rc_config $name
elif [ -f /etc/rc.conf ]; then
. /etc/rc.conf
elif [ -f @SYSCONFBASE@/rc.conf ]; then
. @SYSCONFBASE@/rc.conf
fi
cd /
command_args="-w -s -D ${pgsql_home}/data -m fast -l ${pgsql_home}/errlog"
command_args_daemon="${command_args}"
if [ -n "${pgsql_flags}" ]; then
command_args="${command_args} -o \\\"${pgsql_flags}\\\""
command_args_daemon="${command_args} -o \"${pgsql_flags}\""
fi
pgsql_precmd()
{
ulimit -n 4096
ulimit -n ${pgsql_nfiles}
if [ ! -d ${pgsql_home}/data/base ]; then
pgsql_initdb
fi
@ -71,40 +75,37 @@ pgsql_initdb()
@CHOWN@ ${pgsql_user} ${pgsql_home}
@CHGRP@ ${pgsql_group} ${pgsql_home}
@CHMOD@ 0700 ${pgsql_home}
doit="@SU@ -m ${pgsql_user} -c '${command} init ${command_args}'"
eval $doit
@SU@ -m ${pgsql_user} -c "${command} init ${command_args}"
fi
}
pgsql_start()
{
@ECHO@ "Starting ${name}."
doit="@SU@ -m ${pgsql_user} -c '${command} start ${command_args}'"
eval $doit
@SU@ -m ${pgsql_user} -c "${command} start ${command_args_daemon}"
}
pgsql_restart()
{
@ECHO@ "Restarting ${name}."
doit="@SU@ -m ${pgsql_user} -c '${command} restart ${command_args}'"
eval $doit
@SU@ -m ${pgsql_user} -c "${command} restart ${command_args_daemon}"
}
pgsql_stop()
{
@ECHO@ "Stopping ${name}."
doit="@SU@ -m ${pgsql_user} -c '${command} stop ${command_args}'"
eval $doit
@SU@ -m ${pgsql_user} -c "${command} stop ${command_args}"
}
pgsql_reload()
{
@ECHO@ "Reloading ${name}."
doit="@SU@ -m ${pgsql_user} -c '${command} reload ${command_args}'"
eval $doit
@SU@ -m ${pgsql_user} -c "${command} reload ${command_args_daemon}"
}
if [ -f /etc/rc.subr -a -d /etc/rc.d -a -f /etc/rc.d/DAEMON ]; then
if [ -f @SYSCONFBASE@/rc.subr ] && \
[ -d @SYSCONFBASE@/rc.d ] && \
[ -f @SYSCONFBASE@/rc.d/DAEMON ]; then
run_rc_command "$1"
else
pidfile="${pgsql_home}/data/postmaster.pid"

View File

@ -1,4 +1,4 @@
# $NetBSD: Makefile.common,v 1.28 2023/11/13 20:22:04 adam Exp $
# $NetBSD: Makefile.common,v 1.29 2024/02/09 08:33:12 adam Exp $
#
# This Makefile fragment is included by all PostgreSQL packages built from
# the main sources of the PostgreSQL distribution except jdbc-postgresql.
@ -16,7 +16,7 @@
# used by databases/postgresql12-pltcl/Makefile
# used by databases/postgresql12-server/Makefile
DISTNAME= postgresql-12.17
DISTNAME= postgresql-12.18
CATEGORIES= databases
MASTER_SITES= ${MASTER_SITE_PGSQL:=source/v${PKGVERSION_NOREV}/}
EXTRACT_SUFX= .tar.bz2

View File

@ -1,8 +1,8 @@
$NetBSD: distinfo,v 1.22 2023/11/13 20:22:04 adam Exp $
$NetBSD: distinfo,v 1.23 2024/02/09 08:33:12 adam Exp $
BLAKE2s (postgresql-12.17.tar.bz2) = ff611570be67a59f0ec43f5e501de6d5929c15853641b2d0f80e2b1183df4ef8
SHA512 (postgresql-12.17.tar.bz2) = 8bf67475db4ec5baf058ca976ea3e416df39cd9d15131be3fa3c161edbfa93f74251d33b29d23b3084c95bbb73fb6606f4615e528129674047a75a86e7417373
Size (postgresql-12.17.tar.bz2) = 21181616 bytes
BLAKE2s (postgresql-12.18.tar.bz2) = a0fceb3f9c5cefde28cb0a596942f920bd42817ecaddaa69beed195a89b014c2
SHA512 (postgresql-12.18.tar.bz2) = 723105a2b280ed9116615fa5fe29034a8588e474ed622de2c439f95e5b621b8865224e02553b71cba8d0288b1ee9fea077b20bd77fe2c858cd988b417efa56c0
Size (postgresql-12.18.tar.bz2) = 21208935 bytes
SHA1 (patch-config_missing) = c2d7d742922ba6861e7660c75b7b53f09e564813
SHA1 (patch-config_perl.m4) = b3393d0f28e97f89ae20297d85553c508b3896bb
SHA1 (patch-configure) = b0a758023b3b263ff51b154d0da32cf02520c6cd

View File

@ -1,28 +0,0 @@
$NetBSD: patch-src_pl_plperl_plperl.h,v 1.2 2023/02/15 20:50:57 adam Exp $
--- src/pl/plperl/plperl.h.orig 2023-02-06 21:45:00.000000000 +0000
+++ src/pl/plperl/plperl.h
@@ -70,6 +70,11 @@
#define HAS_BOOL 1
#endif
+#ifdef __sun
+#define list_head sun_list_head
+#define list_tail sun_list_tail
+#endif
+
/*
* Newer versions of the perl headers trigger a lot of warnings with our
* compiler flags (at least -Wdeclaration-after-statement,
@@ -121,6 +126,11 @@
#include "XSUB.h"
#endif
+#ifdef __sun
+#undef list_head
+#undef list_tail
+#endif
+
/* put back our *printf macros ... this must match src/include/port.h */
#ifdef vsnprintf
#undef vsnprintf

View File

@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.14 2023/11/13 20:22:06 adam Exp $
@comment $NetBSD: PLIST,v 1.15 2024/02/09 08:33:13 adam Exp $
man/man1/clusterdb.1
man/man1/createdb.1
man/man1/createuser.1
@ -975,6 +975,7 @@ share/doc/postgresql/html/release-13-10.html
share/doc/postgresql/html/release-13-11.html
share/doc/postgresql/html/release-13-12.html
share/doc/postgresql/html/release-13-13.html
share/doc/postgresql/html/release-13-14.html
share/doc/postgresql/html/release-13-2.html
share/doc/postgresql/html/release-13-3.html
share/doc/postgresql/html/release-13-4.html

View File

@ -1,6 +1,7 @@
@comment $NetBSD: PLIST,v 1.1 2020/10/18 09:24:02 adam Exp $
@comment $NetBSD: PLIST,v 1.2 2024/02/09 08:33:13 adam Exp $
include/postgresql/server/plperl.h
include/postgresql/server/plperl_helpers.h
include/postgresql/server/plperl_system.h
include/postgresql/server/ppport.h
lib/postgresql/plperl.so
${PLIST.nls}share/locale/cs/LC_MESSAGES/plperl-13.mo

View File

@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.1 2020/10/18 09:24:03 adam Exp $
@comment $NetBSD: PLIST,v 1.2 2024/02/09 08:33:13 adam Exp $
include/postgresql/server/plpy_cursorobject.h
include/postgresql/server/plpy_elog.h
include/postgresql/server/plpy_exec.h
@ -12,6 +12,7 @@ include/postgresql/server/plpy_subxactobject.h
include/postgresql/server/plpy_typeio.h
include/postgresql/server/plpy_util.h
include/postgresql/server/plpython.h
include/postgresql/server/plpython_system.h
${PLIST.llvm}lib/postgresql/bitcode/hstore_plpython3.index.bc
${PLIST.llvm}lib/postgresql/bitcode/hstore_plpython3/hstore_plpython.bc
${PLIST.py2x}lib/postgresql/hstore_plpython2.so

View File

@ -1,6 +1,6 @@
#!@RCD_SCRIPTS_SHELL@
#
# $NetBSD: pgsql.sh,v 1.1 2020/10/18 09:24:03 adam Exp $
# $NetBSD: pgsql.sh,v 1.2 2024/02/09 08:33:14 adam Exp $
#
# PostgreSQL database rc.d control script
#
@ -18,8 +18,8 @@
# pgsql_home="/path/to/home" # path to pgsql database directory
# See postmaster(1) for possible options.
if [ -f /etc/rc.subr ]; then
. /etc/rc.subr
if [ -f @SYSCONFBASE@/rc.subr ]; then
. @SYSCONFBASE@/rc.subr
fi
name="pgsql"
@ -30,6 +30,7 @@ procname="@PREFIX@/bin/postgres"
: ${pgsql_group:=@PGGROUP@}
: ${pgsql_home:=@PGHOME@}
pgsql_nfiles=4096
extra_commands="initdb reload"
initdb_cmd="pgsql_initdb"
start_precmd="pgsql_precmd"
@ -39,22 +40,25 @@ restart_cmd="pgsql_restart"
stop_cmd="pgsql_stop"
reload_cmd="pgsql_reload"
if [ -f /etc/rc.subr -a -d /etc/rc.d -a -f /etc/rc.d/DAEMON ]; then
if [ -f @SYSCONFBASE@/rc.subr ] && \
[ -d @SYSCONFBASE@/rc.d ] && \
[ -f @SYSCONFBASE@/rc.d/DAEMON ]; then
load_rc_config $name
elif [ -f /etc/rc.conf ]; then
. /etc/rc.conf
elif [ -f @SYSCONFBASE@/rc.conf ]; then
. @SYSCONFBASE@/rc.conf
fi
cd /
command_args="-w -s -D ${pgsql_home}/data -m fast -l ${pgsql_home}/errlog"
command_args_daemon="${command_args}"
if [ -n "${pgsql_flags}" ]; then
command_args="${command_args} -o \\\"${pgsql_flags}\\\""
command_args_daemon="${command_args} -o \"${pgsql_flags}\""
fi
pgsql_precmd()
{
ulimit -n 4096
ulimit -n ${pgsql_nfiles}
if [ ! -d ${pgsql_home}/data/base ]; then
pgsql_initdb
fi
@ -71,40 +75,37 @@ pgsql_initdb()
@CHOWN@ ${pgsql_user} ${pgsql_home}
@CHGRP@ ${pgsql_group} ${pgsql_home}
@CHMOD@ 0700 ${pgsql_home}
doit="@SU@ -m ${pgsql_user} -c '${command} init ${command_args}'"
eval $doit
@SU@ -m ${pgsql_user} -c "${command} init ${command_args}"
fi
}
pgsql_start()
{
@ECHO@ "Starting ${name}."
doit="@SU@ -m ${pgsql_user} -c '${command} start ${command_args}'"
eval $doit
@SU@ -m ${pgsql_user} -c "${command} start ${command_args_daemon}"
}
pgsql_restart()
{
@ECHO@ "Restarting ${name}."
doit="@SU@ -m ${pgsql_user} -c '${command} restart ${command_args}'"
eval $doit
@SU@ -m ${pgsql_user} -c "${command} restart ${command_args_daemon}"
}
pgsql_stop()
{
@ECHO@ "Stopping ${name}."
doit="@SU@ -m ${pgsql_user} -c '${command} stop ${command_args}'"
eval $doit
@SU@ -m ${pgsql_user} -c "${command} stop ${command_args}"
}
pgsql_reload()
{
@ECHO@ "Reloading ${name}."
doit="@SU@ -m ${pgsql_user} -c '${command} reload ${command_args}'"
eval $doit
@SU@ -m ${pgsql_user} -c "${command} reload ${command_args_daemon}"
}
if [ -f /etc/rc.subr -a -d /etc/rc.d -a -f /etc/rc.d/DAEMON ]; then
if [ -f @SYSCONFBASE@/rc.subr ] && \
[ -d @SYSCONFBASE@/rc.d ] && \
[ -f @SYSCONFBASE@/rc.d/DAEMON ]; then
run_rc_command "$1"
else
pidfile="${pgsql_home}/data/postmaster.pid"

View File

@ -1,4 +1,4 @@
# $NetBSD: Makefile.common,v 1.21 2023/11/13 20:22:05 adam Exp $
# $NetBSD: Makefile.common,v 1.22 2024/02/09 08:33:13 adam Exp $
#
# This Makefile fragment is included by all PostgreSQL packages built from
# the main sources of the PostgreSQL distribution except jdbc-postgresql.
@ -16,7 +16,7 @@
# used by databases/postgresql13-pltcl/Makefile
# used by databases/postgresql13-server/Makefile
DISTNAME= postgresql-13.13
DISTNAME= postgresql-13.14
CATEGORIES= databases
MASTER_SITES= ${MASTER_SITE_PGSQL:=source/v${PKGVERSION_NOREV}/}
EXTRACT_SUFX= .tar.bz2

View File

@ -1,8 +1,8 @@
$NetBSD: distinfo,v 1.20 2023/11/13 20:22:05 adam Exp $
$NetBSD: distinfo,v 1.21 2024/02/09 08:33:13 adam Exp $
BLAKE2s (postgresql-13.13.tar.bz2) = de7adb4945155deb57dd1a6623a89810447a3f9aa74ee4c429f15d0d8bf1538d
SHA512 (postgresql-13.13.tar.bz2) = d7b1076cdc406ac83440c75d18e6dc6db9af709615344978ba0135b45a127082b1d3c6ad6d8cd6259d67ddf38cfcee37dd78dcfbf8e4a710b724c67cf36170a7
Size (postgresql-13.13.tar.bz2) = 21563452 bytes
BLAKE2s (postgresql-13.14.tar.bz2) = 51cde2d961c227a23f6728b98c333acb1c270dc1b73e5680316eb7a1d7a48002
SHA512 (postgresql-13.14.tar.bz2) = 25d545de69d6ac16b044e09939678af97b6574c71d47d98f95f0ef9ad11ff65e864e503ddff119d73fbb3c61e648e31219982d60da7fc2382ba10e0bfc370aa5
Size (postgresql-13.14.tar.bz2) = 21584146 bytes
SHA1 (patch-config_missing) = c2d7d742922ba6861e7660c75b7b53f09e564813
SHA1 (patch-config_perl.m4) = b3393d0f28e97f89ae20297d85553c508b3896bb
SHA1 (patch-configure) = 142ba9dc85a2408802e4b9e4943b775312d577c9
@ -15,4 +15,3 @@ SHA1 (patch-src_fe__utils_Makefile) = c4d2c9f7c2f550c3a9d4d2089b033d029b7a6551
SHA1 (patch-src_interfaces_libpq_Makefile) = 61bcf84eb69b6ec9faabab0b61913766f4b20f8c
SHA1 (patch-src_makefiles_Makefile.solaris) = 10bf43bee54a6a1b6086c1652076544b05bf0192
SHA1 (patch-src_pl_plperl_GNUmakefile) = 161a8f7af61b3a33b255fdee9fa7d4918decde7d
SHA1 (patch-src_pl_plperl_plperl.h) = 99f04b6a733a799a15e46a011697729be6be4717

View File

@ -1,28 +0,0 @@
$NetBSD: patch-src_pl_plperl_plperl.h,v 1.2 2023/02/15 20:50:58 adam Exp $
--- src/pl/plperl/plperl.h.orig 2023-02-06 21:42:56.000000000 +0000
+++ src/pl/plperl/plperl.h
@@ -70,6 +70,11 @@
#define HAS_BOOL 1
#endif
+#ifdef __sun
+#define list_head sun_list_head
+#define list_tail sun_list_tail
+#endif
+
/*
* Newer versions of the perl headers trigger a lot of warnings with our
* compiler flags (at least -Wdeclaration-after-statement,
@@ -121,6 +126,11 @@
#include "XSUB.h"
#endif
+#ifdef __sun
+#undef list_head
+#undef list_tail
+#endif
+
/* put back our *printf macros ... this must match src/include/port.h */
#ifdef vsnprintf
#undef vsnprintf

View File

@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.11 2023/11/13 20:22:06 adam Exp $
@comment $NetBSD: PLIST,v 1.12 2024/02/09 08:33:14 adam Exp $
man/man1/clusterdb.1
man/man1/createdb.1
man/man1/createuser.1
@ -988,6 +988,7 @@ share/doc/postgresql/html/regress-variant.html
share/doc/postgresql/html/regress.html
share/doc/postgresql/html/release-14-1.html
share/doc/postgresql/html/release-14-10.html
share/doc/postgresql/html/release-14-11.html
share/doc/postgresql/html/release-14-2.html
share/doc/postgresql/html/release-14-3.html
share/doc/postgresql/html/release-14-4.html

View File

@ -1,6 +1,7 @@
@comment $NetBSD: PLIST,v 1.2 2021/11/16 10:14:38 adam Exp $
@comment $NetBSD: PLIST,v 1.3 2024/02/09 08:33:14 adam Exp $
include/postgresql/server/plperl.h
include/postgresql/server/plperl_helpers.h
include/postgresql/server/plperl_system.h
include/postgresql/server/ppport.h
lib/postgresql/plperl.so
${PLIST.nls}share/locale/cs/LC_MESSAGES/plperl-14.mo

View File

@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.1 2021/10/08 10:23:44 adam Exp $
@comment $NetBSD: PLIST,v 1.2 2024/02/09 08:33:14 adam Exp $
include/postgresql/server/plpy_cursorobject.h
include/postgresql/server/plpy_elog.h
include/postgresql/server/plpy_exec.h
@ -12,6 +12,7 @@ include/postgresql/server/plpy_subxactobject.h
include/postgresql/server/plpy_typeio.h
include/postgresql/server/plpy_util.h
include/postgresql/server/plpython.h
include/postgresql/server/plpython_system.h
${PLIST.llvm}lib/postgresql/bitcode/hstore_plpython3.index.bc
${PLIST.llvm}lib/postgresql/bitcode/hstore_plpython3/hstore_plpython.bc
${PLIST.py2x}lib/postgresql/hstore_plpython2.so

View File

@ -1,6 +1,6 @@
#!@RCD_SCRIPTS_SHELL@
#
# $NetBSD: pgsql.sh,v 1.2 2022/10/02 14:24:50 martin Exp $
# $NetBSD: pgsql.sh,v 1.3 2024/02/09 08:33:14 adam Exp $
#
# PostgreSQL database rc.d control script
#
@ -18,8 +18,8 @@
# pgsql_home="/path/to/home" # path to pgsql database directory
# See postmaster(1) for possible options.
if [ -f /etc/rc.subr ]; then
. /etc/rc.subr
if [ -f @SYSCONFBASE@/rc.subr ]; then
. @SYSCONFBASE@/rc.subr
fi
name="pgsql"
@ -40,10 +40,12 @@ restart_cmd="pgsql_restart"
stop_cmd="pgsql_stop"
reload_cmd="pgsql_reload"
if [ -f /etc/rc.subr ] && [ -d /etc/rc.d ] && [ -f /etc/rc.d/DAEMON ]; then
if [ -f @SYSCONFBASE@/rc.subr ] && \
[ -d @SYSCONFBASE@/rc.d ] && \
[ -f @SYSCONFBASE@/rc.d/DAEMON ]; then
load_rc_config $name
elif [ -f /etc/rc.conf ]; then
. /etc/rc.conf
elif [ -f @SYSCONFBASE@/rc.conf ]; then
. @SYSCONFBASE@/rc.conf
fi
cd /
@ -101,7 +103,9 @@ pgsql_reload()
@SU@ -m ${pgsql_user} -c "${command} reload ${command_args_daemon}"
}
if [ -f /etc/rc.subr ] && [ -d /etc/rc.d ] && [ -f /etc/rc.d/DAEMON ]; then
if [ -f @SYSCONFBASE@/rc.subr ] && \
[ -d @SYSCONFBASE@/rc.d ] && \
[ -f @SYSCONFBASE@/rc.d/DAEMON ]; then
run_rc_command "$1"
else
pidfile="${pgsql_home}/data/postmaster.pid"

View File

@ -1,4 +1,4 @@
# $NetBSD: Makefile.common,v 1.13 2023/11/13 20:22:06 adam Exp $
# $NetBSD: Makefile.common,v 1.14 2024/02/09 08:33:14 adam Exp $
#
# This Makefile fragment is included by all PostgreSQL packages built from
# the main sources of the PostgreSQL distribution except jdbc-postgresql.
@ -16,7 +16,7 @@
# used by databases/postgresql14-pltcl/Makefile
# used by databases/postgresql14-server/Makefile
DISTNAME= postgresql-14.10
DISTNAME= postgresql-14.11
CATEGORIES= databases
MASTER_SITES= ${MASTER_SITE_PGSQL:=source/v${PKGVERSION_NOREV}/}
EXTRACT_SUFX= .tar.bz2

View File

@ -1,8 +1,8 @@
$NetBSD: distinfo,v 1.13 2023/11/13 20:22:06 adam Exp $
$NetBSD: distinfo,v 1.14 2024/02/09 08:33:14 adam Exp $
BLAKE2s (postgresql-14.10.tar.bz2) = a496cab7728b6af59a5a6aa53027aa9472ed97ec68c371a737c85093fecd8c55
SHA512 (postgresql-14.10.tar.bz2) = f546e62eb158efdeecf091271ee60945604ca7f3683f0b259ee18eb682431158e282bf4f81d8df304c956919788f8077e72aa47c467d32d6aef1ccfe470862a5
Size (postgresql-14.10.tar.bz2) = 22298652 bytes
BLAKE2s (postgresql-14.11.tar.bz2) = 28138313ab0520b08ca4a771193a9566a8162952be136159c2cfee629ef5d55f
SHA512 (postgresql-14.11.tar.bz2) = 67289cd638ed7b13e845263d5a34394347f33735d9e2fafd6aa3562989a3a9455ea547d1b5079138648f33b093e77841654188fc74a49c0d6d458a42cfb57ffe
Size (postgresql-14.11.tar.bz2) = 22354758 bytes
SHA1 (patch-config_missing) = c2d7d742922ba6861e7660c75b7b53f09e564813
SHA1 (patch-config_perl.m4) = b3393d0f28e97f89ae20297d85553c508b3896bb
SHA1 (patch-configure) = 142ba9dc85a2408802e4b9e4943b775312d577c9
@ -14,4 +14,3 @@ SHA1 (patch-src_backend_Makefile) = 736ff7db09faf167c6e40a45a1099836f3e98911
SHA1 (patch-src_interfaces_libpq_Makefile) = 61bcf84eb69b6ec9faabab0b61913766f4b20f8c
SHA1 (patch-src_makefiles_Makefile.solaris) = 10bf43bee54a6a1b6086c1652076544b05bf0192
SHA1 (patch-src_pl_plperl_GNUmakefile) = 161a8f7af61b3a33b255fdee9fa7d4918decde7d
SHA1 (patch-src_pl_plperl_plperl.h) = fd65b9930a150a9bbd1fd3b5771144a6608126a2

View File

@ -1,28 +0,0 @@
$NetBSD: patch-src_pl_plperl_plperl.h,v 1.2 2023/02/15 20:51:00 adam Exp $
--- src/pl/plperl/plperl.h.orig 2023-02-06 21:41:14.000000000 +0000
+++ src/pl/plperl/plperl.h
@@ -70,6 +70,11 @@
#define HAS_BOOL 1
#endif
+#ifdef __sun
+#undef list_head
+#undef list_tail
+#endif
+
/*
* Newer versions of the perl headers trigger a lot of warnings with our
* compiler flags (at least -Wdeclaration-after-statement,
@@ -122,6 +127,11 @@
#include "XSUB.h"
#endif
+#ifdef __sun
+#undef list_head
+#undef list_tail
+#endif
+
/* put back our *printf macros ... this must match src/include/port.h */
#ifdef vsnprintf
#undef vsnprintf

View File

@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.6 2023/11/13 20:22:07 adam Exp $
@comment $NetBSD: PLIST,v 1.7 2024/02/09 08:33:15 adam Exp $
man/man1/clusterdb.1
man/man1/createdb.1
man/man1/createuser.1
@ -1004,6 +1004,7 @@ share/doc/postgresql/html/release-15-2.html
share/doc/postgresql/html/release-15-3.html
share/doc/postgresql/html/release-15-4.html
share/doc/postgresql/html/release-15-5.html
share/doc/postgresql/html/release-15-6.html
share/doc/postgresql/html/release-15.html
share/doc/postgresql/html/release-prior.html
share/doc/postgresql/html/release.html

View File

@ -1,6 +1,7 @@
@comment $NetBSD: PLIST,v 1.1 2022/10/19 13:16:46 adam Exp $
@comment $NetBSD: PLIST,v 1.2 2024/02/09 08:33:15 adam Exp $
include/postgresql/server/plperl.h
include/postgresql/server/plperl_helpers.h
include/postgresql/server/plperl_system.h
include/postgresql/server/ppport.h
lib/postgresql/plperl.so
${PLIST.nls}share/locale/cs/LC_MESSAGES/plperl-15.mo

View File

@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.1 2022/10/19 13:16:46 adam Exp $
@comment $NetBSD: PLIST,v 1.2 2024/02/09 08:33:15 adam Exp $
include/postgresql/server/plpy_cursorobject.h
include/postgresql/server/plpy_elog.h
include/postgresql/server/plpy_exec.h
@ -12,6 +12,7 @@ include/postgresql/server/plpy_subxactobject.h
include/postgresql/server/plpy_typeio.h
include/postgresql/server/plpy_util.h
include/postgresql/server/plpython.h
include/postgresql/server/plpython_system.h
${PLIST.llvm}lib/postgresql/bitcode/hstore_plpython3.index.bc
${PLIST.llvm}lib/postgresql/bitcode/hstore_plpython3/hstore_plpython.bc
${PLIST.py2x}lib/postgresql/hstore_plpython2.so

View File

@ -1,6 +1,6 @@
#!@RCD_SCRIPTS_SHELL@
#
# $NetBSD: pgsql.sh,v 1.1 2022/10/19 13:16:46 adam Exp $
# $NetBSD: pgsql.sh,v 1.2 2024/02/09 08:33:15 adam Exp $
#
# PostgreSQL database rc.d control script
#
@ -18,8 +18,8 @@
# pgsql_home="/path/to/home" # path to pgsql database directory
# See postmaster(1) for possible options.
if [ -f /etc/rc.subr ]; then
. /etc/rc.subr
if [ -f @SYSCONFBASE@/rc.subr ]; then
. @SYSCONFBASE@/rc.subr
fi
name="pgsql"
@ -40,10 +40,12 @@ restart_cmd="pgsql_restart"
stop_cmd="pgsql_stop"
reload_cmd="pgsql_reload"
if [ -f /etc/rc.subr ] && [ -d /etc/rc.d ] && [ -f /etc/rc.d/DAEMON ]; then
if [ -f @SYSCONFBASE@/rc.subr ] && \
[ -d @SYSCONFBASE@/rc.d ] && \
[ -f @SYSCONFBASE@/rc.d/DAEMON ]; then
load_rc_config $name
elif [ -f /etc/rc.conf ]; then
. /etc/rc.conf
elif [ -f @SYSCONFBASE@/rc.conf ]; then
. @SYSCONFBASE@/rc.conf
fi
cd /
@ -101,7 +103,9 @@ pgsql_reload()
@SU@ -m ${pgsql_user} -c "${command} reload ${command_args_daemon}"
}
if [ -f /etc/rc.subr ] && [ -d /etc/rc.d ] && [ -f /etc/rc.d/DAEMON ]; then
if [ -f @SYSCONFBASE@/rc.subr ] && \
[ -d @SYSCONFBASE@/rc.d ] && \
[ -f @SYSCONFBASE@/rc.d/DAEMON ]; then
run_rc_command "$1"
else
pidfile="${pgsql_home}/data/postmaster.pid"

View File

@ -1,4 +1,4 @@
# $NetBSD: Makefile.common,v 1.7 2023/11/13 20:22:07 adam Exp $
# $NetBSD: Makefile.common,v 1.8 2024/02/09 08:33:14 adam Exp $
#
# This Makefile fragment is included by all PostgreSQL packages built from
# the main sources of the PostgreSQL distribution except jdbc-postgresql.
@ -16,7 +16,7 @@
# used by databases/postgresql15-pltcl/Makefile
# used by databases/postgresql15-server/Makefile
DISTNAME= postgresql-15.5
DISTNAME= postgresql-15.6
CATEGORIES= databases
MASTER_SITES= ${MASTER_SITE_PGSQL:=source/v${PKGVERSION_NOREV}/}
EXTRACT_SUFX= .tar.bz2

View File

@ -1,8 +1,8 @@
$NetBSD: distinfo,v 1.6 2023/11/13 20:22:07 adam Exp $
$NetBSD: distinfo,v 1.7 2024/02/09 08:33:14 adam Exp $
BLAKE2s (postgresql-15.5.tar.bz2) = 28c68867eaa76753b02c6a4e5063e55d821e0425d382f434eec0d8e5291ebaa2
SHA512 (postgresql-15.5.tar.bz2) = 9ed9d160b3cef99954ccd47a970c107b7e3b0196a7d848f740bf3c52a1c626f6f457814c97f37b9f0467bb07734e19806a15bd9cf3c39445e1d89e75b37064cc
Size (postgresql-15.5.tar.bz2) = 23091780 bytes
BLAKE2s (postgresql-15.6.tar.bz2) = bc541bb2dc9fddd7e26a9927d84f23a432ac6cff1fbe31bd2e4969bc457ffcf7
SHA512 (postgresql-15.6.tar.bz2) = d9f158d844ec21bc5a7eccad9193dfe026d3df46a011980412ad7d150b3894c01754be0053bed530976047d7eff657204ac321138ba8da6eac8fb7b93b9520ad
Size (postgresql-15.6.tar.bz2) = 23093967 bytes
SHA1 (patch-config_missing) = c2d7d742922ba6861e7660c75b7b53f09e564813
SHA1 (patch-config_perl.m4) = b3393d0f28e97f89ae20297d85553c508b3896bb
SHA1 (patch-configure) = 142ba9dc85a2408802e4b9e4943b775312d577c9
@ -13,4 +13,3 @@ SHA1 (patch-src_backend_Makefile) = 28a34701159db3cf3a020402ee3467a73d9a1457
SHA1 (patch-src_interfaces_libpq_Makefile) = 61bcf84eb69b6ec9faabab0b61913766f4b20f8c
SHA1 (patch-src_makefiles_Makefile.solaris) = 10bf43bee54a6a1b6086c1652076544b05bf0192
SHA1 (patch-src_pl_plperl_GNUmakefile) = 161a8f7af61b3a33b255fdee9fa7d4918decde7d
SHA1 (patch-src_pl_plperl_plperl.h) = 67b71bee267448088c43ae1f206d6eaee4c08dea

View File

@ -1,28 +0,0 @@
$NetBSD: patch-src_pl_plperl_plperl.h,v 1.2 2023/02/15 20:51:01 adam Exp $
--- src/pl/plperl/plperl.h.orig 2023-02-06 21:39:04.000000000 +0000
+++ src/pl/plperl/plperl.h
@@ -70,6 +70,11 @@
#define HAS_BOOL 1
#endif
+#ifdef __sun
+#define list_head sun_list_head
+#define list_tail sun_list_tail
+#endif
+
/*
* Newer versions of the perl headers trigger a lot of warnings with our
* compiler flags (at least -Wdeclaration-after-statement,
@@ -122,6 +127,11 @@
#include "XSUB.h"
#endif
+#ifdef __sun
+#undef list_head
+#undef list_tail
+#endif
+
/* put back our *printf macros ... this must match src/include/port.h */
#ifdef vsnprintf
#undef vsnprintf

View File

@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.2 2023/11/13 20:22:08 adam Exp $
@comment $NetBSD: PLIST,v 1.3 2024/02/09 08:33:16 adam Exp $
man/man1/clusterdb.1
man/man1/createdb.1
man/man1/createuser.1
@ -999,6 +999,7 @@ share/doc/postgresql/html/regress-tap.html
share/doc/postgresql/html/regress-variant.html
share/doc/postgresql/html/regress.html
share/doc/postgresql/html/release-16-1.html
share/doc/postgresql/html/release-16-2.html
share/doc/postgresql/html/release-16.html
share/doc/postgresql/html/release-prior.html
share/doc/postgresql/html/release.html

View File

@ -1,5 +1,6 @@
@comment $NetBSD: PLIST,v 1.1 2023/09/17 08:53:21 adam Exp $
@comment $NetBSD: PLIST,v 1.2 2024/02/09 08:33:16 adam Exp $
include/postgresql/server/plperl.h
include/postgresql/server/plperl_system.h
include/postgresql/server/ppport.h
lib/postgresql/plperl.${SOEXT}
${PLIST.nls}share/locale/cs/LC_MESSAGES/plperl-16.mo

View File

@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.2 2023/11/13 20:22:09 adam Exp $
@comment $NetBSD: PLIST,v 1.3 2024/02/09 08:33:16 adam Exp $
include/postgresql/server/plpy_cursorobject.h
include/postgresql/server/plpy_elog.h
include/postgresql/server/plpy_exec.h
@ -12,6 +12,7 @@ include/postgresql/server/plpy_subxactobject.h
include/postgresql/server/plpy_typeio.h
include/postgresql/server/plpy_util.h
include/postgresql/server/plpython.h
include/postgresql/server/plpython_system.h
${PLIST.llvm}lib/postgresql/bitcode/hstore_plpython3.index.bc
${PLIST.llvm}lib/postgresql/bitcode/hstore_plpython3/hstore_plpython.bc
${PLIST.py2x}lib/postgresql/hstore_plpython2.${SOEXT}

View File

@ -1,4 +1,4 @@
# $NetBSD: Makefile.common,v 1.3 2023/11/13 20:22:08 adam Exp $
# $NetBSD: Makefile.common,v 1.4 2024/02/09 08:33:15 adam Exp $
#
# This Makefile fragment is included by all PostgreSQL packages built from
# the main sources of the PostgreSQL distribution except jdbc-postgresql.
@ -16,7 +16,7 @@
# used by databases/postgresql16-pltcl/Makefile
# used by databases/postgresql16-server/Makefile
DISTNAME= postgresql-16.1
DISTNAME= postgresql-16.2
CATEGORIES= databases
MASTER_SITES= ${MASTER_SITE_PGSQL:=source/v${PKGVERSION_NOREV}/}
EXTRACT_SUFX= .tar.bz2

View File

@ -1,8 +1,8 @@
$NetBSD: distinfo,v 1.3 2023/12/20 18:38:39 nros Exp $
$NetBSD: distinfo,v 1.4 2024/02/09 08:33:15 adam Exp $
BLAKE2s (postgresql-16.1.tar.bz2) = 9ee0564bc27659694ba7e536d75ae453d44a4f4d6d98763463ba6028e445a027
SHA512 (postgresql-16.1.tar.bz2) = 69f4635e5841452599f13b47df41ce2425ab34b4e4582fd2c635bc78d561fa36c5b03eccb4ae6569872dc74775be1b5a62dee20c9a4f12a43339250128352918
Size (postgresql-16.1.tar.bz2) = 24605482 bytes
BLAKE2s (postgresql-16.2.tar.bz2) = 976c36e29862ad29a0d31fe1bd85f8f9a7a1bdacb5dc7839cf96855310c7a0a4
SHA512 (postgresql-16.2.tar.bz2) = 3194941cc3f1ec86b6cf4f08c6422d268d99890441f8fc9ab87b6a7fd16c990fa230b544308644cbef54e6960c4984e3703752e40930bdc0537b7bfda3ab7ccf
Size (postgresql-16.2.tar.bz2) = 24711703 bytes
SHA1 (patch-config_missing) = c2d7d742922ba6861e7660c75b7b53f09e564813
SHA1 (patch-config_perl.m4) = 9c4bf707b6aded63b2e0cff375465693cad1dea9
SHA1 (patch-configure) = 3392111516ca65ad7980ee39246c4210ec020c34
@ -13,4 +13,3 @@ SHA1 (patch-src_backend_Makefile) = a4d4cdb46fed094367d4953ad256f239ac82194b
SHA1 (patch-src_interfaces_libpq_Makefile) = 61bcf84eb69b6ec9faabab0b61913766f4b20f8c
SHA1 (patch-src_makefiles_Makefile.solaris) = 2dd1a3e6b279331b0835d3af3af02f4fe1cfa216
SHA1 (patch-src_pl_plperl_GNUmakefile) = 6626a4dcea72dd6c0f51ffada202659f0f9f0ab9
SHA1 (patch-src_pl_plperl_plperl.h) = 67b71bee267448088c43ae1f206d6eaee4c08dea

View File

@ -1,28 +0,0 @@
$NetBSD: patch-src_pl_plperl_plperl.h,v 1.1 2023/09/17 08:53:21 adam Exp $
--- src/pl/plperl/plperl.h.orig 2023-02-06 21:39:04.000000000 +0000
+++ src/pl/plperl/plperl.h
@@ -70,6 +70,11 @@
#define HAS_BOOL 1
#endif
+#ifdef __sun
+#define list_head sun_list_head
+#define list_tail sun_list_tail
+#endif
+
/*
* Newer versions of the perl headers trigger a lot of warnings with our
* compiler flags (at least -Wdeclaration-after-statement,
@@ -122,6 +127,11 @@
#include "XSUB.h"
#endif
+#ifdef __sun
+#undef list_head
+#undef list_tail
+#endif
+
/* put back our *printf macros ... this must match src/include/port.h */
#ifdef vsnprintf
#undef vsnprintf