Work around an arm32 compiler bug

This commit is contained in:
abs 2001-05-18 13:26:23 +00:00
parent 866c6dee43
commit f74924b52f
2 changed files with 19 additions and 1 deletions

View file

@ -1,6 +1,7 @@
$NetBSD: distinfo,v 1.2 2001/04/19 11:07:59 skrll Exp $
$NetBSD: distinfo,v 1.3 2001/05/18 13:26:23 abs Exp $
SHA1 (xscreensaver-3.28.tar.gz) = c1a0de2966f30d56c1660519d450b87e4892c95a
Size (xscreensaver-3.28.tar.gz) = 1497039 bytes
SHA1 (patch-aa) = 397e55a520f1e10e5a1bb1595b6b42e4b70674f1
SHA1 (patch-ab) = fe0c6c387ce5956c7851f8e1f31777961b8bd69a
SHA1 (patch-ae) = c3e7ddffb2caab5c545b0834c93238455852dea6

View file

@ -0,0 +1,17 @@
$NetBSD: patch-ab,v 1.8 2001/05/18 13:26:23 abs Exp $
--- hacks/Makefile.in.orig Fri May 18 13:27:34 2001
+++ hacks/Makefile.in
@@ -363,6 +363,12 @@
.c.o:
$(CC) -c $(INCLUDES) $(DEFS) $(CFLAGS) $(X_CFLAGS) $<
+# Work around gcc codegen bug
+.if $(MACHINE_ARCH) == "arm32"
+distort.o:
+ $(CC) -c $(INCLUDES) $(DEFS) $(CFLAGS) $(X_CFLAGS) -O0 $<
+.endif
+
# Some hacks use a slightly-differently-compiled variant of this file.
# This is how to make the the other .o file from it.
#