Explicitly add the dependency on OpenSSL for encryption and bump the
PKGREVISION. Remove unnecessary patch-af for working around DES API differences between OpenSSL 0.9.6 and 0.9.7.
This commit is contained in:
parent
e027b8d70c
commit
f74dfbfee3
3 changed files with 6 additions and 21 deletions
|
@ -1,7 +1,8 @@
|
|||
# $NetBSD: Makefile,v 1.15 2004/05/15 08:31:22 grant Exp $
|
||||
# $NetBSD: Makefile,v 1.16 2004/12/15 21:16:32 jlam Exp $
|
||||
#
|
||||
|
||||
DISTNAME= cfengine-1.6.5
|
||||
PKGREVISION= 1
|
||||
CATEGORIES= sysutils net
|
||||
MASTER_SITES= ftp://ftp.iu.hio.no/pub/cfengine/ \
|
||||
http://sunsite.utk.edu/ftp/pub/cfengine/cfengine-ftp/
|
||||
|
@ -11,10 +12,13 @@ HOMEPAGE= http://www.cfengine.org/
|
|||
COMMENT= Automate configuration and administration of large systems
|
||||
|
||||
USE_BUILDLINK3= YES
|
||||
USE_OLD_DES_API= YES
|
||||
USE_GNU_TOOLS+= lex
|
||||
GNU_CONFIGURE= YES
|
||||
CONFIGURE_ARGS= --without-pthreads
|
||||
|
||||
.include "../../security/openssl/buildlink3.mk"
|
||||
|
||||
pre-configure:
|
||||
cd ${WRKSRC}; \
|
||||
${ACLOCAL}; \
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: distinfo,v 1.7 2004/09/16 18:08:36 minskim Exp $
|
||||
$NetBSD: distinfo,v 1.8 2004/12/15 21:16:32 jlam Exp $
|
||||
|
||||
SHA1 (cfengine-1.6.5.tar.gz) = 0e40c6094cb4fa12b34920d30e789719e04df511
|
||||
Size (cfengine-1.6.5.tar.gz) = 879792 bytes
|
||||
|
@ -7,5 +7,4 @@ SHA1 (patch-ab) = dc6a9d7381778b5f3c2fdb16e65204d5c3faac0d
|
|||
SHA1 (patch-ac) = 417ca3785c7d7d668a08d4aad298a8d2ec4a6571
|
||||
SHA1 (patch-ad) = 047e02555d541c22f07cb3e3a102beb0be32df6d
|
||||
SHA1 (patch-ae) = 283e129a515b664f651fd2272e3f9f8d7f99b60f
|
||||
SHA1 (patch-af) = 202bd09675ce4e861d2df01f6e52a05dcb4a4a7c
|
||||
SHA1 (patch-ag) = 228f0934e2e9409615b868a8c9a0a5829e4f9196
|
||||
|
|
|
@ -1,18 +0,0 @@
|
|||
$NetBSD: patch-af,v 1.4 2004/09/10 21:12:21 wiz Exp $
|
||||
|
||||
--- src/encrypt.c.orig 2002-06-20 15:38:34.000000000 +0200
|
||||
+++ src/encrypt.c
|
||||
@@ -38,7 +38,12 @@
|
||||
|
||||
#if defined(HAVE_LIBCRYPTO) || defined(HAVE_OPENSSL_DES_H)
|
||||
/* must be des.h from OpenSSL */
|
||||
-# include <openssl/des.h>
|
||||
+# include <openssl/opensslv.h>
|
||||
+# if OPENSSL_VERSION_NUMBER < 0x0090700fL
|
||||
+# include <openssl/des.h>
|
||||
+# else
|
||||
+# include <des.h>
|
||||
+# endif
|
||||
# define USE_SSL 1
|
||||
#endif
|
||||
|
Loading…
Reference in a new issue