patch for kde security advisory 20100825-1
This commit is contained in:
parent
df63bd6dd0
commit
f78975a1a4
3 changed files with 38 additions and 3 deletions
|
@ -1,7 +1,7 @@
|
|||
# $NetBSD: Makefile,v 1.11 2010/09/14 11:01:17 wiz Exp $
|
||||
# $NetBSD: Makefile,v 1.12 2010/09/15 19:47:33 markd Exp $
|
||||
|
||||
DISTNAME= kdegraphics-${_KDE_VERSION}
|
||||
PKGREVISION= 2
|
||||
PKGREVISION= 3
|
||||
CATEGORIES= graphics
|
||||
COMMENT= Graphical tools for the KDE desktop
|
||||
|
||||
|
|
|
@ -1,5 +1,6 @@
|
|||
$NetBSD: distinfo,v 1.9 2010/07/04 11:02:32 markd Exp $
|
||||
$NetBSD: distinfo,v 1.10 2010/09/15 19:47:33 markd Exp $
|
||||
|
||||
SHA1 (kdegraphics-4.4.5.tar.bz2) = 9d878e917de53a0b70df7d1d9d9c57f771e4be72
|
||||
RMD160 (kdegraphics-4.4.5.tar.bz2) = f574b9b5f89b868ccab250093ef75ab8db7d4833
|
||||
Size (kdegraphics-4.4.5.tar.bz2) = 3822688 bytes
|
||||
SHA1 (patch-aa) = 692a789e1652fb38d683cdb41a02769bb60139f7
|
||||
|
|
34
graphics/kdegraphics4/patches/patch-aa
Normal file
34
graphics/kdegraphics4/patches/patch-aa
Normal file
|
@ -0,0 +1,34 @@
|
|||
$NetBSD: patch-aa,v 1.1 2010/09/15 19:47:33 markd Exp $
|
||||
|
||||
svn r1167826 for advisory 20100825-1
|
||||
|
||||
Index: okular/generators/plucker/unpluck/image.cpp
|
||||
===================================================================
|
||||
--- okular/generators/plucker/unpluck/image.cpp (revision 1167825)
|
||||
+++ okular/generators/plucker/unpluck/image.cpp (revision 1167826)
|
||||
@@ -289,8 +289,23 @@
|
||||
for (j = 0; j < bytes_per_row;) {
|
||||
incount = *palm_ptr++;
|
||||
inval = *palm_ptr++;
|
||||
- memset (rowbuf + j, inval, incount);
|
||||
- j += incount;
|
||||
+ if (incount + j <= bytes_per_row * width)
|
||||
+ {
|
||||
+ memset (rowbuf + j, inval, incount);
|
||||
+ j += incount;
|
||||
+ }
|
||||
+ else
|
||||
+ {
|
||||
+ free (rowbuf);
|
||||
+ free (lastrow);
|
||||
+ free (jpeg_row);
|
||||
+
|
||||
+ jpeg_destroy_compress (&cinfo);
|
||||
+
|
||||
+ fclose( outfile );
|
||||
+
|
||||
+ return false;
|
||||
+ }
|
||||
}
|
||||
}
|
||||
else if ((flags & PALM_IS_COMPRESSED_FLAG)
|
Loading…
Reference in a new issue