Update to 8.0.

fix PR pkg/44465

Changelog:
2010-01-08    <Jim@LS-RED>

	* Version 8.0 released

2010-01-05    <Jim@LS-RED>

	* xspim/Imakefile, spim/Makefile Jaymie Strecker [JStrecker@wooster.edu]:
	Change install path from /usr to /usr/local.
	Removed -D option, which doesn't exists on MacOS.

	* pervasive:
	Change license to a BSD license, update copyright notices, and
	eliminated references to my old email address.

2009-12-05    <Jim@LS1>

	* CPU/spim-utils.c (initialize_run_stack) [÷ýŽ´ö´ÊîÜ® bupjae@hotmail.com]:
	Simplify alignment of data on stack to ensure enough room is left
	for environment and args at top of stack.

	* PCSpim/PCSpimView.cpp:
	Initialize stack with arguments when running program from run dialog.

	* spim/spim.c (read_input) [Adam Wolfe Gordon
	adam.wolfegordon@gmail.com}:
	read_input filled buffer with last character of file not terminated by
	newline.

	* Documentation/spim.html [Dave Comer dmcomer@dmcmicro.com]:
	Links to MIPS documentation were broken.

2009-09-22    <Jim@LS1>

	* spim/spim.c (main) [Ohad Kammar ohad.kammar@ed.ac.uk]:
	Did not return value from exit syscall.

2009-03-01  James larus  <larus@ubuntu-laptop>

	* xspim/buttons.c [Karl Ljungkvist k.ljungkvist@gmail.com]:
	Step command reinitialized the stack, which changed registers (argc, argv).

2009-03-01    <Jim@LS1>

	* Documentation/spim.html:
	Updated web page to remove reference to spim source in PCSpim source distribution.

	* PCSpim/PCSpimView.{cpp, h}, SettingsDlg.cpp, BreakpointDlg.cpp, MainFrm.{cpp, h}:
	Force redisplay of data segment in situations in which register
	values may have changed, such as $sp. Some cleanup as well.

	* PCSpim/PCSpimView.cpp:
	Properly initialize the PC at the first invocation of the step operation.

	* PCSpim/PCSpimView.cpp, spim/spim.c [Pierce, Bill [pierce@hood.edu]:
	Initialize the stack when initializing the world, so the stack is
	initialized when single stepping as well as running.

2009-02-13    <Jim@LS1>

	* CPU/mem.c (bad_mem_write) [phong le phongle@nlsim.com]:
	Major memory leak: instructions overwritten by self-modifying code
	were not freed!

	* spim/Configure, xspim/Configure [Carlos Pantelides carlos_pantelides@yahoo.com]:
	Added test for 64 bit Linux systems.

2009-01-22    <Jim@LS1>

	* spim/Makefile:
	Fix install commands so exceptions.s is installed at /usr/lib/spim.
	Rerelease of spim.tar.*

2009-01-14    <Jim@LS1>

	* pcspim.zip:
	Rerelease of pcspim to correct installer problem. Visual Studio
	9.0 required new crt and mfc libraries.

2009-01-01    <Jim@LS1>

	* Released version 7.4

2009-01-01  James larus  <larus@ubuntu-laptop>

	* xspim/Imakefile, spim/Makefile:
	Fix install directories for Linux.

2008-11-29    <Jim@LS1>

	* xspim/buttons.c [karl.marklund@gmail.com]:
	Command line arguments for assembly code not properly set.

2008-11-28    <Jim@LS1>

	* PCSpim/PCSpimView.{cpp,h}:
	Command line arguments not set properly on second and subsequent runs.

2008-11-01    <Jim@LS1>

	* Version 7.4

	* Tests/tt.core.s (madd_) Miguel BarŽÃŽ£o [mjsb@di.uevora.pt]:
	Added test for madd(2, -1) with (hi, lo) = (0, -1).

2008-05-18    <Jim@LS1>

	* CPU/scanner.l [liblit@cs.wisc.edu]:
	Fix for flex 2.5.33 was too specific for that version and failed
	on later versions, which propagated the change recoganized by fix
	of2005-02-05.

2007-05-20    <Jim@LS1>

	* CPU/run.c (run_spim):
	Fixed handling of borrow from subtract of low-order word in MSUB
	and MSUBU

2007-05-03    <Jim@LS1>

	* CPU/run.c Tim ODonnell [timodonnell@gmail.com]:
	Fixed handling of overflow from add of low-order word in MADD and
	MADDU.

2007-04-15    <Jim@LS1>

	* Documentation/spim.html:
	Updated MIPS documenation links to reflect new file
	versions. Included link to Nokia 660 port.

2007-01-14    <Jim@LS1>

	* CPU/inst.c (inst_decode) Cai Hongxu [caihongxu@gmail.com]:
	Did not correctly decode SPECIAL2 instructions (e.g., madd).

2006-08-28    <Jim@LS1>

	* spim/Makefile:
	Explicitly include exception handler path for "make test" to
	eliminate need to install it before running test.
This commit is contained in:
ryoon 2011-02-05 13:38:14 +00:00
parent 02a858be96
commit f7a477996a
6 changed files with 61 additions and 85 deletions

View file

@ -1,31 +1,23 @@
# $NetBSD: Makefile,v 1.39 2009/05/19 08:59:13 wiz Exp $
# $NetBSD: Makefile,v 1.40 2011/02/05 13:38:14 ryoon Exp $
DISTNAME= spim-7.3
DISTNAME= spim-8.0
CATEGORIES= emulators
MASTER_SITES= http://pages.cs.wisc.edu/~larus/SPIM/
MASTER_SITES= http://pages.cs.wisc.edu/~larus/SPIM/
MAINTAINER= pkgsrc-users@NetBSD.org
HOMEPAGE= http://pages.cs.wisc.edu/~larus/spim.html
HOMEPAGE= http://spimsimulator.sourceforge.net/
COMMENT= MIPS R2000 Simulator
LICENSE= spim-license
RESTRICTED= No permission to copy, and prohibited commercially.
NO_SRC_ON_CDROM= ${RESTRICTED}
NO_BIN_ON_CDROM= ${RESTRICTED}
NO_SRC_ON_FTP= ${RESTRICTED}
NO_BIN_ON_FTP= ${RESTRICTED}
LICENSE= modified-bsd
PKG_DESTDIR_SUPPORT= user-destdir
WRKSRC= ${WRKDIR}/${PKGNAME_NOREV}
HAS_CONFIGURE= yes
CONFIGURE_DIRS= xspim
BUILD_DIRS= spim xspim
CONFIGURE_SCRIPT= ./Configure
USE_IMAKE= yes
USE_TOOLS+= gzip flex yacc
XMKMF= ${X11BASE}/bin/xmkmf # don't specify -a option
INSTALL_TARGET= install
INSTALL_TARGET= install install-man
SUBST_CLASSES+= cpudir
SUBST_STAGE.cpudir= post-patch
@ -33,25 +25,25 @@ SUBST_MESSAGE.cpudir= rename CPU_DIR
SUBST_FILES.cpudir= spim/Makefile xspim/Imakefile
SUBST_SED.cpudir= -e s:CPU_DIR:CPUDIR:
INSTALLATION_DIRS= bin share/spim share/doc/spim man/man1
INSTALLATION_DIRS= share/doc/${PKGBASE} ${PKGMANDIR}/man1
post-configure:
cd ${WRKSRC}/spim && ${SETENV} ${_CONFIGURE_SCRIPT_ENV} \
${CONFIG_SHELL} ${CONFIG_SHELL_FLAGS} \
${CONFIGURE_SCRIPT} ${CONFIGURE_ARGS}
post-install:
@${ECHO} "Installing spim/xspim documentation"
${INSTALL_DATA} ${WRKSRC}/Documentation/spim.man \
${DESTDIR}${PREFIX}/man/man1/spim.1
${INSTALL_DATA} ${WRKSRC}/Documentation/xspim.man \
${DESTDIR}${PREFIX}/man/man1/xspim.1
${INSTALL_DATA} ${WRKSRC}/Documentation/TeX/spim.tex \
${DESTDIR}${PREFIX}/share/doc/spim
${INSTALL_DATA} ${WRKSRC}/Documentation/TeX/*.id \
${DESTDIR}${PREFIX}/share/doc/spim
${INSTALL_DATA} ${WRKSRC}/Documentation/TeX/cycle.ps \
${DESTDIR}${PREFIX}/share/doc/spim
#post-install:
# @${ECHO} "Installing spim/xspim documentation"
# ${INSTALL_DATA} ${WRKSRC}/Documentation/spim.man \
# ${DESTDIR}${PREFIX}/${PKGMANDIR}/man1/spim.1
# ${INSTALL_DATA} ${WRKSRC}/Documentation/xspim.man \
# ${DESTDIR}${PREFIX}/${PKGMANDIR}/man1/xspim.1
# ${INSTALL_DATA} ${WRKSRC}/Documentation/TeX/spim.tex \
# ${DESTDIR}${PREFIX}/share/doc/${PKGBASE}
# ${INSTALL_DATA} ${WRKSRC}/Documentation/TeX/*.id \
# ${DESTDIR}${PREFIX}/share/doc/${PKGBASE}
# ${INSTALL_DATA} ${WRKSRC}/Documentation/TeX/cycle.ps \
# ${DESTDIR}${PREFIX}/share/doc/${PKGBASE}
.include "../../x11/libXaw/buildlink3.mk"
.include "../../x11/libXp/buildlink3.mk"

View file

@ -1,10 +1,9 @@
$NetBSD: distinfo,v 1.11 2009/03/22 19:55:42 markd Exp $
$NetBSD: distinfo,v 1.12 2011/02/05 13:38:14 ryoon Exp $
SHA1 (spim-7.3.tar.gz) = 630b75ebc9365093e1b3d0c98ca0524f772d8647
RMD160 (spim-7.3.tar.gz) = f87116820755ff76087889bbd0f39eaacbce201a
Size (spim-7.3.tar.gz) = 347226 bytes
SHA1 (patch-aa) = 8dfa13e5d986d02bd0a995401b0a8582c849a0b9
SHA1 (patch-ab) = 175b8ac38b140c8b284a21663f2be86cc6196979
SHA1 (patch-ac) = 198d1d95302463348043281ed4e2e14d83fb5855
SHA1 (patch-ad) = 66a7b90a20764eb022e45552775be21fcfef6b5a
SHA1 (patch-ae) = 1f5610a0458acb132a108bfc29504b1d05fca5f0
SHA1 (spim-8.0.tar.gz) = 979b91e0acb792310593d31aa65e49cccec73036
RMD160 (spim-8.0.tar.gz) = 129e61a6ee2f338abe2eafb175ac16fc0ebd20c7
Size (spim-8.0.tar.gz) = 355204 bytes
SHA1 (patch-aa) = 8232ff358f1bf2ede3216187faf77aad85b1da87
SHA1 (patch-ab) = 6f52160d99f363dc0b8d327e05bee2470b59dd41
SHA1 (patch-ac) = 0150642458e8e7feabf7ab02ed219107c4e5b778
SHA1 (patch-ad) = 056ef015de5daff3003a834ff4867f97db70c79f

View file

@ -1,34 +1,34 @@
$NetBSD: patch-aa,v 1.6 2009/03/22 19:55:42 markd Exp $
$NetBSD: patch-aa,v 1.7 2011/02/05 13:38:15 ryoon Exp $
--- xspim/Imakefile.orig 2006-08-29 14:23:19.000000000 +1200
--- xspim/Imakefile.orig 2010-01-09 05:22:58.000000000 +0000
+++ xspim/Imakefile
@@ -33,13 +33,13 @@
@@ -43,13 +43,13 @@
#
# Full path for the directory that will hold the executable files:
-BIN_DIR = /usr/local/bin
+# BIN_DIR = /usr/local/bin
+#BIN_DIR = /usr/local/bin
# Full path for the directory that will hold the exception handler:
-EXCEPTION_DIR = /usr/local/lib
-EXCEPTION_DIR = /usr/local/lib/spim
+EXCEPTION_DIR = $(PREFIX)/share/spim
# Full path for the directory that will hold the man files:
-MAN_DIR = /usr/man/mann
+# MAN_DIR = /usr/man/mann
-MAN_DIR = /usr/local/man/en
+#MAN_DIR = /usr/local/man/en
# If you have flex, use it instead of lex. If you use flex, define this
@@ -112,7 +112,7 @@ force: configuration
@@ -122,7 +122,7 @@ force: configuration
configuration:
./Configure
-InstallProgram(xspim,$(BIN_DIR))
+InstallProgram(xspim,$(BINDIR))
InstallNonExec($(CPU_DIR)/exceptions.s,$(EXCEPTION_DIR))
InstallNonExec($(CPU_DIR)/exceptions.s,$(EXCEPTION_DIR)/exceptions.s)
#InstallManPage($(DOC_DIR)/xspim,$(MAN_DIR))
@@ -147,7 +147,7 @@ very-clean: clean
@@ -157,7 +157,7 @@ very-clean: clean
rm -f configuration
makedepend: y.tab.c

View file

@ -1,11 +1,12 @@
$NetBSD: patch-ab,v 1.2 2009/03/22 19:55:42 markd Exp $
$NetBSD: patch-ab,v 1.3 2011/02/05 13:38:15 ryoon Exp $
--- xspim/Configure.orig 2006-08-29 14:23:19.000000000 +1200
--- xspim/Configure.orig 2010-01-09 05:22:58.000000000 +0000
+++ xspim/Configure
@@ -153,13 +153,14 @@ fi;
@@ -170,14 +170,14 @@ fi;
echo
echo Checking for /usr/include/termios.h
-echo Checking for /usr/include/termios.h
-if [ -f /usr/include/termios.h ]; then
- echo "-DUSE_TERMIOS" >> ./configuration
- echo "Yes, it is there"
@ -13,7 +14,7 @@ $NetBSD: patch-ab,v 1.2 2009/03/22 19:55:42 markd Exp $
- # No termios
- echo "No, it is not there"
-fi;
+# The pkg uses unportable termios.h stuff, so disable it.
+#echo Checking for /usr/include/termios.h
+#if [ -f /usr/include/termios.h ]; then
+# echo "-DUSE_TERMIOS" >> ./configuration
+# echo "Yes, it is there"

View file

@ -1,8 +1,8 @@
$NetBSD: patch-ac,v 1.2 2009/03/22 19:55:42 markd Exp $
$NetBSD: patch-ac,v 1.3 2011/02/05 13:38:15 ryoon Exp $
--- spim/Configure.orig 2006-08-29 14:23:19.000000000 +1200
--- spim/Configure.orig 2010-01-09 05:22:57.000000000 +0000
+++ spim/Configure
@@ -152,14 +152,15 @@ fi;
@@ -172,14 +172,14 @@ fi;
echo
@ -14,7 +14,6 @@ $NetBSD: patch-ac,v 1.2 2009/03/22 19:55:42 markd Exp $
- # No termios
- echo "No, it is not there"
-fi;
+# The pkg uses unportable termios.h stuff, so disable it.
+#echo Checking for /usr/include/termios.h
+#if [ -f /usr/include/termios.h ]; then
+# echo "-DUSE_TERMIOS" >> ./configuration

View file

@ -1,8 +1,8 @@
$NetBSD: patch-ad,v 1.2 2009/03/22 19:55:42 markd Exp $
$NetBSD: patch-ad,v 1.3 2011/02/05 13:38:15 ryoon Exp $
--- spim/Makefile.orig 2006-08-29 14:23:19.000000000 +1200
--- spim/Makefile.orig 2010-01-09 05:22:57.000000000 +0000
+++ spim/Makefile
@@ -54,13 +54,13 @@ DOC_DIR = ../Documentation
@@ -66,13 +66,13 @@ DOC_DIR = ../Documentation
# Full path for the directory that will hold the executable files:
@ -10,16 +10,16 @@ $NetBSD: patch-ad,v 1.2 2009/03/22 19:55:42 markd Exp $
+BIN_DIR = $(DESTDIR)$(PREFIX)/bin
# Full path for the directory that will hold the exception handler:
-EXCEPTION_DIR = /usr/local/lib
+EXCEPTION_DIR = $(PREFIX)/share/spim
-EXCEPTION_DIR = /usr/local/lib/spim
+EXCEPTION_DIR = $(DESTDIR)$(PREFIX)/share/spim
# Full path for the directory that will hold the man files:
-MAN_DIR = /usr/man/mann
+MAN_DIR = $(DESTDIR)$(PREFIX)/man/man1
-MAN_DIR = /usr/local/man/en
+MAN_DIR = $(DESTDIR)$(PREFIX)/$(PKGMANDIR)/man1
# If you have flex, use it instead of lex. If you use flex, define this
@@ -92,7 +92,7 @@ ENDIAN=`cat configuration`
@@ -104,9 +104,9 @@ ENDIAN=`cat configuration`
DEFINES = $(ENDIAN) $(MEM_SIZES) -DDEFAULT_EXCEPTION_HANDLER="\"$(EXCEPTION_DIR)/exceptions.s\"" -DSPIM_VERSION="\"`cat ../VERSION`\""
@ -29,7 +29,9 @@ $NetBSD: patch-ad,v 1.2 2009/03/22 19:55:42 markd Exp $
-YFLAGS = -d --file-prefix=y
+YFLAGS = -d # --file-prefix=y
YCFLAGS =
@@ -108,6 +108,7 @@ LEXCFLAGS = -O $(CFLAGS)
LDFLAGS = -lm
CSH = bash
@@ -120,6 +120,7 @@ LEXCFLAGS = -O $(CFLAGS)
OBJS = spim-utils.o run.o mem.o inst.o data.o sym-tbl.o y.tab.o lex.yy.o \
syscall.o display-utils.o string-stream.o
@ -37,29 +39,12 @@ $NetBSD: patch-ad,v 1.2 2009/03/22 19:55:42 markd Exp $
spim: force
make -f Makefile spim2
@@ -174,11 +175,11 @@ clean:
rm -f spim spim.exe *.o TAGS test.out lex.yy.c y.tab.c y.tab.h y.output
install: spim
install -c -s spim $(BIN_DIR)
- install -c -m 0444 $(CPU_DIR)/exceptions.s $(EXCEPTION_DIR)
+ install -c -m 0444 $(CPU_DIR)/exceptions.s $(DESTDIR)$(EXCEPTION_DIR)
-install-man:
- install -c -m 0444 $(DOC_DIR)/spim.man $(MAN_DIR)
+install.man:
+ install -c -m 0444 $(DOC_DIR)/spim.man $(MAN_DIR)/spim.1
very-clean: clean
rm -f configuration
@@ -195,8 +196,8 @@ splint: spim
@@ -211,7 +212,7 @@ splint: spim
y.tab.h: y.tab.c
y.tab.c: $(CPU_DIR)/parser.y
- bison $(YFLAGS) $(CPU_DIR)/parser.y
+ $(YACC) $(YFLAGS) $(CPUDIR)/parser.y
y.tab.o: y.tab.c
$(CC) $(CFLAGS) $(YCFLAGS) -c y.tab.c
$(CC) $(CFLAGS) $(YCFLAGS) -c y.tab.c