Switched to CMake; removed gimp dependency.

This commit is contained in:
adam 2014-07-10 13:41:48 +00:00
parent 9b613567b1
commit f7f054bff5
4 changed files with 31 additions and 8 deletions

View file

@ -1,7 +1,7 @@
# $NetBSD: Makefile,v 1.15 2014/06/29 21:42:25 dholland Exp $
# $NetBSD: Makefile,v 1.16 2014/07/10 13:41:48 adam Exp $
DISTNAME= libpano13-2.9.19
PKGREVISION= 1
PKGREVISION= 2
CATEGORIES= graphics
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=panotools/}
@ -10,9 +10,10 @@ HOMEPAGE= http://panotools.sourceforge.net/
COMMENT= Cross-platform library behind Panorama Tools and other stitchers
LICENSE= gnu-gpl-v2
MAKE_JOBS_SAFE= no
USE_CMAKE= yes
USE_LANGUAGES= c c++
USE_LIBTOOL= yes
GNU_CONFIGURE= yes
PKGCONFIG_OVERRIDE= libpano13.pc.in
.include "../../mk/bsd.prefs.mk"
@ -22,7 +23,6 @@ BUILDLINK_TRANSFORM+= rm:-lsunmath
.endif
.include "../../mk/jpeg.buildlink3.mk"
.include "../../graphics/gimp/buildlink3.mk"
.include "../../graphics/png/buildlink3.mk"
.include "../../graphics/tiff/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

View file

@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.2 2010/09/15 10:13:26 adam Exp $
@comment $NetBSD: PLIST,v 1.3 2014/07/10 13:41:48 adam Exp $
bin/PTblender
bin/PTcrop
bin/PTinfo
@ -20,7 +20,10 @@ include/pano13/pteditor.h
include/pano13/ptutils.h
include/pano13/queryfeature.h
include/pano13/version.h
lib/libpano13.la
lib/libpano13.a
lib/libpano13.so
lib/libpano13.so.3
lib/libpano13.so.3.0.0
lib/pkgconfig/libpano13.pc
man/man1/PTAInterpolate.1
man/man1/PTblender.1
@ -34,3 +37,10 @@ man/man1/PTtiff2psd.1
man/man1/PTtiffdump.1
man/man1/PTuncrop.1
man/man1/panoinfo.1
share/pano13/doc/AUTHORS
share/pano13/doc/COPYING
share/pano13/doc/Optimize.txt
share/pano13/doc/PTblender.readme
share/pano13/doc/PTmender.readme
share/pano13/doc/README
share/pano13/doc/stitch.txt

View file

@ -1,5 +1,6 @@
$NetBSD: distinfo,v 1.7 2014/06/05 06:18:28 adam Exp $
$NetBSD: distinfo,v 1.8 2014/07/10 13:41:48 adam Exp $
SHA1 (libpano13-2.9.19.tar.gz) = 85d8d94c96780fa5b6df2c2e4929f8d20557f128
RMD160 (libpano13-2.9.19.tar.gz) = 88b8770815d3a8bd41cfe367ae19daffcf2ec76a
Size (libpano13-2.9.19.tar.gz) = 3527845 bytes
SHA1 (patch-man_CMakeLists.txt) = fe68c0f3a53f496dfb9a09583b02fe3a37a225e7

View file

@ -0,0 +1,12 @@
$NetBSD: patch-man_CMakeLists.txt,v 1.1 2014/07/10 13:41:48 adam Exp $
Fix man path.
--- man/CMakeLists.txt.orig 2014-07-10 11:21:45.000000000 +0000
+++ man/CMakeLists.txt
@@ -25,4 +25,4 @@ endforeach(_m)
add_custom_target(man ALL DEPENDS ${_manuals})
-install(FILES ${_manuals} DESTINATION "share/man/man1" COMPONENT doc)
+install(FILES ${_manuals} DESTINATION "man/man1" COMPONENT doc)