p5-LWP-Protocol-https: update to 6.11.

6.11      2023-07-09 15:10:30Z
    - Remove Authority section from dist.ini (GH#64) (Olaf Alders)
    - Add very basic diagnostic information via test (GH#73) (Olaf Alders)
    - CVE-2014-3230 - don't disable verification if only hostnames should not
      (GH#14) (Steffen Ullrich)
    - Make explicit requirement of Mozilla::CA obsolete (GH#72) (Steffen
      Ullrich and Olaf Alders)
    - Remove _in_san and _cn_match. Empty out the _check_sock hook (GH#71)
      (Chase Whitener)
    - Use warnings (GH#69) (Pete Houston)
This commit is contained in:
wiz 2024-01-04 10:55:23 +00:00
parent 73f31e6a64
commit f7ff8cbc1b
4 changed files with 6 additions and 48 deletions

View file

@ -1,8 +1,7 @@
# $NetBSD: Makefile,v 1.29 2023/07/06 09:42:48 wiz Exp $
# $NetBSD: Makefile,v 1.30 2024/01/04 10:55:23 wiz Exp $
DISTNAME= LWP-Protocol-https-6.10
DISTNAME= LWP-Protocol-https-6.11
PKGNAME= p5-${DISTNAME}
PKGREVISION= 3
CATEGORIES= www perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN:=../../authors/id/O/OA/OALDERS/}

View file

@ -1,7 +1,5 @@
$NetBSD: distinfo,v 1.11 2021/10/26 11:30:10 nia Exp $
$NetBSD: distinfo,v 1.12 2024/01/04 10:55:23 wiz Exp $
BLAKE2s (LWP-Protocol-https-6.10.tar.gz) = 43daacda03e6dc9342d259cc5d115ab922db39fc45cf63d00eee32744f98ef8b
SHA512 (LWP-Protocol-https-6.10.tar.gz) = 4d3c89dab6fadcb574c176977ca6debba177ee3f817e87319d9cd81e0a0b09214e271c2e97edc456dad2f4a1ebf8c6266a4ae52c3a93144880a5b32db97e7a31
Size (LWP-Protocol-https-6.10.tar.gz) = 33691 bytes
SHA1 (patch-lib_LWP_Protocol_https.pm) = b4129bf47059955b8527761c81674ee44318f8a0
SHA1 (patch-t_https__proxy.t) = 0653e29cdbe683329ccfa065d527a2e37bd3fde7
BLAKE2s (LWP-Protocol-https-6.11.tar.gz) = 03ed33635863d9ec8953566a8cbcbd729db650c88336be1c38f0f12e76b2d6bd
SHA512 (LWP-Protocol-https-6.11.tar.gz) = 1e74c45898778c58d00eefbdd04a3ed47cf38164296278bec66c9b85f48ad635931873d2bf5423be8562df2c22b4bbf8eff0502bd29ba1c790bbbf76f3616ecf
Size (LWP-Protocol-https-6.11.tar.gz) = 32599 bytes

View file

@ -1,20 +0,0 @@
$NetBSD: patch-lib_LWP_Protocol_https.pm,v 1.1 2014/05/15 10:17:38 wiz Exp $
Fix for CVE-2014-3230 from
https://github.com/libwww-perl/lwp-protocol-https/pull/14
--- lib/LWP/Protocol/https.pm.orig 2014-04-18 16:33:26.000000000 +0000
+++ lib/LWP/Protocol/https.pm
@@ -21,7 +21,11 @@ sub _extra_sock_opts
$ssl_opts{SSL_verifycn_scheme} = 'www';
}
else {
- $ssl_opts{SSL_verify_mode} = 0;
+ if ( $Net::HTTPS::SSL_SOCKET_CLASS eq 'Net::SSL' ) {
+ $ssl_opts{SSL_verifycn_scheme} = '';
+ } else {
+ $ssl_opts{SSL_verifycn_scheme} = 'none';
+ }
}
if ($ssl_opts{SSL_verify_mode}) {
unless (exists $ssl_opts{SSL_ca_file} || exists $ssl_opts{SSL_ca_path}) {

View file

@ -1,19 +0,0 @@
$NetBSD: patch-t_https__proxy.t,v 1.1 2014/05/15 10:17:38 wiz Exp $
Fix for CVE-2014-3230 from
https://github.com/libwww-perl/lwp-protocol-https/pull/14
--- t/https_proxy.t.orig 2014-04-18 16:21:26.000000000 +0000
+++ t/https_proxy.t
@@ -66,7 +66,10 @@ my %ua;
$ua{noproxy} = LWP::UserAgent->new(
keep_alive => 10, # size of connection cache
# server does not know the expected name and returns generic certificate
- ssl_opts => { verify_hostname => 0 }
+ ssl_opts => {
+ verify_hostname => 0,
+ SSL_ca_file => $cafile,
+ }
);
$ua{proxy} = LWP::UserAgent->new(