Add @PREFIX@/lib to SEARCH_LIB in configure to end up with a sane search
path on SunOS, where a transformation from 'lib' to 'lib/64' is performend automatically when ABI=64.
This commit is contained in:
parent
dc3100cf07
commit
f821bd4059
2 changed files with 11 additions and 4 deletions
|
@ -1,4 +1,4 @@
|
|||
# $NetBSD: Makefile.common,v 1.11 2012/01/20 12:02:23 drochner Exp $
|
||||
# $NetBSD: Makefile.common,v 1.12 2012/03/12 10:39:13 fhajny Exp $
|
||||
#
|
||||
# used by x11/wxGTK28/Makefile
|
||||
# used by x11/wxGTK28-contrib/Makefile
|
||||
|
@ -53,6 +53,7 @@ SUBST_STAGE.fix-paths= pre-configure
|
|||
SUBST_MESSAGE.fix-paths= Fixing absolute paths.
|
||||
SUBST_FILES.fix-paths= configure
|
||||
SUBST_SED.fix-paths= -e 's,/usr/pkg/include,${PREFIX}/include,g'
|
||||
SUBST_SED.fix-paths+= -e 's,@PREFIX@,${PREFIX},g'
|
||||
|
||||
pre-configure:
|
||||
mkdir ${WRKSRC}/build-non-unicode ${WRKSRC}/build-unicode
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: patch-aa,v 1.4 2012/01/27 06:07:48 sbd Exp $
|
||||
$NetBSD: patch-aa,v 1.5 2012/03/12 10:39:13 fhajny Exp $
|
||||
|
||||
--- configure.orig 2009-03-06 12:17:38.000000000 +0000
|
||||
+++ configure
|
||||
|
@ -37,7 +37,7 @@ $NetBSD: patch-aa,v 1.4 2012/01/27 06:07:48 sbd Exp $
|
|||
/usr/X11R6/include \
|
||||
/usr/X11R6.4/include \
|
||||
\
|
||||
@@ -25055,6 +25056,7 @@ fi
|
||||
@@ -25055,11 +25056,12 @@ fi
|
||||
wx_cv_std_libpath="lib";
|
||||
;;
|
||||
esac
|
||||
|
@ -45,6 +45,12 @@ $NetBSD: patch-aa,v 1.4 2012/01/27 06:07:48 sbd Exp $
|
|||
|
||||
echo "$as_me:$LINENO: result: $wx_cv_std_libpath" >&5
|
||||
echo "${ECHO_T}$wx_cv_std_libpath" >&6
|
||||
|
||||
-SEARCH_LIB="`echo "$SEARCH_INCLUDE" | sed s@include@$wx_cv_std_libpath@g` /usr/$wx_cv_std_libpath"
|
||||
+SEARCH_LIB="`echo "$SEARCH_INCLUDE" | sed s@include@$wx_cv_std_libpath@g` /usr/$wx_cv_std_libpath @PREFIX@/lib"
|
||||
|
||||
if test "$build" != "$host" -a "$GCC" = yes; then
|
||||
if cross_root=`$CC -print-prog-name=ld 2>/dev/null`; then
|
||||
@@ -26379,9 +26381,9 @@ echo "${ECHO_T}$ac_cv_header_png_h" >&6
|
||||
|
||||
|
||||
|
@ -98,7 +104,7 @@ $NetBSD: patch-aa,v 1.4 2012/01/27 06:07:48 sbd Exp $
|
|||
PNG_LINK=" -lpng -lz"
|
||||
fi
|
||||
|
||||
@@ -39478,6 +39480,9 @@ echo "$as_me: WARNING: BeOS threads are
|
||||
@@ -39478,6 +39480,9 @@ echo "$as_me: WARNING: BeOS threads are
|
||||
THREAD_OPTS="-mt $THREAD_OPTS"
|
||||
fi
|
||||
;;
|
||||
|
|
Loading…
Reference in a new issue