Initial import of tc-2.2.1, another Japanese imput method.

TC2 provides T-Code and TUT-Code input methods for Emacs users. T-Code
and TUT-Code are called "Kanji Direct Input Method", and desiged to be
more efficient Japanese input method than Kana-Kanji translation.

For more infomation, please look into these web sites.

T-Code   -> http://openlab.ring.gr.jp/tcode/index.html
TUT-Code -> http://www.crew.sfc.keio.ac.jp/~chk/
This commit is contained in:
uebayasi 2002-09-15 06:31:42 +00:00
parent f666ae51e6
commit f85cd2132e
5 changed files with 111 additions and 0 deletions

8
inputmethod/tc/DESCR Normal file
View file

@ -0,0 +1,8 @@
TC2 provides T-Code and TUT-Code input methods for Emacs users. T-Code
and TUT-Code are called "Kanji Direct Input Method", and desiged to be
more efficient Japanese input method than Kana-Kanji translation.
For more infomation, please look into these web sites.
T-Code -> http://openlab.ring.gr.jp/tcode/index.html
TUT-Code -> http://www.crew.sfc.keio.ac.jp/~chk/

25
inputmethod/tc/Makefile Normal file
View file

@ -0,0 +1,25 @@
# $NetBSD: Makefile,v 1.1.1.1 2002/09/15 06:31:42 uebayasi Exp $
#
DISTNAME= tc-2.2.1
CATEGORIES= japanese inputmethod
MASTER_SITES= http://openlab.ring.gr.jp/tcode/resources/soft/
MAINTAINER= tech-pkg-ja@jp.netbsd.org
HOMEPAGE= http://openlab.ring.gr.jp/tcode/tc2/index.html
COMMENT= T-Code driver for Emacs
.include "../../mk/emacs.mk"
.if ${EMACS_FLAVOR} == "emacs"
.elif ${EMACS_FLAVOR} == "xemacs"
CONFIGURE_ARGS+=--with-emacs=xemacs
CONFIGURE_ARGS+=--with-lispdir=${EMACS_LISPPREFIX}/tc
.endif
USE_GMAKE= YES
GNU_CONFIGURE= YES
INFO_FILES= tc.info
.include "../../mk/texinfo.mk"
.include "../../mk/bsd.pkg.mk"

61
inputmethod/tc/PLIST Normal file
View file

@ -0,0 +1,61 @@
@comment $NetBSD: PLIST,v 1.1.1.1 2002/09/15 06:31:42 uebayasi Exp $
bin/tc-mkmzdic
bin/tc-inst
@unexec install-info --delete --info-dir=%D/info %D/info/tc.info
info/tc.info
@exec install-info --info-dir=%D/info %D/info/tc.info
lib/tc/combine
lib/tc/reduce
${EMACS_LISPPREFIX}/tc/eelll.el
${EMACS_LISPPREFIX}/tc/eelll.elc
${EMACS_LISPPREFIX}/tc/tc-bushu.el
${EMACS_LISPPREFIX}/tc/tc-bushu.elc
${EMACS_LISPPREFIX}/tc/tc-help.el
${EMACS_LISPPREFIX}/tc/tc-help.elc
${EMACS_LISPPREFIX}/tc/tc-is18.el
${EMACS_LISPPREFIX}/tc/tc-is19.el
${EMACS_LISPPREFIX}/tc/tc-is20.el
${EMACS_LISPPREFIX}/tc/tc-is20.elc
${EMACS_LISPPREFIX}/tc/tc-mazegaki.el
${EMACS_LISPPREFIX}/tc/tc-mazegaki.elc
${EMACS_LISPPREFIX}/tc/tc-setup.el
${EMACS_LISPPREFIX}/tc/tc-setup.elc
${EMACS_LISPPREFIX}/tc/tc-sysdep.el
${EMACS_LISPPREFIX}/tc/tc-tbl.el
${EMACS_LISPPREFIX}/tc/tc-tbl.elc
${EMACS_LISPPREFIX}/tc/tc-util.el
${EMACS_LISPPREFIX}/tc/tc-util.elc
${EMACS_LISPPREFIX}/tc/tc.el
${EMACS_LISPPREFIX}/tc/tc.elc
${EMACS_LISPPREFIX}/tc/tutc-tbl.el
${EMACS_LISPPREFIX}/tc/tutc-tbl.elc
share/tc/EELLLTXT
share/tc/bushu.help
share/tc/bushu.rev
share/tc/bushu2canna
share/tc/ccdef.tcode
share/tc/dic-trim.el
share/tc/greece.maz
share/tc/itaiji.maz
share/tc/jukujiku.maz
share/tc/manual.dvi
share/tc/mazegaki.dic
share/tc/mkcertain.pl
share/tc/order.txt
share/tc/parts.txt
share/tc/pd_kihon.yom
share/tc/symbol.rev
share/tc/t1200.dat
share/tc/t1353.dat
share/tc/t225.dat
share/tc/t300.dat
share/tc/t400.dat
share/tc/t450.dat
share/tc/t575.dat
share/tc/t675.dat
share/tc/t900.dat
share/tc/tc-ki2.el
share/tc/tchars.txt
share/tc/tcode.txt
share/tc/want.txt
share/tc/where

5
inputmethod/tc/distinfo Normal file
View file

@ -0,0 +1,5 @@
$NetBSD: distinfo,v 1.1.1.1 2002/09/15 06:31:42 uebayasi Exp $
SHA1 (tc-2.2.1.tar.gz) = 358b63da7e0e4db409fbbfbc0cb77035278f1b40
Size (tc-2.2.1.tar.gz) = 655507 bytes
SHA1 (patch-aa) = 86de83fdff9e9d8f7efbb36d8d6c331cd9230b27

View file

@ -0,0 +1,12 @@
$NetBSD: patch-aa,v 1.1.1.1 2002/09/15 06:31:42 uebayasi Exp $
--- etc/Makefile.in.orig Mon Jul 9 03:08:44 2001
+++ etc/Makefile.in Mon Jul 9 03:09:00 2001
@@ -74,7 +74,7 @@
lispdir = @lispdir@
SHELL = /bin/sh
-INSTALL_SCRIPT = $(INSTALL_PROGRAM)
+INSTALL_SCRIPT = $(BSD_INSTALL_SCRIPT)
bin_SCRIPTS = tc-inst