lang/spidermonkey52: import spidermonkey52-52.7.4
SpiderMonkey is the code-name for the Mozilla's C implementation of JavaScript. This package contains SpiderMonkey 52.
This commit is contained in:
parent
727cc0ddb8
commit
f89e054ed6
7 changed files with 274 additions and 0 deletions
2
lang/spidermonkey52/DESCR
Normal file
2
lang/spidermonkey52/DESCR
Normal file
|
@ -0,0 +1,2 @@
|
|||
SpiderMonkey is the code-name for the Mozilla's C implementation of JavaScript.
|
||||
This package contains SpiderMonkey 52.
|
41
lang/spidermonkey52/Makefile
Normal file
41
lang/spidermonkey52/Makefile
Normal file
|
@ -0,0 +1,41 @@
|
|||
# $NetBSD: Makefile,v 1.1 2018/04/29 05:11:00 wiz Exp $
|
||||
|
||||
DISTNAME= mozjs-52.7.4
|
||||
PKGNAME= ${DISTNAME:S/mozjs/spidermonkey52/}
|
||||
CATEGORIES= lang
|
||||
MASTER_SITES= https://queue.taskcluster.net/v1/task/YqG2fjJJSTGzGX090FjDYg/runs/0/artifacts/public/build/
|
||||
EXTRACT_SUFX= .tar.bz2
|
||||
|
||||
MAINTAINER= pkgsrc-users@NetBSD.org
|
||||
HOMEPAGE= https://developer.mozilla.org/en/SpiderMonkey
|
||||
COMMENT= Standalone JavaScript implementation in C (major version 52)
|
||||
LICENSE= mpl-2.0
|
||||
|
||||
HAS_CONFIGURE= yes
|
||||
USE_LANGUAGES= c c++
|
||||
USE_TOOLS+= pkg-config perl gmake
|
||||
|
||||
CONFIGURE_ARGS+= --prefix=${PREFIX}
|
||||
CONFIGURE_ARGS+= --enable-readline
|
||||
CONFIGURE_ARGS+= --with-system-icu
|
||||
CONFIGURE_ARGS+= --with-system-nspr
|
||||
CONFIGURE_ARGS+= --with-system-zlib
|
||||
CONFIGURE_ARGS+= --with-pthreads
|
||||
|
||||
CONFIGURE_DIRS= js/src
|
||||
|
||||
PKGCONFIG_OVERRIDE+= js/src/ctypes/libffi/libffi.pc.in
|
||||
PKGCONFIG_OVERRIDE+= js/src/js.pc.in
|
||||
|
||||
PYTHON_VERSIONS_ACCEPTED= 27
|
||||
PYTHON_FOR_BUILD_ONLY= yes
|
||||
|
||||
# fails, does not find hg/git checkout
|
||||
TEST_TARGET= check
|
||||
|
||||
.include "../../devel/nspr/buildlink3.mk"
|
||||
.include "../../devel/zlib/buildlink3.mk"
|
||||
.include "../../lang/python/tool.mk"
|
||||
.include "../../textproc/icu/buildlink3.mk"
|
||||
.include "../../mk/readline.buildlink3.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
162
lang/spidermonkey52/PLIST
Normal file
162
lang/spidermonkey52/PLIST
Normal file
|
@ -0,0 +1,162 @@
|
|||
@comment $NetBSD: PLIST,v 1.1 2018/04/29 05:11:00 wiz Exp $
|
||||
bin/js52
|
||||
bin/js52-config
|
||||
include/mozjs-52/fdlibm.h
|
||||
include/mozjs-52/jemalloc_types.h
|
||||
include/mozjs-52/js-config.h
|
||||
include/mozjs-52/js.msg
|
||||
include/mozjs-52/js/CallArgs.h
|
||||
include/mozjs-52/js/CallNonGenericMethod.h
|
||||
include/mozjs-52/js/CharacterEncoding.h
|
||||
include/mozjs-52/js/Class.h
|
||||
include/mozjs-52/js/Conversions.h
|
||||
include/mozjs-52/js/Date.h
|
||||
include/mozjs-52/js/Debug.h
|
||||
include/mozjs-52/js/GCAPI.h
|
||||
include/mozjs-52/js/GCAnnotations.h
|
||||
include/mozjs-52/js/GCHashTable.h
|
||||
include/mozjs-52/js/GCPolicyAPI.h
|
||||
include/mozjs-52/js/GCVariant.h
|
||||
include/mozjs-52/js/GCVector.h
|
||||
include/mozjs-52/js/HashTable.h
|
||||
include/mozjs-52/js/HeapAPI.h
|
||||
include/mozjs-52/js/Id.h
|
||||
include/mozjs-52/js/Initialization.h
|
||||
include/mozjs-52/js/LegacyIntTypes.h
|
||||
include/mozjs-52/js/MemoryMetrics.h
|
||||
include/mozjs-52/js/Principals.h
|
||||
include/mozjs-52/js/ProfilingFrameIterator.h
|
||||
include/mozjs-52/js/ProfilingStack.h
|
||||
include/mozjs-52/js/Proxy.h
|
||||
include/mozjs-52/js/Realm.h
|
||||
include/mozjs-52/js/RequiredDefines.h
|
||||
include/mozjs-52/js/RootingAPI.h
|
||||
include/mozjs-52/js/SliceBudget.h
|
||||
include/mozjs-52/js/StructuredClone.h
|
||||
include/mozjs-52/js/SweepingAPI.h
|
||||
include/mozjs-52/js/TraceKind.h
|
||||
include/mozjs-52/js/TracingAPI.h
|
||||
include/mozjs-52/js/TrackedOptimizationInfo.h
|
||||
include/mozjs-52/js/TypeDecls.h
|
||||
include/mozjs-52/js/UbiNode.h
|
||||
include/mozjs-52/js/UbiNodeBreadthFirst.h
|
||||
include/mozjs-52/js/UbiNodeCensus.h
|
||||
include/mozjs-52/js/UbiNodeDominatorTree.h
|
||||
include/mozjs-52/js/UbiNodePostOrder.h
|
||||
include/mozjs-52/js/UbiNodeShortestPaths.h
|
||||
include/mozjs-52/js/UniquePtr.h
|
||||
include/mozjs-52/js/Utility.h
|
||||
include/mozjs-52/js/Value.h
|
||||
include/mozjs-52/js/Vector.h
|
||||
include/mozjs-52/js/WeakMapPtr.h
|
||||
include/mozjs-52/jsalloc.h
|
||||
include/mozjs-52/jsapi.h
|
||||
include/mozjs-52/jsbytecode.h
|
||||
include/mozjs-52/jsclist.h
|
||||
include/mozjs-52/jscpucfg.h
|
||||
include/mozjs-52/jsfriendapi.h
|
||||
include/mozjs-52/jsperf.h
|
||||
include/mozjs-52/jsprf.h
|
||||
include/mozjs-52/jsprototypes.h
|
||||
include/mozjs-52/jspubtd.h
|
||||
include/mozjs-52/jstypes.h
|
||||
include/mozjs-52/jsversion.h
|
||||
include/mozjs-52/jswrapper.h
|
||||
include/mozjs-52/mozilla/Alignment.h
|
||||
include/mozjs-52/mozilla/AllocPolicy.h
|
||||
include/mozjs-52/mozilla/AlreadyAddRefed.h
|
||||
include/mozjs-52/mozilla/Array.h
|
||||
include/mozjs-52/mozilla/ArrayUtils.h
|
||||
include/mozjs-52/mozilla/Assertions.h
|
||||
include/mozjs-52/mozilla/Atomics.h
|
||||
include/mozjs-52/mozilla/Attributes.h
|
||||
include/mozjs-52/mozilla/BinarySearch.h
|
||||
include/mozjs-52/mozilla/BloomFilter.h
|
||||
include/mozjs-52/mozilla/BufferList.h
|
||||
include/mozjs-52/mozilla/Casting.h
|
||||
include/mozjs-52/mozilla/ChaosMode.h
|
||||
include/mozjs-52/mozilla/Char16.h
|
||||
include/mozjs-52/mozilla/CheckedInt.h
|
||||
include/mozjs-52/mozilla/Compiler.h
|
||||
include/mozjs-52/mozilla/Compression.h
|
||||
include/mozjs-52/mozilla/DebugOnly.h
|
||||
include/mozjs-52/mozilla/Decimal.h
|
||||
include/mozjs-52/mozilla/EndianUtils.h
|
||||
include/mozjs-52/mozilla/EnumSet.h
|
||||
include/mozjs-52/mozilla/EnumTypeTraits.h
|
||||
include/mozjs-52/mozilla/EnumeratedArray.h
|
||||
include/mozjs-52/mozilla/EnumeratedRange.h
|
||||
include/mozjs-52/mozilla/FastBernoulliTrial.h
|
||||
include/mozjs-52/mozilla/FloatingPoint.h
|
||||
include/mozjs-52/mozilla/Function.h
|
||||
include/mozjs-52/mozilla/GuardObjects.h
|
||||
include/mozjs-52/mozilla/HashFunctions.h
|
||||
include/mozjs-52/mozilla/IndexSequence.h
|
||||
include/mozjs-52/mozilla/IntegerPrintfMacros.h
|
||||
include/mozjs-52/mozilla/IntegerRange.h
|
||||
include/mozjs-52/mozilla/IntegerTypeTraits.h
|
||||
include/mozjs-52/mozilla/JSONWriter.h
|
||||
include/mozjs-52/mozilla/Likely.h
|
||||
include/mozjs-52/mozilla/LinkedList.h
|
||||
include/mozjs-52/mozilla/MacroArgs.h
|
||||
include/mozjs-52/mozilla/MacroForEach.h
|
||||
include/mozjs-52/mozilla/MathAlgorithms.h
|
||||
include/mozjs-52/mozilla/Maybe.h
|
||||
include/mozjs-52/mozilla/MaybeOneOf.h
|
||||
include/mozjs-52/mozilla/MemoryChecking.h
|
||||
include/mozjs-52/mozilla/MemoryReporting.h
|
||||
include/mozjs-52/mozilla/Move.h
|
||||
include/mozjs-52/mozilla/NotNull.h
|
||||
include/mozjs-52/mozilla/NullPtr.h
|
||||
include/mozjs-52/mozilla/Opaque.h
|
||||
include/mozjs-52/mozilla/OperatorNewExtensions.h
|
||||
include/mozjs-52/mozilla/Pair.h
|
||||
include/mozjs-52/mozilla/PodOperations.h
|
||||
include/mozjs-52/mozilla/Poison.h
|
||||
include/mozjs-52/mozilla/Range.h
|
||||
include/mozjs-52/mozilla/RangedArray.h
|
||||
include/mozjs-52/mozilla/RangedPtr.h
|
||||
include/mozjs-52/mozilla/ReentrancyGuard.h
|
||||
include/mozjs-52/mozilla/RefCountType.h
|
||||
include/mozjs-52/mozilla/RefCounted.h
|
||||
include/mozjs-52/mozilla/RefPtr.h
|
||||
include/mozjs-52/mozilla/ReverseIterator.h
|
||||
include/mozjs-52/mozilla/RollingMean.h
|
||||
include/mozjs-52/mozilla/SHA1.h
|
||||
include/mozjs-52/mozilla/Saturate.h
|
||||
include/mozjs-52/mozilla/ScopeExit.h
|
||||
include/mozjs-52/mozilla/Scoped.h
|
||||
include/mozjs-52/mozilla/SegmentedVector.h
|
||||
include/mozjs-52/mozilla/SizePrintfMacros.h
|
||||
include/mozjs-52/mozilla/SplayTree.h
|
||||
include/mozjs-52/mozilla/Sprintf.h
|
||||
include/mozjs-52/mozilla/StackWalk.h
|
||||
include/mozjs-52/mozilla/StaticAnalysisFunctions.h
|
||||
include/mozjs-52/mozilla/TaggedAnonymousMemory.h
|
||||
include/mozjs-52/mozilla/TemplateLib.h
|
||||
include/mozjs-52/mozilla/TextUtils.h
|
||||
include/mozjs-52/mozilla/ThreadLocal.h
|
||||
include/mozjs-52/mozilla/TimeStamp.h
|
||||
include/mozjs-52/mozilla/ToString.h
|
||||
include/mozjs-52/mozilla/Tuple.h
|
||||
include/mozjs-52/mozilla/TypeTraits.h
|
||||
include/mozjs-52/mozilla/TypedEnumBits.h
|
||||
include/mozjs-52/mozilla/Types.h
|
||||
include/mozjs-52/mozilla/UniquePtr.h
|
||||
include/mozjs-52/mozilla/UniquePtrExtensions.h
|
||||
include/mozjs-52/mozilla/Unused.h
|
||||
include/mozjs-52/mozilla/Variant.h
|
||||
include/mozjs-52/mozilla/Vector.h
|
||||
include/mozjs-52/mozilla/WeakPtr.h
|
||||
include/mozjs-52/mozilla/XorShift128PlusRNG.h
|
||||
include/mozjs-52/mozilla/double-conversion.h
|
||||
include/mozjs-52/mozilla/fallible.h
|
||||
include/mozjs-52/mozilla/mozalloc.h
|
||||
include/mozjs-52/mozilla/mozalloc_abort.h
|
||||
include/mozjs-52/mozilla/mozalloc_oom.h
|
||||
include/mozjs-52/mozilla/utils.h
|
||||
include/mozjs-52/mozmemory.h
|
||||
include/mozjs-52/mozmemory_wrap.h
|
||||
lib/libjs_static.ajs
|
||||
lib/libmozjs-52.so
|
||||
lib/pkgconfig/mozjs-52.pc
|
15
lang/spidermonkey52/buildlink3.mk
Normal file
15
lang/spidermonkey52/buildlink3.mk
Normal file
|
@ -0,0 +1,15 @@
|
|||
# $NetBSD: buildlink3.mk,v 1.1 2018/04/29 05:11:00 wiz Exp $
|
||||
|
||||
BUILDLINK_TREE+= spidermonkey52
|
||||
|
||||
.if !defined(SPIDERMONKEY52_BUILDLINK3_MK)
|
||||
SPIDERMONKEY52_BUILDLINK3_MK:=
|
||||
|
||||
BUILDLINK_API_DEPENDS.spidermonkey52+= spidermonkey52>=52.0.0
|
||||
BUILDLINK_PKGSRCDIR.spidermonkey52?= ../../lang/spidermonkey52
|
||||
|
||||
.include "../../devel/nspr/buildlink3.mk"
|
||||
.include "../../devel/zlib/buildlink3.mk"
|
||||
.endif # SPIDERMONKEY52_BUILDLINK3_MK
|
||||
|
||||
BUILDLINK_TREE+= -spidermonkey52
|
8
lang/spidermonkey52/distinfo
Normal file
8
lang/spidermonkey52/distinfo
Normal file
|
@ -0,0 +1,8 @@
|
|||
$NetBSD: distinfo,v 1.1 2018/04/29 05:11:00 wiz Exp $
|
||||
|
||||
SHA1 (mozjs-52.7.4.tar.bz2) = ff009853040bb46017204fda4ed69a79484fd321
|
||||
RMD160 (mozjs-52.7.4.tar.bz2) = 71ee71c2444d8b6a1b2b3c744c9f52a2b7129879
|
||||
SHA512 (mozjs-52.7.4.tar.bz2) = 7381f251ca9a4983d181eee2198f89b30505a0de636020e52c0c5b174f4d5cd19ca851222b6d8013bb657f2f1ce1ffcb54816eb928e481be2c9242f918d0125e
|
||||
Size (mozjs-52.7.4.tar.bz2) = 30494311 bytes
|
||||
SHA1 (patch-intl_icu_source_configure) = 1ff1be8ca68566e153219e15b8db696afd08b746
|
||||
SHA1 (patch-js_src_tests_update-test262.sh) = 10d73d95f4b849090bccb8fe656df79cbcea89f3
|
22
lang/spidermonkey52/patches/patch-intl_icu_source_configure
Normal file
22
lang/spidermonkey52/patches/patch-intl_icu_source_configure
Normal file
|
@ -0,0 +1,22 @@
|
|||
$NetBSD: patch-intl_icu_source_configure,v 1.1 2018/04/29 05:11:00 wiz Exp $
|
||||
|
||||
Fix unportable test(1) operator.
|
||||
|
||||
--- intl/icu/source/configure.orig 2018-04-28 01:04:03.000000000 +0000
|
||||
+++ intl/icu/source/configure
|
||||
@@ -7778,13 +7778,13 @@ fi
|
||||
# Now that we're done using CPPFLAGS etc. for tests, we can change it
|
||||
# for build.
|
||||
|
||||
-if test "${CC}" == "clang"; then
|
||||
+if test "${CC}" = "clang"; then
|
||||
CLANGCFLAGS="-Qunused-arguments -Wno-parentheses-equality"
|
||||
else
|
||||
CLANGCFLAGS=""
|
||||
fi
|
||||
|
||||
-if test "${CXX}" == "clang++"; then
|
||||
+if test "${CXX}" = "clang++"; then
|
||||
CLANGCXXFLAGS="-Qunused-arguments -Wno-parentheses-equality"
|
||||
else
|
||||
CLANGCXXFLAGS=""
|
|
@ -0,0 +1,24 @@
|
|||
$NetBSD: patch-js_src_tests_update-test262.sh,v 1.1 2018/04/29 05:11:00 wiz Exp $
|
||||
|
||||
Fix unportable test(1) operator.
|
||||
|
||||
--- js/src/tests/update-test262.sh.orig 2018-04-28 01:04:04.000000000 +0000
|
||||
+++ js/src/tests/update-test262.sh
|
||||
@@ -27,7 +27,7 @@ function usage()
|
||||
|
||||
if [ $# -lt 1 ]; then
|
||||
usage
|
||||
-elif [ $# -eq 1 -o "$2" == "clone" ]; then
|
||||
+elif [ $# -eq 1 -o "$2" = "clone" ]; then
|
||||
# Beware! 'copy' support requires that the clone performed here *never* be
|
||||
# altered. If it were altered, those changes wouldn't appear in the final
|
||||
# set of changes as determined by the 'copy' path below.
|
||||
@@ -47,7 +47,7 @@ elif [ $# -eq 1 -o "$2" == "clone" ]; th
|
||||
|
||||
echo "Feel free to get some coffee - this could take a few minutes..."
|
||||
hg clone $1 ${tmp_dir}
|
||||
-elif [ "$2" == "copy" ]; then
|
||||
+elif [ "$2" = "copy" ]; then
|
||||
echo "Copying directly from $1; be sure this repository is updated to tip"\!
|
||||
tmp_dir="$1"
|
||||
else
|
Loading…
Reference in a new issue