Build fix: NetBSD provides UUID functions in libc, no libuuid here.
This commit is contained in:
parent
e7b4474645
commit
f8a407819d
3 changed files with 37 additions and 2 deletions
|
@ -1,4 +1,4 @@
|
|||
# $NetBSD: Makefile,v 1.4 2011/01/13 13:38:34 wiz Exp $
|
||||
# $NetBSD: Makefile,v 1.5 2011/01/18 15:28:13 asau Exp $
|
||||
#
|
||||
|
||||
SQUEAK_VERSION= 3.11.3.2135
|
||||
|
@ -31,6 +31,13 @@ CMAKE_ARGS+= -DVM_HOST=$(MACHINE_GNU_PLATFORM:Q) -DVM_VERSION=$(SQUEAK_VERSION)
|
|||
CMAKE_ARGS+= -DLIBOSSAUDIO=$(LIBOSSAUDIO) -DDEVOSSAUDIO=$(DEVOSSAUDIO)
|
||||
#CFLAGS= -g -fomit-frame-pointer
|
||||
|
||||
.include "../../mk/bsd.prefs.mk"
|
||||
|
||||
.if $(OPSYS) == "NetBSD"
|
||||
# UUID routines are in libc:
|
||||
BUILDLINK_TRANSFORM+= rm:-luuid
|
||||
.endif
|
||||
|
||||
PLIST_SUBST= SQUEAK_VERSION=$(SQUEAK_VERSION)
|
||||
|
||||
.include "options.mk"
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: distinfo,v 1.2 2010/06/01 21:55:32 markd Exp $
|
||||
$NetBSD: distinfo,v 1.3 2011/01/18 15:28:13 asau Exp $
|
||||
|
||||
SHA1 (squeak/Squeak-3.11.3.2135-src.tar.gz) = cdc033b14e56ea05aa62bcb1686bb73f4347e29f
|
||||
RMD160 (squeak/Squeak-3.11.3.2135-src.tar.gz) = abb7dbde7e79f18161842d1451959ad09e7ef3ad
|
||||
|
@ -9,3 +9,4 @@ SHA1 (patch-ac) = bad06ae257766407c90a62f5927a53c97ee8072a
|
|||
SHA1 (patch-ad) = e426d1de4b496704be08c67d2d2ab61a24735017
|
||||
SHA1 (patch-ae) = 73c358e42d153c9e6fe605fa1c77360ad48c6ec3
|
||||
SHA1 (patch-af) = 529550d988f5655791942145c79f5448431c04c4
|
||||
SHA1 (patch-ag) = 6c435d13b36c5308d516f35d4b3988dfecf2f91b
|
||||
|
|
27
lang/squeak-vm/patches/patch-ag
Normal file
27
lang/squeak-vm/patches/patch-ag
Normal file
|
@ -0,0 +1,27 @@
|
|||
$NetBSD: patch-ag,v 1.1 2011/01/18 15:28:13 asau Exp $
|
||||
|
||||
Use uuidgen(2) on NetBSD.
|
||||
|
||||
--- unix/plugins/UUIDPlugin/sqUnixUUID.c.orig 2009-08-26 22:12:10.000000000 +0400
|
||||
+++ unix/plugins/UUIDPlugin/sqUnixUUID.c 2011-01-18 01:02:30.000000000 +0300
|
||||
@@ -1,4 +1,8 @@
|
||||
#include "config.h"
|
||||
+#if defined(__NetBSD__)
|
||||
+#include <sys/types.h>
|
||||
+#include <sys/uuid.h>
|
||||
+#endif
|
||||
#include <uuid.h>
|
||||
#include "sq.h"
|
||||
|
||||
@@ -15,7 +19,11 @@
|
||||
int MakeUUID(char *location)
|
||||
{
|
||||
uuid_t uuid;
|
||||
+#if defined(__NetBSD__)
|
||||
+ uuidgen(&uuid, 1);
|
||||
+#else
|
||||
uuid_generate(uuid);
|
||||
+#endif
|
||||
memcpy((void *)location, (void *)&uuid, sizeof(uuid));
|
||||
return 1;
|
||||
}
|
Loading…
Reference in a new issue