Updated to version 1.0

Changes:

1.0:
====
Only minor bugfixes were made to the previous version.

- Fixed channel public key list saving on backup router on JOIN
  command reply.
- New optimized logging.

0.9.21:
=======
A small bugfix release.

- Added default limit how many channels one client can join (50).
- Added missing getopt.[ch].
- Fixed compilation with pkg-config files

0.9.20:
=======
A bugfix release to the SILC Server.  In addition of various bugfixes,
this version now also includes new math library that from now on will be
included in all SILC distributions.

- Added more liberal channel names from the previous more stricter
  identifier string change.
- Added SERVICE command to server, though services aren't supported yet.
- Fixed MOTD command to send empty reply if motd does not exist.
- Fixed LIST command.
- Fixed query to stop if client goes away.
- Added pkg-config check to the configure.
- Several other bugfixes were made.
This commit is contained in:
salo 2005-06-19 01:22:17 +00:00
parent 49cb8e1be9
commit f8da63e164
5 changed files with 45 additions and 52 deletions

View file

@ -1,8 +1,7 @@
# $NetBSD: Makefile,v 1.39 2005/04/11 21:45:05 tv Exp $
# $NetBSD: Makefile,v 1.40 2005/06/19 01:22:17 salo Exp $
#
DISTNAME= silc-server-0.9.19p1
PKGNAME= ${DISTNAME:S/p1/.1/}
DISTNAME= silc-server-1.0
CATEGORIES= chat security
MASTER_SITES= http://www.silcnet.org/download/server/sources/ \
ftp://ftp.silcnet.org/silc/server/sources/ \
@ -15,11 +14,10 @@ MAINTAINER= salo@NetBSD.org
HOMEPAGE= http://www.silcnet.org/
COMMENT= Server for the Secure Internet Live Conferencing (SILC) protocol
USE_PKGINSTALL= YES
GNU_CONFIGURE= YES
USE_LIBTOOL= YES
USE_PKGINSTALL= yes
GNU_CONFIGURE= yes
USE_LIBTOOL= yes
SHLIBTOOL_OVERRIDE= libtool */*/*/libtool
WRKSRC= ${WRKDIR}/${DISTNAME:S/p1//}
DEINSTALL_EXTRA_TMPL+= ${.CURDIR}/DEINSTALL
@ -62,6 +60,7 @@ CONFIGURE_ARGS+= --with-logsdir=${VARBASE}/log/silcd
CONFIGURE_ARGS+= --with-silcd-pid-file=${VARBASE}/run/silcd.pid
CONFIGURE_ARGS+= --without-iconv
CONFIGURE_ARGS+= --without-libtoolfix
CONFIGURE_ARGS+= --enable-shared
# XXX: Avoid an ICE in gcc2 on sparc64
#

View file

@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.17 2005/05/02 20:33:58 reed Exp $
@comment $NetBSD: PLIST,v 1.18 2005/06/19 01:22:17 salo Exp $
lib/silc-server/libsilc.la
lib/silc-server/modules/aes.sim.so
lib/silc-server/modules/blowfish.sim.so
@ -15,11 +15,16 @@ sbin/silcd
share/doc/silc-server/CHANGES
share/doc/silc-server/COPYING
share/doc/silc-server/CREDITS
share/doc/silc-server/CodingStyle
share/doc/silc-server/FAQ
share/doc/silc-server/INSTALL
share/doc/silc-server/README
share/doc/silc-server/TODO
share/doc/silc-server/draft-riikonen-presence-attrs-03.txt
share/doc/silc-server/draft-riikonen-silc-commands-06.txt
share/doc/silc-server/draft-riikonen-silc-flags-payloads-04.txt
share/doc/silc-server/draft-riikonen-silc-ke-auth-08.txt
share/doc/silc-server/draft-riikonen-silc-pp-09.txt
share/doc/silc-server/draft-riikonen-silc-spec-08.txt
share/examples/rc.d/silcd
share/examples/silc-server/README
share/examples/silc-server/cell_backup.conf

View file

@ -1,7 +1,7 @@
$NetBSD: distinfo,v 1.27 2005/04/08 15:09:43 salo Exp $
$NetBSD: distinfo,v 1.28 2005/06/19 01:22:17 salo Exp $
SHA1 (silc-server-0.9.19p1.tar.bz2) = 5ef4c79aafe668efb31ab7f11cbdfdfdae1b7754
RMD160 (silc-server-0.9.19p1.tar.bz2) = 24e72b8e5c833da1b21dcdbc63aef2a5d2bdcadb
Size (silc-server-0.9.19p1.tar.bz2) = 1182404 bytes
SHA1 (patch-aa) = 181bf9a721abaeaaa0afd7e24017cd49a8020ac4
SHA1 (silc-server-1.0.tar.bz2) = bcf440c89b3266f47e64a8f175ffba117f071899
RMD160 (silc-server-1.0.tar.bz2) = 0316e72d48ca8b4d092db8765807d97ab659b317
Size (silc-server-1.0.tar.bz2) = 969309 bytes
SHA1 (patch-aa) = 3b189047000593b36305f23301987982706355dc
SHA1 (patch-ab) = 55b3f00076c5b8a443465753ae07b9e812236f18

View file

@ -1,9 +1,8 @@
# $NetBSD: options.mk,v 1.2 2005/05/31 10:01:36 dillo Exp $
# $NetBSD: options.mk,v 1.3 2005/06/19 01:22:17 salo Exp $
#
PKG_OPTIONS_VAR= PKG_OPTIONS.silc-server
PKG_SUPPORTED_OPTIONS= debug inet6
PKG_SUGGESTED_OPTIONS= inet6
.include "../../mk/bsd.options.mk"

View file

@ -1,52 +1,42 @@
$NetBSD: patch-aa,v 1.9 2003/10/16 12:37:44 salo Exp $
$NetBSD: patch-aa,v 1.10 2005/06/19 01:22:17 salo Exp $
--- Makefile.in.orig 2003-10-15 19:22:13.000000000 +0200
+++ Makefile.in 2003-10-16 13:16:39.000000000 +0200
@@ -710,14 +710,12 @@
-mkdir -p $(mandir)/man1
--- apps/silcd/Makefile.in.orig 2005-05-10 18:59:04.000000000 +0200
+++ apps/silcd/Makefile.in 2005-06-19 02:36:04.000000000 +0200
@@ -581,13 +581,10 @@
install-dirs-server: install-dirs
install-dirs-server:
-mkdir -p $(docdir)
- -mkdir -p $(etcdir)
- -mkdir -p $(logsdir)
-mkdir -p $(mandir)/man5
-mkdir -p $(mandir)/man8
doc-install:
-$(INSTALL_DATA) $(srcdir)/doc/CodingStyle $(docdir)/
-$(INSTALL_DATA) $(srcdir)/doc/FAQ $(docdir)/
- -$(INSTALL_DATA) $(srcdir)/doc/*.txt $(docdir)/
-$(INSTALL_DATA) $(srcdir)/COPYING $(docdir)/
-$(INSTALL_DATA) $(srcdir)/CHANGES $(docdir)/
-$(INSTALL_DATA) $(srcdir)/CREDITS $(docdir)/
@@ -732,7 +730,6 @@
doc-install-server:
- -$(INSTALL_DATA) $(top_srcdir)/doc/example_silcd.conf $(docdir)/
-@if test -f $(top_srcdir)/doc/silcd.8 ; then \
$(INSTALL_DATA) $(top_srcdir)/doc/silcd.8 $(mandir)/man8; \
fi
doc-install-server: doc-install
- -$(INSTALL_DATA) $(srcdir)/doc/example_silcd.conf $(docdir)/
-@if test -f $(srcdir)/doc/silcd.8 ; then \
$(INSTALL_DATA) $(srcdir)/doc/silcd.8 $(mandir)/man8; \
@@ -605,8 +602,10 @@
fi
@@ -767,9 +764,12 @@
-cp -R $(srcdir)/tutorial $(prefix)
examples-install:
- -mkdir -p $(docdir)/examples/
- -$(INSTALL_DATA) $(srcdir)/doc/examples/README $(docdir)/examples/
- -$(INSTALL_DATA) $(srcdir)/doc/examples/silc* $(docdir)/examples/
- -$(INSTALL_DATA) $(top_srcdir)/doc/examples/* $(docdir)/examples/
+ -mkdir -p $(examplesdir)
+ -$(INSTALL_DATA) $(srcdir)/doc/examples/README $(examplesdir)
+ -$(INSTALL_DATA) $(srcdir)/doc/examples/silc* $(examplesdir)
+ -$(INSTALL_DATA) $(srcdir)/doc/examples/cell* $(examplesdir)
+ -$(INSTALL_DATA) $(srcdir)/doc/example_silcd.conf $(examplesdir)/silcd.conf.default
+ -$(INSTALL_DATA) $(srcdir)/doc/silcalgs.conf $(examplesdir)/silcalgs.conf.default
+ -$(INSTALL_DATA) $(top_srcdir)/doc/examples/* $(examplesdir)/
+ -$(INSTALL_DATA) $(top_srcdir)/doc/example_silcd.conf $(examplesdir)/silcd.conf.default
+ -$(INSTALL_DATA) $(top_srcdir)/doc/silcalgs.conf $(examplesdir)/silcalgs.conf.default
generate-server-key:
-@if test '!' -f $(etcdir)/silcd.pub ; then \
@@ -778,7 +778,7 @@
@@ -616,9 +615,7 @@
install-data-hook: \
install-dirs-server \
doc-install-server \
- etc-install-server \
- examples-install \
- generate-server-key
+ examples-install
@INCLUDE_DEFINES_INT@
@SILC_DIST_CLIENT_TRUE@install-data-hook: install-dirs-client sim-install doc-install-client etc-install-client
@SILC_DIST_CLIENT_FALSE@@SILC_DIST_TOOLKIT_TRUE@install-data-hook: install-dirs-client install-dirs-server sim-install doc-install-client doc-install-server toolkit-install examples-install etc-install-client etc-install-server
-@SILC_DIST_CLIENT_FALSE@@SILC_DIST_TOOLKIT_FALSE@install-data-hook: install-dirs-server sim-install doc-install-server examples-install etc-install-server generate-server-key
+@SILC_DIST_CLIENT_FALSE@@SILC_DIST_TOOLKIT_FALSE@install-data-hook: install-dirs-server sim-install doc-install-server examples-install
# Tell versions [3.59,3.63) of GNU make to not export all variables.
# Otherwise a system limit (for SysV at least) may be exceeded.
.NOEXPORT: