update to 0.8.5

major changes:
-statistic system
-improvements in the Audio CD playback (CDDB)
-new and improved video filters
-new AJAX HTTP interface
This commit is contained in:
drochner 2006-05-10 16:28:43 +00:00
parent 7bc0a76019
commit f8dba14c70
7 changed files with 223 additions and 257 deletions

View file

@ -1,8 +1,7 @@
# $NetBSD: Makefile,v 1.2 2006/05/06 08:25:20 xtraeme Exp $
# $NetBSD: Makefile,v 1.3 2006/05/10 16:28:43 drochner Exp $
#
DISTNAME= vlc-${VLC_VER}
PKGREVISION= 1
CATEGORIES= multimedia
MASTER_SITES= http://download.videolan.org/pub/videolan/vlc/${VLC_VER}/
EXTRACT_SUFX= .tar.bz2
@ -15,8 +14,9 @@ USE_TOOLS+= gmake pkg-config
USE_PKGLOCALEDIR= yes
GNU_CONFIGURE= yes
PTHREAD_OPTS+= require
USE_LANGUAGES+= c++
VLC_VER= 0.8.4a
VLC_VER= 0.8.5
.include "../../mk/bsd.prefs.mk"
@ -38,15 +38,28 @@ CONFIGURE_ARGS+= --disable-mpc
CONFIGURE_ARGS+= --disable-dts
CONFIGURE_ARGS+= --with-ffmpeg-tree=${BUILDLINK_PREFIX.ffmpeg}/lib
CONFIGURE_ARGS+= --with-ffmpeg-zlib
CONFIGURE_ARGS+= --enable-cddax
CONFIGURE_ARGS+= --enable-dvdread
pre-install:
${INSTALL_DATA_DIR} ${PREFIX}/share/vlc/http/admin
${INSTALL_DATA_DIR} ${PREFIX}/share/vlc/http/dialogs
${INSTALL_DATA_DIR} ${PREFIX}/share/vlc/http/images
${INSTALL_DATA_DIR} ${PREFIX}/share/vlc/http/js
${INSTALL_DATA_DIR} ${PREFIX}/share/vlc/http/old
${INSTALL_DATA_DIR} ${PREFIX}/share/vlc/http/old/admin
${INSTALL_DATA_DIR} ${PREFIX}/share/vlc/http/old/vlm
${INSTALL_DATA_DIR} ${PREFIX}/share/vlc/http/requests
${INSTALL_DATA_DIR} ${PREFIX}/share/vlc/osdmenu/default
${INSTALL_DATA_DIR} ${PREFIX}/share/vlc/osdmenu/default/selected
${INSTALL_DATA_DIR} ${PREFIX}/share/vlc/osdmenu/default/selection
${INSTALL_DATA_DIR} ${PREFIX}/share/vlc/osdmenu/default/volume
${INSTALL_DATA_DIR} ${PREFIX}/share/vlc/osdmenu/dvd/selected
${INSTALL_DATA_DIR} ${PREFIX}/share/vlc/osdmenu/dvd/volume
${INSTALL_DATA_DIR} ${PREFIX}/share/vlc/osdmenu/dvd/unselect
${INSTALL_DATA_DIR} ${PREFIX}/share/vlc/osdmenu/dvd/selection
${INSTALL_DATA_DIR} ${PREFIX}/share/vlc/skins2
${INSTALL_DATA_DIR} ${PREFIX}/share/vlc/skins2/fonts
${INSTALL_DATA} ${WRKSRC}/doc/vlc.1 ${PREFIX}/man/man1
${INSTALL_DATA} ${WRKSRC}/doc/vlc-config.1 ${PREFIX}/man/man1

View file

@ -1,12 +1,14 @@
@comment $NetBSD: PLIST,v 1.2 2006/05/06 08:25:20 xtraeme Exp $
@comment $NetBSD: PLIST,v 1.3 2006/05/10 16:28:43 drochner Exp $
bin/vlc
bin/vlc-config
bin/wxvlc
include/vlc/aout.h
include/vlc/control.h
include/vlc/decoder.h
include/vlc/input.h
include/vlc/intf.h
include/vlc/libvlc.h
include/vlc/mediacontrol.h
include/vlc/mediacontrol_structures.h
include/vlc/sout.h
include/vlc/vlc.h
include/vlc/vout.h
@ -46,6 +48,7 @@ lib/vlc/audio_filter/libheadphone_channel_mixer_plugin.so
lib/vlc/audio_filter/liblinear_resampler_plugin.so
lib/vlc/audio_filter/libmpgatofixed32_plugin.so
lib/vlc/audio_filter/libnormvol_plugin.so
lib/vlc/audio_filter/libparam_eq_plugin.so
lib/vlc/audio_filter/libs16tofixed32_plugin.so
lib/vlc/audio_filter/libs16tofloat32_plugin.so
lib/vlc/audio_filter/libs16tofloat32swab_plugin.so
@ -136,6 +139,7 @@ lib/vlc/libstream_out_switcher.a
lib/vlc/misc/libdummy_plugin.so
lib/vlc/misc/libexport_plugin.so
lib/vlc/misc/libfreetype_plugin.so
lib/vlc/misc/libgrowl_plugin.so
lib/vlc/misc/libipv4_plugin.so
lib/vlc/misc/libipv6_plugin.so
lib/vlc/misc/liblogger_plugin.so
@ -157,6 +161,7 @@ lib/vlc/packetizer/libpacketizer_h264_plugin.so
lib/vlc/packetizer/libpacketizer_mpeg4audio_plugin.so
lib/vlc/packetizer/libpacketizer_mpeg4video_plugin.so
lib/vlc/packetizer/libpacketizer_mpegvideo_plugin.so
lib/vlc/services_discovery/libpodcast_plugin.so
lib/vlc/services_discovery/libsap_plugin.so
lib/vlc/services_discovery/libshout_plugin.so
lib/vlc/stream_out/libstream_out_bridge_plugin.so
@ -182,6 +187,7 @@ lib/vlc/video_filter/libdeinterlace_plugin.so
lib/vlc/video_filter/libdistort_plugin.so
lib/vlc/video_filter/libinvert_plugin.so
lib/vlc/video_filter/liblogo_plugin.so
lib/vlc/video_filter/libmagnify_plugin.so
lib/vlc/video_filter/libmarq_plugin.so
lib/vlc/video_filter/libmosaic_plugin.so
lib/vlc/video_filter/libmotionblur_plugin.so
@ -213,10 +219,15 @@ share/locale/en_GB/LC_MESSAGES/vlc.mo
share/locale/es/LC_MESSAGES/vlc.mo
share/locale/fr/LC_MESSAGES/vlc.mo
share/locale/gl/LC_MESSAGES/vlc.mo
share/locale/he/LC_MESSAGES/vlc.mo
share/locale/hi/LC_MESSAGES/vlc.mo
share/locale/hu/LC_MESSAGES/vlc.mo
share/locale/it/LC_MESSAGES/vlc.mo
share/locale/ja/LC_MESSAGES/vlc.mo
share/locale/ka/LC_MESSAGES/vlc.mo
share/locale/ko/LC_MESSAGES/vlc.mo
share/locale/nl/LC_MESSAGES/vlc.mo
share/locale/oc/LC_MESSAGES/vlc.mo
share/locale/pt_BR/LC_MESSAGES/vlc.mo
share/locale/ro/LC_MESSAGES/vlc.mo
share/locale/ru/LC_MESSAGES/vlc.mo
@ -224,18 +235,111 @@ share/locale/sv/LC_MESSAGES/vlc.mo
share/locale/tr/LC_MESSAGES/vlc.mo
share/locale/zh_CN/LC_MESSAGES/vlc.mo
share/locale/zh_TW/LC_MESSAGES/vlc.mo
share/vlc/http/admin/.access
share/vlc/http/admin/browse.html
share/vlc/http/admin/dboxfiles.html
share/vlc/http/admin/index.html
share/vlc/http/cone_minus.png
share/vlc/http/cone_plus.png
share/vlc/http/.hosts
share/vlc/http/dialogs/.hosts
share/vlc/http/dialogs/browse
share/vlc/http/dialogs/footer
share/vlc/http/dialogs/input
share/vlc/http/dialogs/main
share/vlc/http/dialogs/mosaic
share/vlc/http/dialogs/playlist
share/vlc/http/dialogs/sout
share/vlc/http/dialogs/vlm
share/vlc/http/favicon.ico
share/vlc/http/iehacks.css
share/vlc/http/images/delete.png
share/vlc/http/images/delete_small.png
share/vlc/http/images/eject.png
share/vlc/http/images/empty.png
share/vlc/http/images/fullscreen.png
share/vlc/http/images/help.png
share/vlc/http/images/info.png
share/vlc/http/images/loop.png
share/vlc/http/images/minus.png
share/vlc/http/images/next.png
share/vlc/http/images/pause.png
share/vlc/http/images/play.png
share/vlc/http/images/playlist.png
share/vlc/http/images/playlist_small.png
share/vlc/http/images/plus.png
share/vlc/http/images/prev.png
share/vlc/http/images/refresh.png
share/vlc/http/images/repeat.png
share/vlc/http/images/sd.png
share/vlc/http/images/shuffle.png
share/vlc/http/images/slider_bar.png
share/vlc/http/images/slider_left.png
share/vlc/http/images/slider_point.png
share/vlc/http/images/slider_right.png
share/vlc/http/images/slow.png
share/vlc/http/images/sort.png
share/vlc/http/images/sout.png
share/vlc/http/images/speaker.png
share/vlc/http/images/speaker_mute.png
share/vlc/http/images/stop.png
share/vlc/http/images/vlc16x16.png
share/vlc/http/images/volume_down.png
share/vlc/http/images/volume_up.png
share/vlc/http/images/white.png
share/vlc/http/images/white_cross_small.png
share/vlc/http/index.html
share/vlc/http/info.html
share/vlc/http/js/functions.js
share/vlc/http/js/mosaic.js
share/vlc/http/js/vlm.js
share/vlc/http/mosaic.html
share/vlc/http/old/.hosts
share/vlc/http/old/admin/.access
share/vlc/http/old/admin/browse.html
share/vlc/http/old/admin/dboxfiles.html
share/vlc/http/old/admin/index.html
share/vlc/http/old/cone_minus.png
share/vlc/http/old/cone_plus.png
share/vlc/http/old/index.html
share/vlc/http/old/info.html
share/vlc/http/old/style.css
share/vlc/http/old/vlm/edit.html
share/vlc/http/old/vlm/index.html
share/vlc/http/old/vlm/new.html
share/vlc/http/old/vlm/show.html
share/vlc/http/old/webcam.html
share/vlc/http/requests/browse.xml
share/vlc/http/requests/playlist.xml
share/vlc/http/requests/readme
share/vlc/http/requests/status.xml
share/vlc/http/requests/vlm.xml
share/vlc/http/requests/vlm_cmd.xml
share/vlc/http/style.css
share/vlc/http/webcam.html
share/vlc/http/vlm.html
share/vlc/http/vlm_export.html
share/vlc/osdmenu/default.cfg
share/vlc/osdmenu/default/selected/bw.png
share/vlc/osdmenu/default/selected/esc.png
share/vlc/osdmenu/default/selected/fw.png
share/vlc/osdmenu/default/selected/next.png
share/vlc/osdmenu/default/selected/play_pause.png
share/vlc/osdmenu/default/selected/previous.png
share/vlc/osdmenu/default/selected/stop.png
share/vlc/osdmenu/default/selected/volume.png
share/vlc/osdmenu/default/selection/bw.png
share/vlc/osdmenu/default/selection/esc.png
share/vlc/osdmenu/default/selection/fw.png
share/vlc/osdmenu/default/selection/next.png
share/vlc/osdmenu/default/selection/play_pause.png
share/vlc/osdmenu/default/selection/previous.png
share/vlc/osdmenu/default/selection/stop.png
share/vlc/osdmenu/default/selection/volume.png
share/vlc/osdmenu/default/unselected.png
share/vlc/osdmenu/default/volume/volume_00.png
share/vlc/osdmenu/default/volume/volume_01.png
share/vlc/osdmenu/default/volume/volume_02.png
share/vlc/osdmenu/default/volume/volume_03.png
share/vlc/osdmenu/default/volume/volume_04.png
share/vlc/osdmenu/default/volume/volume_05.png
share/vlc/osdmenu/default/volume/volume_06.png
share/vlc/osdmenu/default/volume/volume_07.png
share/vlc/osdmenu/default/volume/volume_08.png
share/vlc/osdmenu/default/volume/volume_09.png
share/vlc/osdmenu/default/volume/volume_10.png
share/vlc/osdmenu/dvd.cfg
share/vlc/osdmenu/dvd/selected/bw.png
share/vlc/osdmenu/dvd/selected/esc.png
@ -273,6 +377,12 @@ share/vlc/pda-playlistb16x16.xpm
share/vlc/pda-preferencesb16x16.xpm
share/vlc/pda-rewindb16x16.xpm
share/vlc/pda-stopb16x16.xpm
share/vlc/skins2/default.vlt
share/vlc/skins2/fonts/FreeSans.ttf
share/vlc/skins2/fonts/FreeSansBold.ttf
share/vlc/skins2/skin.catalog
share/vlc/skins2/skin.dtd
share/vlc/skins2/winamp2.xml
share/vlc/vlc128x128.png
share/vlc/vlc16x16.png
share/vlc/vlc16x16.xpm
@ -280,13 +390,25 @@ share/vlc/vlc32x32.png
share/vlc/vlc32x32.xpm
share/vlc/vlc48x48.ico
share/vlc/vlc48x48.png
@dirrm share/vlc/skins2/fonts
@dirrm share/vlc/skins2
@dirrm share/vlc/osdmenu/dvd/volume
@dirrm share/vlc/osdmenu/dvd/unselect
@dirrm share/vlc/osdmenu/dvd/selection
@dirrm share/vlc/osdmenu/dvd/selected
@dirrm share/vlc/osdmenu/dvd
@dirrm share/vlc/osdmenu/default/volume
@dirrm share/vlc/osdmenu/default/selection
@dirrm share/vlc/osdmenu/default/selected
@dirrm share/vlc/osdmenu/default
@dirrm share/vlc/osdmenu
@dirrm share/vlc/http/admin
@dirrm share/vlc/http/requests
@dirrm share/vlc/http/old/vlm
@dirrm share/vlc/http/old/admin
@dirrm share/vlc/http/old
@dirrm share/vlc/http/js
@dirrm share/vlc/http/images
@dirrm share/vlc/http/dialogs
@dirrm share/vlc/http
@dirrm share/vlc
@dirrm share/doc/vlc

View file

@ -1,8 +1,8 @@
$NetBSD: distinfo,v 1.1.1.1 2006/05/04 19:19:59 drochner Exp $
$NetBSD: distinfo,v 1.2 2006/05/10 16:28:43 drochner Exp $
SHA1 (vlc-0.8.4a.tar.bz2) = 043462db25e6eeb7f648c600d2dbca1524056580
RMD160 (vlc-0.8.4a.tar.bz2) = 50ea307c1aa70d7189a8c7cd09bf5e1d60e4856b
Size (vlc-0.8.4a.tar.bz2) = 7191539 bytes
SHA1 (patch-ab) = 6d776a5c323bd840c3080d25bc7188dd04a9f340
SHA1 (patch-af) = 3e887918d6e70630282dcac7979f4a9f6673a6a5
SHA1 (vlc-0.8.5.tar.bz2) = 2f0a26a336a5211f32c7bcc653dfd0b27f1fb26b
RMD160 (vlc-0.8.5.tar.bz2) = d24140a5b4bf771754028090e103bb5c171e4fd8
Size (vlc-0.8.5.tar.bz2) = 8562996 bytes
SHA1 (patch-ag) = 4c1b802dc4df1c521398dc9b07794232bb5b21d9
SHA1 (patch-ah) = 5a355a70b7b39c0a33db7cc37e3944f903686d3f
SHA1 (patch-ai) = 99214a216739200660795aaf3100fd69da7d45ee

View file

@ -1,205 +0,0 @@
$NetBSD: patch-ab,v 1.1.1.1 2006/05/04 19:20:00 drochner Exp $
--- modules/access/cdda/info.c.orig 2006-05-04 15:57:30.000000000 +0200
+++ modules/access/cdda/info.c
@@ -163,13 +163,13 @@ cddb_end: ;
} \
#define add_cddb_meta(FIELD, VLC_META) \
- add_meta_val(VLC_META, p_cdda->cddb.disc->FIELD);
+ add_meta_val(VLC_META, cddb_disc_get_##FIELD(p_cdda->cddb.disc));
#define add_cddb_meta_fmt(FIELD, FORMAT_SPEC, VLC_META) \
{ \
char psz_buf[100]; \
snprintf( psz_buf, sizeof(psz_buf)-1, FORMAT_SPEC, \
- p_cdda->cddb.disc->FIELD ); \
+ cddb_disc_get_##FIELD(p_cdda->cddb.disc) ); \
psz_buf[sizeof(psz_buf)-1] = '\0'; \
add_meta_val(VLC_META, psz_buf); \
}
@@ -195,13 +195,13 @@ cddb_end: ;
under category "Disc" if the string is not null or the null string.
*/
#define add_cddb_disc_info_str(TITLE, FIELD) \
- add_info_str("Disc", TITLE, p_cdda->cddb.disc->FIELD)
+ add_info_str("Disc", TITLE, cddb_disc_get_##FIELD(p_cdda->cddb.disc))
/* Adds a CDDB numeric-valued entry to the stream and media information
under category "Disc" if the string is not null or the null string.
*/
#define add_cddb_disc_info_val(TITLE, FMT, FIELD) \
- add_info_val("Disc", TITLE, FMT, p_cdda->cddb.disc->FIELD)
+ add_info_val("Disc", TITLE, FMT, cddb_disc_get_##FIELD(p_cdda->cddb.disc))
/* Adds a CD-Text string-valued entry to the stream and media information
under category "Disc" if the string is not null or the null string.
@@ -283,11 +283,11 @@ CDDAMetaInfo( access_t *p_access, track_
if( CDIO_INVALID_TRACK == i_track )
{
- psz_meta_title = p_cdda->cddb.disc->title;
- psz_meta_artist = p_cdda->cddb.disc->artist;
- if ( p_cdda->cddb.disc->genre && strlen(p_cdda->cddb.disc->genre) )
+ psz_meta_title = cddb_disc_get_title(p_cdda->cddb.disc);
+ psz_meta_artist = cddb_disc_get_artist(p_cdda->cddb.disc);
+ if ( cddb_disc_get_genre(p_cdda->cddb.disc) && strlen(cddb_disc_get_genre(p_cdda->cddb.disc)) )
add_cddb_meta(genre, VLC_META_GENRE);
- if ( 0 != p_cdda->cddb.disc->year )
+ if ( 0 != cddb_disc_get_year(p_cdda->cddb.disc) )
add_cddb_meta_fmt(year, "%d", VLC_META_DATE );
}
else
@@ -295,13 +295,13 @@ CDDAMetaInfo( access_t *p_access, track_
cddb_track_t *t=cddb_disc_get_track(p_cdda->cddb.disc, i_track-1);
if (t != NULL )
{
- if( t->title != NULL && ! p_cdda->b_nav_mode )
+ if( cddb_track_get_title(t) != NULL && ! p_cdda->b_nav_mode )
{
- add_meta_val( VLC_META_TITLE, t->title );
+ add_meta_val( VLC_META_TITLE, cddb_track_get_title(t) );
}
- if( t->artist != NULL )
+ if( cddb_track_get_artist(t) != NULL )
{
- add_meta_val( VLC_META_ARTIST, t->artist );
+ add_meta_val( VLC_META_ARTIST, cddb_track_get_artist(t) );
}
}
}
@@ -339,14 +339,14 @@ CDDAMetaInfo( access_t *p_access, track_
if (p_cdda->b_cddb_enabled && p_cdda->cddb.disc)
{
add_cddb_disc_info_str("Artist (CDDB)", artist);
- if ( CDDB_CAT_INVALID != p_cdda->cddb.disc->category )
+ if ( CDDB_CAT_INVALID != cddb_disc_get_category(p_cdda->cddb.disc) )
add_info_str("Disc", "Category (CDDB)",
- CDDB_CATEGORY[p_cdda->cddb.disc->category]);
+ CDDB_CATEGORY[cddb_disc_get_category(p_cdda->cddb.disc)]);
add_cddb_disc_info_val("Disc ID (CDDB)", "%x", discid);
add_cddb_disc_info_str("Extended Data (CDDB)", ext_data);
add_cddb_disc_info_str("Genre (CDDB)", genre);
add_cddb_disc_info_str("Title (CDDB)", title);
- if ( 0 != p_cdda->cddb.disc->year )
+ if ( 0 != cddb_disc_get_year(p_cdda->cddb.disc) )
add_cddb_disc_info_val("Year (CDDB)", "%d", year);
}
@@ -423,10 +423,10 @@ CDDAMetaInfo( access_t *p_access, track_
cddb_track_t *t=cddb_disc_get_track(p_cdda->cddb.disc, i);
if (t != NULL)
{
- add_info_str(psz_track, "Artist (CDDB)", t->artist);
- add_info_str(psz_track, "Title (CDDB)", t->title);
+ add_info_str(psz_track, "Artist (CDDB)", cddb_track_get_artist(t));
+ add_info_str(psz_track, "Title (CDDB)", cddb_track_get_title(t));
add_info_str(psz_track, "Extended Data (CDDB)",
- t->ext_data);
+ cddb_track_get_ext_data(t));
}
}
#endif /*HAVE_LIBCDDB*/
@@ -566,41 +566,41 @@ CDDAFormatStr( const access_t *p_access,
&& p_cdda->p_cdtext[0]->field[CDTEXT_PERFORMER])
psz = p_cdda->p_cdtext[0]->field[CDTEXT_PERFORMER];
if (want_cddb_info(p_cdda, psz))
- psz = p_cdda->cddb.disc->artist;
+ psz = cddb_disc_get_artist(p_cdda->cddb.disc);
goto format_str;
case 'A':
if (p_cdda->p_cdtext[0]
&& p_cdda->p_cdtext[0]->field[CDTEXT_TITLE])
psz = p_cdda->p_cdtext[0]->field[CDTEXT_TITLE];
if (want_cddb_info(p_cdda, psz))
- psz = p_cdda->cddb.disc->title;
+ psz = cddb_disc_get_title(p_cdda->cddb.disc);
goto format_str;
case 'C':
if (!p_cdda->b_cddb_enabled) goto not_special;
if (p_cdda->cddb.disc)
add_format_str_info(
- CDDB_CATEGORY[p_cdda->cddb.disc->category]);
+ CDDB_CATEGORY[cddb_disc_get_category(p_cdda->cddb.disc)]);
break;
case 'G':
if (p_cdda->p_cdtext[0]
&& p_cdda->p_cdtext[0]->field[CDTEXT_GENRE])
psz = p_cdda->p_cdtext[0]->field[CDTEXT_GENRE];
if (want_cddb_info(p_cdda, psz))
- psz = p_cdda->cddb.disc->genre;
+ psz = cddb_disc_get_genre(p_cdda->cddb.disc);
goto format_str;
case 'I':
if (p_cdda->p_cdtext[0]
&& p_cdda->p_cdtext[0]->field[CDTEXT_DISCID])
psz = p_cdda->p_cdtext[0]->field[CDTEXT_DISCID];
if (want_cddb_info(p_cdda, psz)) {
- add_format_num_info(p_cdda->cddb.disc->discid, "%x");
+ add_format_num_info(cddb_disc_get_discid(p_cdda->cddb.disc), "%x");
} else if (psz)
add_format_str_info(psz);
break;
case 'Y':
if (!p_cdda->b_cddb_enabled) goto not_special;
if (p_cdda->cddb.disc)
- add_format_num_info(p_cdda->cddb.disc->year, "%5d");
+ add_format_num_info(cddb_disc_get_year(p_cdda->cddb.disc), "%5d");
break;
case 't':
if ( CDIO_INVALID_TRACK == i_track ) break;
@@ -608,8 +608,8 @@ CDDAFormatStr( const access_t *p_access,
{
cddb_track_t *t=cddb_disc_get_track(p_cdda->cddb.disc,
i_track-1);
- if (t != NULL && t->title != NULL) {
- add_format_str_info(t->title);
+ if (t != NULL && cddb_track_get_title(t) != NULL) {
+ add_format_str_info(cddb_track_get_title(t));
} else {
add_format_str_info(psz_mrl);
}
@@ -631,8 +631,8 @@ CDDAFormatStr( const access_t *p_access,
{
cddb_track_t *t=cddb_disc_get_track(p_cdda->cddb.disc,
i_track-1);
- if (t != NULL && t->artist != NULL)
- psz = t->artist;
+ if (t != NULL && cddb_track_get_artist(t) != NULL)
+ psz = cddb_track_get_artist(t);
}
goto format_str;
case 'e':
@@ -644,8 +644,8 @@ CDDAFormatStr( const access_t *p_access,
{
cddb_track_t *t=cddb_disc_get_track(p_cdda->cddb.disc,
i_track-1);
- if (t != NULL && t->ext_data != NULL)
- psz = t->ext_data;
+ if (t != NULL && cddb_track_get_ext_data(t) != NULL)
+ psz = cddb_track_get_ext_data(t);
}
goto format_str;
break;
@@ -884,15 +884,15 @@ int CDDAAddMetaToItem( access_t *p_acces
if (t)
{
- if (t->artist)
+ if (cddb_track_get_artist(t))
add_playlist_track_info_str("Artist (CDDB)",
- t->artist);
- if (t->title)
+ cddb_track_get_artist(t));
+ if (cddb_track_get_title(t))
add_playlist_track_info_str("Title (CDDB)",
- t->title);
- if (t->ext_data)
+ cddb_track_get_title(t));
+ if (cddb_track_get_ext_data(t))
add_playlist_track_info_str("Extended information (CDDB)",
- t->ext_data);
+ cddb_track_get_ext_data(t));
}
}
#endif /*HAVE_LIBCDDB*/

View file

@ -1,31 +0,0 @@
$NetBSD: patch-af,v 1.1.1.1 2006/05/04 19:20:00 drochner Exp $
--- modules/gui/wxwidgets/open.cpp.orig 2006-05-04 16:27:15.000000000 +0200
+++ modules/gui/wxwidgets/open.cpp
@@ -1334,7 +1334,7 @@ static char * ProbeDVD(const wxChar *dev
{
char **ppsz_cd_drives;
const wxWX2MBbuf tmp_buf = wxConvCurrent->cWX2MB(device);
- char *psz_device = const_cast<char *>(tmp_buf.data());
+ char *psz_device = const_cast<char *>(tmp_buf);
if( IsDVD(psz_device) )
{
@@ -1404,7 +1404,7 @@ static char * ProbeCDDA(const wxChar *de
{
char *ppsz_device[2];
const wxWX2MBbuf tmp_buf = wxConvCurrent->cWX2MB(device);
- char *psz_device = const_cast<char *>(tmp_buf.data());
+ char *psz_device = const_cast<char *>(tmp_buf);
ppsz_device[0] = (device && *device) ? psz_device : NULL;
ppsz_device[1] = NULL;
return ProbeDevice(ppsz_device, CDIO_FS_AUDIO, false);
@@ -1417,7 +1417,7 @@ static char * ProbeVCD(const wxChar *dev
{
char *ppsz_device[2];
const wxWX2MBbuf tmp_buf = wxConvCurrent->cWX2MB(device);
- char *psz_device = const_cast<char *>(tmp_buf.data());
+ char *psz_device = const_cast<char *>(tmp_buf);
ppsz_device[0] = (device && *device) ? psz_device : NULL;
ppsz_device[1] = NULL;
return ProbeDevice(ppsz_device,

View file

@ -0,0 +1,18 @@
$NetBSD: patch-ah,v 1.1 2006/05/10 16:28:43 drochner Exp $
--- src/misc/charset.c.orig 2006-05-06 17:52:13.000000000 +0200
+++ src/misc/charset.c
@@ -37,10 +37,9 @@
#if !defined WIN32
# if HAVE_LANGINFO_CODESET
# include <langinfo.h>
-# else
-# if HAVE_SETLOCALE
-# include <locale.h>
-# endif
+# endif
+# if HAVE_SETLOCALE
+# include <locale.h>
# endif
#elif defined WIN32
# include <windows.h>

View file

@ -0,0 +1,49 @@
$NetBSD: patch-ai,v 1.1 2006/05/10 16:28:43 drochner Exp $
--- configure.orig 2006-05-08 13:43:40.000000000 +0200
+++ configure
@@ -36628,7 +36628,7 @@ fi;
test "${enable_debug}" != "yes" && enable_debug="no"
-if test "x${enable_debug}" == "xno"; then
+if test "x${enable_debug}" = "xno"; then
cat >>confdefs.h <<\_ACEOF
#define NDEBUG 1
_ACEOF
@@ -58120,7 +58120,7 @@ rm -f conftest.err conftest.$ac_objext \
conftest$ac_exeext conftest.$ac_ext
done
LIBS="${LIBS_save}"
- if test "${LIBS_cclink}" == "no"; then
+ if test "${LIBS_cclink}" = "no"; then
{ { echo "$as_me:$LINENO: error: cannot find XML parser for CyberLink
See \`config.log' for more details." >&5
echo "$as_me: error: cannot find XML parser for CyberLink
@@ -58244,7 +58244,7 @@ else
has_upnp="no"
fi
- if test "x${enable_upnp}" != "x" && test "${has_upnp}" == "no"; then
+ if test "x${enable_upnp}" != "x" && test "${has_upnp}" = "no"; then
 
{ { echo "$as_me:$LINENO: error: cannot find Intel UPnP SDK (libupnp)" >&5
echo "$as_me: error: cannot find Intel UPnP SDK (libupnp)" >&2;}
@@ -58252,7 +58252,7 @@ echo "$as_me: error: cannot find Intel U
fi
- if test "${has_upnp}" == "yes"; then
+ if test "${has_upnp}" = "yes"; then
for element in upnp_intel; do
@@ -58271,7 +58271,7 @@ else
fi
-if test "${has_upnp}" == "yes"; then
+if test "${has_upnp}" = "yes"; then
PLUGINS="${PLUGINS} upnp_intel"