Fix build with clang.
This commit is contained in:
parent
76e59c26c3
commit
f8e1d2110a
6 changed files with 74 additions and 2 deletions
|
@ -1,5 +1,6 @@
|
|||
$NetBSD: distinfo,v 1.1.1.1 2008/04/27 06:41:08 wiz Exp $
|
||||
$NetBSD: distinfo,v 1.2 2012/03/28 20:46:57 wiz Exp $
|
||||
|
||||
SHA1 (agg-2.5.tar.gz) = 08f23da64da40b90184a0414369f450115cdb328
|
||||
RMD160 (agg-2.5.tar.gz) = fac24d8ea56ee0a87307189f73c432b07b6d3c50
|
||||
Size (agg-2.5.tar.gz) = 564313 bytes
|
||||
SHA1 (patch-include_agg__renderer__outline__aa.h) = 157cd8287d171bf67039b80ecce1a5ac8360cea8
|
||||
|
|
|
@ -0,0 +1,14 @@
|
|||
$NetBSD: patch-include_agg__renderer__outline__aa.h,v 1.1 2012/03/28 20:46:57 wiz Exp $
|
||||
|
||||
Fix build with clang-3.1 (avoiding unconst by removing unused function).
|
||||
|
||||
--- include/agg_renderer_outline_aa.h.orig 2006-10-09 04:07:08.000000000 +0000
|
||||
+++ include/agg_renderer_outline_aa.h
|
||||
@@ -1375,7 +1375,6 @@ namespace agg
|
||||
//---------------------------------------------------------------------
|
||||
void profile(const line_profile_aa& prof) { m_profile = &prof; }
|
||||
const line_profile_aa& profile() const { return *m_profile; }
|
||||
- line_profile_aa& profile() { return *m_profile; }
|
||||
|
||||
//---------------------------------------------------------------------
|
||||
int subpixel_width() const { return m_profile->subpixel_width(); }
|
|
@ -1,5 +1,8 @@
|
|||
$NetBSD: distinfo,v 1.55 2011/09/12 19:14:42 wiz Exp $
|
||||
$NetBSD: distinfo,v 1.56 2012/03/28 20:40:38 wiz Exp $
|
||||
|
||||
SHA1 (mldonkey-3.1.0.tar.bz2) = 9479c61ab067b01c76cbc11e41477f00a17f5d41
|
||||
RMD160 (mldonkey-3.1.0.tar.bz2) = 69c2bf1937bb2a782166a3b08d87e4537ec03eea
|
||||
Size (mldonkey-3.1.0.tar.bz2) = 2820081 bytes
|
||||
SHA1 (patch-Makefile) = 2ba1d230021ffe2ba0875cb5a0c4ac654d6f7956
|
||||
SHA1 (patch-src_utils_lib_CryptoPP.cc) = e60fa91e0ef423e0f46ceaa3ce822c6b22153847
|
||||
SHA1 (patch-src_utils_lib_CryptoPP.h) = 2d575d8a9b91b419f7791aafc1e0d2de1b8277ba
|
||||
|
|
15
net/mldonkey/patches/patch-Makefile
Normal file
15
net/mldonkey/patches/patch-Makefile
Normal file
|
@ -0,0 +1,15 @@
|
|||
$NetBSD: patch-Makefile,v 1.1 2012/03/28 20:40:38 wiz Exp $
|
||||
|
||||
clang does not know -O6.
|
||||
|
||||
--- Makefile.orig 2011-08-08 05:11:57.000000000 +0000
|
||||
+++ Makefile
|
||||
@@ -5033,7 +5033,7 @@ ocamldoc_html: $(CORE_DOC) $(libclient_D
|
||||
$(OCAMLDOC) -sort -dump ocamldoc/ocamldocdump -html -d ocamldoc $(INCLUDES) $(libclient_DOC) $(CORE_DOC)
|
||||
|
||||
$(LIB)/md4_cc.o: $(LIB)/md4.c
|
||||
- $(OCAMLC) -ccopt "$(CFLAGS) -O6 -o $(LIB)/md4_cc.o" -ccopt "" -c $(LIB)/md4.c
|
||||
+ $(OCAMLC) -ccopt "$(CFLAGS) -o $(LIB)/md4_cc.o" -ccopt "" -c $(LIB)/md4.c
|
||||
|
||||
$(CDK)/heap_c.o: $(CDK)/heap_c.c
|
||||
$(OCAMLC) -ccopt "$(CFLAGS) $(MORECFLAGS) -o $(CDK)/heap_c.o" -ccopt "" -c $(CDK)/heap_c.c
|
15
net/mldonkey/patches/patch-src_utils_lib_CryptoPP.cc
Normal file
15
net/mldonkey/patches/patch-src_utils_lib_CryptoPP.cc
Normal file
|
@ -0,0 +1,15 @@
|
|||
$NetBSD: patch-src_utils_lib_CryptoPP.cc,v 1.1 2012/03/28 20:40:38 wiz Exp $
|
||||
|
||||
Fix build with clang-3.1.
|
||||
|
||||
--- src/utils/lib/CryptoPP.cc.orig 2010-10-23 18:23:38.000000000 +0000
|
||||
+++ src/utils/lib/CryptoPP.cc
|
||||
@@ -5413,7 +5413,7 @@ template <class T> const T& AbstractEucl
|
||||
Element g[3]={b, a};
|
||||
unsigned int i0=0, i1=1, i2=2;
|
||||
|
||||
- while (!Equal(g[i1], this->Identity()))
|
||||
+ while (!this->Equal(g[i1], this->Identity()))
|
||||
{
|
||||
g[i2] = Mod(g[i0], g[i1]);
|
||||
unsigned int t = i0; i0 = i1; i1 = i2; i2 = t;
|
24
net/mldonkey/patches/patch-src_utils_lib_CryptoPP.h
Normal file
24
net/mldonkey/patches/patch-src_utils_lib_CryptoPP.h
Normal file
|
@ -0,0 +1,24 @@
|
|||
$NetBSD: patch-src_utils_lib_CryptoPP.h,v 1.1 2012/03/28 20:40:38 wiz Exp $
|
||||
|
||||
Fix build with clang-3.1.
|
||||
|
||||
--- src/utils/lib/CryptoPP.h.orig 2011-05-07 18:40:00.000000000 +0000
|
||||
+++ src/utils/lib/CryptoPP.h
|
||||
@@ -2633,7 +2633,7 @@ public:
|
||||
|
||||
pointer allocate(size_type n, const void * = NULL)
|
||||
{
|
||||
- CheckSize(n);
|
||||
+ this->CheckSize(n);
|
||||
if (n == 0)
|
||||
return NULL;
|
||||
return new T[n];
|
||||
@@ -5612,7 +5612,7 @@ template <class T, class B, class BASE>
|
||||
{
|
||||
this->ThrowIfInvalidTruncatedSize(size);
|
||||
|
||||
- PadLastBlock(this->BlockSize() - 2*sizeof(HashWordType));
|
||||
+ this->PadLastBlock(this->BlockSize() - 2*sizeof(HashWordType));
|
||||
CorrectEndianess(this->m_data, this->m_data, this->BlockSize() - 2*sizeof(HashWordType));
|
||||
|
||||
this->m_data[this->m_data.size()-2] = B::ToEnum() ? this->GetBitCountHi() : this->GetBitCountLo();
|
Loading…
Reference in a new issue