get rid of autoconf build dependency by patching configure

This commit is contained in:
dillo 2002-10-02 22:30:59 +00:00
parent 317244aa10
commit f96c9310f7
6 changed files with 203 additions and 14 deletions

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.2 2002/08/25 19:23:19 jlam Exp $
# $NetBSD: Makefile,v 1.3 2002/10/02 22:30:59 dillo Exp $
#
DISTNAME= fam-2.6.7
@ -11,14 +11,9 @@ MAINTAINER= packages@netbsd.org
HOMEPAGE= http://oss.sgi.com/projects/fam/
COMMENT= File Alteration Monitor
BUILD_DEPENDS+= autoconf>=2.13:../../devel/autoconf
USE_GMAKE= YES
USE_LIBTOOL= YES
GNU_CONFIGURE= YES
LIBTOOL_OVERRIDE= ${WRKSRC}/libtool
pre-configure:
cd ${WRKSRC} && ${LOCALBASE}/bin/autoconf
.include "../../mk/bsd.pkg.mk"

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.3 2002/08/25 19:23:20 jlam Exp $
$NetBSD: distinfo,v 1.4 2002/10/02 22:30:59 dillo Exp $
SHA1 (fam-2.6.7.tar.gz) = ca03cb4120e3cc7f6bb08c8183b358e240bd5d36
Size (fam-2.6.7.tar.gz) = 241203 bytes
@ -25,3 +25,4 @@ SHA1 (patch-at) = 83f5680d43ad0e06e5eca517cbba2d0866ae42bc
SHA1 (patch-au) = 10d6ce9a3c37ff986c8ff8b786b33d7714d8f904
SHA1 (patch-av) = 18a90c53d641305ef02f71bf443c84d50a2c3fff
SHA1 (patch-aw) = a6b75b6c2b85d1b8247cee16fd23fbaffa346c05
SHA1 (patch-ax) = 197328b2f6444ed052d0ab0ae5d6d5a516fede37

View file

@ -0,0 +1,179 @@
$NetBSD: patch-ax,v 1.1 2002/10/02 22:31:00 dillo Exp $
--- configure.orig Thu Oct 3 00:27:08 2002
+++ configure
@@ -1881,6 +1881,43 @@ fi
+ac_safe=`echo "mntent.h" | sed 'y%./+-%__p_%'`
+echo $ac_n "checking for mntent.h""... $ac_c" 1>&6
+echo "configure:1887: checking for mntent.h" >&5
+if eval "test \"`echo '$''{'ac_cv_header_$ac_safe'+set}'`\" = set"; then
+ echo $ac_n "(cached) $ac_c" 1>&6
+else
+ cat > conftest.$ac_ext <<EOF
+#line 1892 "configure"
+#include "confdefs.h"
+#include <mntent.h>
+EOF
+ac_try="$ac_cpp conftest.$ac_ext >/dev/null 2>conftest.out"
+{ (eval echo configure:1897: \"$ac_try\") 1>&5; (eval $ac_try) 2>&5; }
+ac_err=`grep -v '^ *+' conftest.out | grep -v "^conftest.${ac_ext}\$"`
+if test -z "$ac_err"; then
+ rm -rf conftest*
+ eval "ac_cv_header_$ac_safe=yes"
+else
+ echo "$ac_err" >&5
+ echo "configure: failed program was:" >&5
+ cat conftest.$ac_ext >&5
+ rm -rf conftest*
+ eval "ac_cv_header_$ac_safe=no"
+fi
+rm -f conftest*
+fi
+if eval "test \"`echo '$ac_cv_header_'$ac_safe`\" = yes"; then
+ echo "$ac_t""yes" 1>&6
+ cat >> confdefs.h <<\EOF
+#define HAVE_MNTENT_H 1
+EOF
+
+else
+ echo "$ac_t""no" 1>&6
+fi
+
+
if test `uname` = 'IRIX' || test `uname` = 'IRIX64'; then
have_imon=yes
cat >> confdefs.h <<\EOF
@@ -2382,129 +2419,8 @@ fi
- echo $ac_n "checking mntent.h for MNTTYPE_NFS""... $ac_c" 1>&6
-echo "configure:2387: checking mntent.h for MNTTYPE_NFS" >&5
- cat > conftest.$ac_ext <<EOF
-#line 2389 "configure"
-#include "confdefs.h"
-#include <mntent.h>
-int main() {
-const char *foo = MNTTYPE_NFS;
-; return 0; }
-EOF
-if { (eval echo configure:2396: \"$ac_compile\") 1>&5; (eval $ac_compile) 2>&5; }; then
- rm -rf conftest*
- fam_have_decl_in_mntent=yes
-else
- echo "configure: failed program was:" >&5
- cat conftest.$ac_ext >&5
- rm -rf conftest*
- fam_have_decl_in_mntent=no
-fi
-rm -f conftest*
- echo "$ac_t""$fam_have_decl_in_mntent" 1>&6
- if test "$fam_have_decl_in_mntent" = "yes"; then
- :
- else
- { echo "configure: error: Didn't find MNTTYPE_NFS in mntent.h" 1>&2; exit 1; }
- fi
-
-
- echo $ac_n "checking mntent.h for MNTTYPE_NFS2""... $ac_c" 1>&6
-echo "configure:2415: checking mntent.h for MNTTYPE_NFS2" >&5
- cat > conftest.$ac_ext <<EOF
-#line 2417 "configure"
-#include "confdefs.h"
-#include <mntent.h>
-int main() {
-const char *foo = MNTTYPE_NFS2;
-; return 0; }
-EOF
-if { (eval echo configure:2424: \"$ac_compile\") 1>&5; (eval $ac_compile) 2>&5; }; then
- rm -rf conftest*
- fam_have_decl_in_mntent=yes
-else
- echo "configure: failed program was:" >&5
- cat conftest.$ac_ext >&5
- rm -rf conftest*
- fam_have_decl_in_mntent=no
-fi
-rm -f conftest*
- echo "$ac_t""$fam_have_decl_in_mntent" 1>&6
- if test "$fam_have_decl_in_mntent" = "yes"; then
- cat >> confdefs.h <<\EOF
-#define HAVE_MNTTYPE_NFS2 1
-EOF
-
- else
- :
- fi
-
-
- echo $ac_n "checking mntent.h for MNTTYPE_NFS3""... $ac_c" 1>&6
-echo "configure:2446: checking mntent.h for MNTTYPE_NFS3" >&5
- cat > conftest.$ac_ext <<EOF
-#line 2448 "configure"
-#include "confdefs.h"
-#include <mntent.h>
-int main() {
-const char *foo = MNTTYPE_NFS3;
-; return 0; }
-EOF
-if { (eval echo configure:2455: \"$ac_compile\") 1>&5; (eval $ac_compile) 2>&5; }; then
- rm -rf conftest*
- fam_have_decl_in_mntent=yes
-else
- echo "configure: failed program was:" >&5
- cat conftest.$ac_ext >&5
- rm -rf conftest*
- fam_have_decl_in_mntent=no
-fi
-rm -f conftest*
- echo "$ac_t""$fam_have_decl_in_mntent" 1>&6
- if test "$fam_have_decl_in_mntent" = "yes"; then
- cat >> confdefs.h <<\EOF
-#define HAVE_MNTTYPE_NFS3 1
-EOF
-
- else
- :
- fi
-
-
- echo $ac_n "checking mntent.h for MNTTYPE_CACHEFS""... $ac_c" 1>&6
-echo "configure:2477: checking mntent.h for MNTTYPE_CACHEFS" >&5
- cat > conftest.$ac_ext <<EOF
-#line 2479 "configure"
-#include "confdefs.h"
-#include <mntent.h>
-int main() {
-const char *foo = MNTTYPE_CACHEFS;
-; return 0; }
-EOF
-if { (eval echo configure:2486: \"$ac_compile\") 1>&5; (eval $ac_compile) 2>&5; }; then
- rm -rf conftest*
- fam_have_decl_in_mntent=yes
-else
- echo "configure: failed program was:" >&5
- cat conftest.$ac_ext >&5
- rm -rf conftest*
- fam_have_decl_in_mntent=no
-fi
-rm -f conftest*
- echo "$ac_t""$fam_have_decl_in_mntent" 1>&6
- if test "$fam_have_decl_in_mntent" = "yes"; then
- cat >> confdefs.h <<\EOF
-#define HAVE_MNTTYPE_CACHEFS 1
-EOF
-
- else
- :
- fi
-
-
echo $ac_n "checking netinet/in.h for bindresvport()""... $ac_c" 1>&6
-echo "configure:2508: checking netinet/in.h for bindresvport()" >&5
+echo "configure:2424: checking netinet/in.h for bindresvport()" >&5
if eval "test \"`echo '$''{'fam_cv_bindresvport_in_in_h'+set}'`\" = set"; then
echo $ac_n "(cached) $ac_c" 1>&6
else

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.23 2002/09/19 09:04:27 jlam Exp $
# $NetBSD: Makefile,v 1.24 2002/10/02 22:38:59 dillo Exp $
#
DISTNAME= nut-0.50.0
@ -10,8 +10,6 @@ MAINTAINER= lukem@netbsd.org
HOMEPAGE= http://www.exploits.org/nut/
COMMENT= Network UPS Tools
BUILD_DEPENDS+= autoconf>=2.13:../../devel/autoconf
USE_BUILDLINK2= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --sysconfdir=${NUT_CONFDIR} \
@ -58,9 +56,6 @@ RCD_SCRIPTS= ups upsd upsdriver upslog upsmon
OWN_DIRS= ${NUT_CONFDIR}
OWN_DIRS_PERMS= ${NUT_STATEDIR} ${NUT_USER} ${NUT_GROUP} 0770
pre-configure:
cd ${WRKSRC}; ${LOCALBASE}/bin/autoreconf --force
pre-install:
@${INSTALL_DATA_DIR} ${NUT_EGDIR}

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.14 2002/08/25 21:51:05 jlam Exp $
$NetBSD: distinfo,v 1.15 2002/10/02 22:38:59 dillo Exp $
SHA1 (nut-0.50.0.tar.gz) = b8826f2e7301e5c753ac946574a53d651faf69c3
Size (nut-0.50.0.tar.gz) = 382755 bytes
@ -7,3 +7,4 @@ SHA1 (patch-ab) = fac1a47430a2c2d692ecede2ac6ed78c60a82566
SHA1 (patch-ac) = 60b2ac079232ab4af1b41928760601f0a09b9ae1
SHA1 (patch-ad) = 1132a678cc53882cc92764ed17bbd4cf4152c58d
SHA1 (patch-ag) = b6ae992f9b92d68683ac6adb7378d11158cc1fdc
SHA1 (patch-ah) = 352138de98a1a0451f20e6b60e4f0f44bcbe645d

View file

@ -0,0 +1,18 @@
$NetBSD: patch-ah,v 1.1 2002/10/02 22:39:00 dillo Exp $
--- configure.orig Thu Oct 3 00:37:12 2002
+++ configure
@@ -2684,13 +2684,6 @@ fi
-grep "^$RUN_AS_GROUP:" /etc/group >/dev/null 2>/dev/null
-if (test "$?" = "1")
-then
- # not found, fatal error
- echo "configure: warning: $RUN_AS_GROUP not found in /etc/group!" 1>&2
- echo "configure: warning: You might want to rerun configure using --with-group and another group name." 1>&2
-fi
echo $ac_n "checking facility for syslog""... $ac_c" 1>&6