Update parrot from version 1.8.0 to 1.9.0.

Pkgsrc changes:
 o Adjust patches to match new code
 o Adjust PLIST to what's being installed

Upstream changes:

- Core
  + Made profiling runcore output format configurable and extensible
    options include "pprof" and "none" ("binary" and "callgrind" are planned)
  + Added environment variables to specify profiling output type and filename
    (PARROT_PROFILING_OUTPUT and PARROT_PROFILING_FILENAME)
  + Began merging Freeze/Thaw and Bytecode generator/loader
- Compilers
  + Included latest nqp-rx compiler, with many improvements
    - GLOBAL:: package identifier
    - dynamic variables look in global namespace
    - $obj."$method" syntax
    - :p(os) and :c(ontinue) option on regexes
    - try/CATCH/CONTROL handling
    - support leading & on subroutine declarations
    - allow "category:" names (for builtin operators)
    - simple version of smartmatch operator
    - simple regex matches
    - updated HLL::Compiler with new import/export methods
- Miscellaneous
  + Portability updates for RTEMS, and Intel architectures with GNU compilers
  + Completed conversion of ticket tracking system from RT to Trac
  + New draft of PDD31 for HLL export API and import implementation
  + Several (build time, runtime) performance improvements
  + Converted many tests to PIR, reducing test execution time
  + Various bugfixes, code cleanups, and coding standard fixes
This commit is contained in:
he 2010-01-28 13:06:18 +00:00
parent 7cc9684ff4
commit f97dd8cf52
5 changed files with 21 additions and 22 deletions

View file

@ -1,7 +1,7 @@
# $NetBSD: Makefile,v 1.25 2009/12/17 14:47:35 he Exp $
# $NetBSD: Makefile,v 1.26 2010/01/28 13:06:18 he Exp $
#
VERSION= 1.8.0
VERSION= 1.9.0
RTYPE= devel
DISTNAME= parrot-${VERSION}
CATEGORIES= lang

View file

@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.11 2009/12/17 14:47:35 he Exp $
@comment $NetBSD: PLIST,v 1.12 2010/01/28 13:06:19 he Exp $
bin/parrot
bin/parrot-nqp
bin/parrot_config
@ -193,8 +193,8 @@ lib/parrot/${PKGVERSION}/library/CGI/QueryHash.pbc
lib/parrot/${PKGVERSION}/library/CGI/QueryHash.pir
lib/parrot/${PKGVERSION}/library/Config/JSON.pbc
lib/parrot/${PKGVERSION}/library/Config/JSON.pir
lib/parrot/${PKGVERSION}/library/Configure.pbc
lib/parrot/${PKGVERSION}/library/Configure.pir
lib/parrot/${PKGVERSION}/library/Configure/genfile.pbc
lib/parrot/${PKGVERSION}/library/Configure/genfile.pir
lib/parrot/${PKGVERSION}/library/Crow.pbc
lib/parrot/${PKGVERSION}/library/Crow.pir
lib/parrot/${PKGVERSION}/library/Curses.pir
@ -339,6 +339,7 @@ lib/parrot/${PKGVERSION}/library/yaml_dumper.pir
lib/parrot/${PKGVERSION}/parrot_config.o
lib/parrot/${PKGVERSION}/tools/build/ops2c.pl
lib/parrot/${PKGVERSION}/tools/build/pmc2c.pl
lib/parrot/${PKGVERSION}/tools/dev/create_language.pl
lib/parrot/${PKGVERSION}/tools/dev/gen_makefile.pl
lib/parrot/${PKGVERSION}/tools/dev/mk_language_shell.pl
lib/parrot/${PKGVERSION}/tools/dev/pbc_to_exe.pir
@ -362,6 +363,7 @@ lib/parrot/${PKGVERSION}/tools/lib/Parrot/Configure/Options/Test/Prepare.pm
lib/parrot/${PKGVERSION}/tools/lib/Parrot/Configure/Step.pm
lib/parrot/${PKGVERSION}/tools/lib/Parrot/Configure/Step/List.pm
lib/parrot/${PKGVERSION}/tools/lib/Parrot/Configure/Step/Methods.pm
lib/parrot/${PKGVERSION}/tools/lib/Parrot/Configure/Step/Test.pm
lib/parrot/${PKGVERSION}/tools/lib/Parrot/Configure/Test.pm
lib/parrot/${PKGVERSION}/tools/lib/Parrot/Configure/Trace.pm
lib/parrot/${PKGVERSION}/tools/lib/Parrot/Configure/Utils.pm
@ -440,11 +442,9 @@ lib/parrot/${PKGVERSION}/tools/lib/Parrot/Pmc2c/VTable.pm
lib/parrot/${PKGVERSION}/tools/lib/Parrot/Revision.pm
lib/parrot/${PKGVERSION}/tools/lib/Parrot/SearchOps.pm
lib/parrot/${PKGVERSION}/tools/lib/Parrot/Test.pm
lib/parrot/${PKGVERSION}/tools/lib/Parrot/Test/Cardinal.pm
lib/parrot/${PKGVERSION}/tools/lib/Parrot/Test/Harness.pm
lib/parrot/${PKGVERSION}/tools/lib/Parrot/Test/PGE.pm
lib/parrot/${PKGVERSION}/tools/lib/Parrot/Test/PIR_PGE.pm
lib/parrot/${PKGVERSION}/tools/lib/Parrot/Test/Perl6.pm
lib/parrot/${PKGVERSION}/tools/lib/Parrot/Test/Pod.pm
lib/parrot/${PKGVERSION}/tools/lib/Parrot/Test/Pod/Utils.pm
lib/parrot/${PKGVERSION}/tools/lib/Parrot/Test/Util.pm
@ -516,7 +516,6 @@ src/parrot/${PKGVERSION}/pmc/bignum.pmc
src/parrot/${PKGVERSION}/pmc/boolean.dump
src/parrot/${PKGVERSION}/pmc/boolean.pmc
src/parrot/${PKGVERSION}/pmc/callsignature.pmc
src/parrot/${PKGVERSION}/pmc/callsignaturereturns.pmc
src/parrot/${PKGVERSION}/pmc/capture.pmc
src/parrot/${PKGVERSION}/pmc/class.pmc
src/parrot/${PKGVERSION}/pmc/codestring.pmc

View file

@ -1,8 +1,8 @@
$NetBSD: distinfo,v 1.20 2009/12/17 14:47:35 he Exp $
$NetBSD: distinfo,v 1.21 2010/01/28 13:06:19 he Exp $
SHA1 (parrot-1.8.0.tar.gz) = 7b9da16c51a9a863ae02c7c8bd5626a015d8cf25
RMD160 (parrot-1.8.0.tar.gz) = 8785b7f0a15d7e0d67563ead626cf069594945d2
Size (parrot-1.8.0.tar.gz) = 4035226 bytes
SHA1 (patch-ad) = 9002a7ca55f8f960bea669e383431b3eeb83a878
SHA1 (patch-ae) = 72e4752112dab2f0b72ede5c45b77fd5b5554606
SHA1 (parrot-1.9.0.tar.gz) = 5f9fe29bb317d3b3f6e8caaf79fb27d5e8627ea5
RMD160 (parrot-1.9.0.tar.gz) = 1d63025b29a5c13a357cd6855cb89fa0489c4b81
Size (parrot-1.9.0.tar.gz) = 4065631 bytes
SHA1 (patch-ad) = c78517453408f1e4bb05e2bd8c2967b8f6f47c6e
SHA1 (patch-ae) = 34994ac2344b0c5b3ba3556b4f60e0f77b6feb31
SHA1 (patch-ak) = 2caa175c26fcf717f6377fadd04b74a7c9cf750d

View file

@ -1,15 +1,15 @@
$NetBSD: patch-ad,v 1.3 2009/04/14 23:50:20 he Exp $
$NetBSD: patch-ad,v 1.4 2010/01/28 13:06:19 he Exp $
Allow parrot to detect perldoc when run as root. Perldoc changes
uid to 'nobody', 'nouser' or uid -2 when run as root, so it won't
be able to write files created by root with mode 0600 (or create new
files in directories owned by root mode 0755).
--- config/auto/perldoc.pm.orig 2009-03-08 21:32:47.000000000 +0100
--- config/auto/perldoc.pm.orig 2009-12-15 18:22:07.000000000 +0100
+++ config/auto/perldoc.pm
@@ -38,7 +38,9 @@ sub runstep {
my $cmd = $conf->data->get_p5('scriptdirexp') . q{/perldoc};
my $cmd = $conf->data->get('scriptdirexp_provisional') . q{/perldoc};
my ( $fh, $filename ) = tempfile( UNLINK => 1 );
- my $content = capture_output("$cmd -ud $filename perldoc") || undef;
+ my($stdout, $stderr, $retval) =

View file

@ -1,11 +1,11 @@
$NetBSD: patch-ae,v 1.1 2009/04/14 23:50:20 he Exp $
$NetBSD: patch-ae,v 1.2 2010/01/28 13:06:19 he Exp $
Perldoc's -d is incompatible with doing the build as root.
--- config/gen/makefiles/docs.in.orig 2009-03-09 05:41:01.000000000 +0100
--- config/gen/makefiles/docs.in.orig 2009-12-15 18:22:07.000000000 +0100
+++ config/gen/makefiles/docs.in
@@ -37,7 +37,7 @@ doc-prep:
$(MKPATH) ops
@@ -41,7 +41,7 @@ doc-prep:
$(TOUCH) doc-prep
packfile-c.pod: ../src/packfile.c
-#IF(new_perldoc): $(PERLDOC) -ud packfile-c.pod ../src/packfile.c