qtcreator: Install desktop files on non-Linux too

This commit is contained in:
nia 2021-05-15 11:42:24 +00:00
parent 6e3e8dc0de
commit f98dd49f41
4 changed files with 36 additions and 5 deletions

View file

@ -1,8 +1,8 @@
# $NetBSD: Makefile,v 1.4 2021/04/21 11:41:34 adam Exp $
# $NetBSD: Makefile,v 1.5 2021/05/15 11:42:24 nia Exp $
DISTNAME= qt-creator-opensource-src-4.13.2
PKGNAME= ${DISTNAME:S/qt-/qt/:S/-opensource-src//}
PKGREVISION= 3
PKGREVISION= 4
CATEGORIES= editors
MASTER_SITES= http://download.qt.io/official_releases/${PKGBASE}/${PKGVERSION_NOREV:R}/${PKGVERSION_NOREV}/
MASTER_SITES+= http://download.qt.io/archive/${PKGBASE}/${PKGVERSION_NOREV:R}/${PKGVERSION_NOREV}/
@ -79,14 +79,15 @@ do-configure:
QMAKE_RPATHDIR+=${LOCALBASE}/lib/qtcreator/plugins \
-o Makefile
.include "../../databases/sqlite3/buildlink3.mk"
.include "../../graphics/hicolor-icon-theme/buildlink3.mk"
.include "../../lang/python/application.mk"
.include "../../lang/clang/buildlink3.mk"
.include "../../sysutils/desktop-file-utils/desktopdb.mk"
.include "../../x11/qt5-qtsvg/buildlink3.mk"
.include "../../x11/qt5-qtserialport/buildlink3.mk"
.include "../../x11/qt5-qtscript/buildlink3.mk"
.include "../../x11/qt5-qtbase/buildlink3.mk"
.include "../../databases/sqlite3/buildlink3.mk"
.include "../../mk/dlopen.buildlink3.mk"
# XXX libSqlite.so fails to link but silently resumes without this.
# XXX Unclear why the conditional doesn't work for NetBSD.

View file

@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.1 2020/11/28 15:56:45 maya Exp $
@comment $NetBSD: PLIST,v 1.2 2021/05/15 11:42:24 nia Exp $
bin/qbs
bin/qbs-config
bin/qbs-config-ui
@ -170,6 +170,7 @@ libexec/qtcreator/qtc-askpass
libexec/qtcreator/qtcreator_process_stub
libexec/qtcreator/qtpromaker
libexec/qtcreator/sdktool
share/applications/org.qt-project.qtcreator.desktop
share/doc/qtcreator/qtcreator-dev.qch
share/doc/qtcreator/qtcreator.qch
share/icons/hicolor/128x128/apps/QtProject-qtcreator.png
@ -180,6 +181,7 @@ share/icons/hicolor/32x32/apps/QtProject-qtcreator.png
share/icons/hicolor/48x48/apps/QtProject-qtcreator.png
share/icons/hicolor/512x512/apps/QtProject-qtcreator.png
share/icons/hicolor/64x64/apps/QtProject-qtcreator.png
share/metainfo/org.qt-project.qtcreator.appdata.xml
share/qtcreator/android/sdk_definitions.json
share/qtcreator/cplusplus/examples/CMakeLists.txt
share/qtcreator/cplusplus/examples/clazy_example.cpp

View file

@ -1,6 +1,7 @@
$NetBSD: distinfo,v 1.1 2020/11/28 15:56:45 maya Exp $
$NetBSD: distinfo,v 1.2 2021/05/15 11:42:24 nia Exp $
SHA1 (qt-creator-opensource-src-4.13.2.zip) = 8665c26a95f4e83b85840abd40dd949163a120fb
RMD160 (qt-creator-opensource-src-4.13.2.zip) = ecdba94f789ffd1747a0c6edfdff79e0bf509437
SHA512 (qt-creator-opensource-src-4.13.2.zip) = efbe7f4ee6ccfcd32ecd182e4a7c88023df86790771c1621b732530fa8bb1f125f0e809c92806903e401a6192df9b3876cc87bae4b504c4e4fbf2e5407b0203a
Size (qt-creator-opensource-src-4.13.2.zip) = 65177262 bytes
SHA1 (patch-qtcreator.pro) = 7f96fc4106ed17e4f7c802ba649392125e23d0c4

View file

@ -0,0 +1,27 @@
$NetBSD: patch-qtcreator.pro,v 1.1 2021/05/15 11:42:24 nia Exp $
Install desktop files on non-Linux too.
--- qtcreator.pro.orig 2020-10-01 00:17:08.000000000 +0000
+++ qtcreator.pro
@@ -97,15 +97,13 @@ else: PLATFORM = "unknown"
BASENAME = $$(INSTALL_BASENAME)
isEmpty(BASENAME): BASENAME = qt-creator-$${PLATFORM}$(INSTALL_EDITION)-$${QTCREATOR_VERSION}$(INSTALL_POSTFIX)
-linux {
- appstream.files = share/metainfo/org.qt-project.qtcreator.appdata.xml
- appstream.path = $$QTC_PREFIX/share/metainfo/
+appstream.files = share/metainfo/org.qt-project.qtcreator.appdata.xml
+appstream.path = $$QTC_PREFIX/share/metainfo/
- desktop.files = share/applications/org.qt-project.qtcreator.desktop
- desktop.path = $$QTC_PREFIX/share/applications/
+desktop.files = share/applications/org.qt-project.qtcreator.desktop
+desktop.path = $$QTC_PREFIX/share/applications/
- INSTALLS += appstream desktop
-}
+INSTALLS += appstream desktop
macx {
APPBUNDLE = "$$OUT_PWD/bin/$${IDE_APP_TARGET}.app"