wabt: updated to 1.0.34

Major changes since 1.0.33:

Parse & write custom-section annotations
Partial wasm2c support for the threads proposal
wasm2c support for the tail-call proposal
Update multi-memory support to match upstream proposal
wasm-opcodecnt renamed to wasm-stats
wasm2c fixes for MIPS
Support global.get in constant expressions
Better spec-compliant parsing on some edge cases
Improved parsing and validation for memory64
This commit is contained in:
adam 2023-10-25 09:05:25 +00:00
parent 4331bef52c
commit f9b7e3d5b9
4 changed files with 39 additions and 23 deletions

View file

@ -1,27 +1,20 @@
# $NetBSD: Makefile,v 1.21 2023/10/24 22:08:59 wiz Exp $
# $NetBSD: Makefile,v 1.22 2023/10/25 09:05:25 adam Exp $
DISTNAME= wabt-1.0.33
PKGREVISION= 1
DISTNAME= wabt-1.0.34
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_GITHUB:=WebAssembly/}
MAINTAINER= pkgsrc-users@NetBSD.org
HOMEPAGE= https://github.com/WebAssembly/wabt/
HOMEPAGE= https://github.com/WebAssembly/wabt
COMMENT= The WebAssembly Binary Toolkit
LICENSE= apache-2.0
CONFIGURE_DIRS= ${WRKDIR}/build
CMAKE_ARG_PATH= ${WRKSRC}
USE_CMAKE= yes
USE_LANGUAGES= c c++
USE_CXX_FEATURES+= c++17
USE_LANGUAGES= c c++
CMAKE_ARGS+= -DBUILD_TESTS=OFF -DBUILD_LIBWASM=OFF
post-extract:
${MKDIR} ${WRKDIR}/build
CMAKE_CONFIGURE_ARGS+= -DBUILD_LIBWASM=OFF
CMAKE_CONFIGURE_ARGS+= -DBUILD_TESTS=OFF
.include "../../devel/cmake/build.mk"
.include "../../security/openssl/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

View file

@ -1,9 +1,9 @@
@comment $NetBSD: PLIST,v 1.4 2023/05/22 14:10:42 fcambus Exp $
@comment $NetBSD: PLIST,v 1.5 2023/10/25 09:05:25 adam Exp $
bin/spectest-interp
bin/wasm-decompile
bin/wasm-interp
bin/wasm-objdump
bin/wasm-opcodecnt
bin/wasm-stats
bin/wasm-strip
bin/wasm-validate
bin/wasm2c
@ -17,7 +17,7 @@ include/wabt/binary-reader-ir.h
include/wabt/binary-reader-logging.h
include/wabt/binary-reader-nop.h
include/wabt/binary-reader-objdump.h
include/wabt/binary-reader-opcnt.h
include/wabt/binary-reader-stats.h
include/wabt/binary-reader.h
include/wabt/binary-writer-spec.h
include/wabt/binary-writer.h
@ -25,7 +25,6 @@ include/wabt/binary.h
include/wabt/binding-hash.h
include/wabt/c-writer.h
include/wabt/cast.h
include/wabt/circular-array.h
include/wabt/color.h
include/wabt/common.h
include/wabt/config.h
@ -88,7 +87,7 @@ man/man1/spectest-interp.1
man/man1/wasm-decompile.1
man/man1/wasm-interp.1
man/man1/wasm-objdump.1
man/man1/wasm-opcodecnt.1
man/man1/wasm-stats.1
man/man1/wasm-strip.1
man/man1/wasm-validate.1
man/man1/wasm2c.1

View file

@ -1,6 +1,7 @@
$NetBSD: distinfo,v 1.17 2023/05/22 14:10:42 fcambus Exp $
$NetBSD: distinfo,v 1.18 2023/10/25 09:05:25 adam Exp $
BLAKE2s (wabt-1.0.33.tar.gz) = 7bd51360eeb6ec5418bfb6ca42c7ea27490db4ba1fb51cfa0aba08156e598d25
SHA512 (wabt-1.0.33.tar.gz) = cf9069a09618ec81c83c3774aee4534149b6e9c53a502bab8786ff421fbe44e2774d2ff1566a62c013147ddb43286eaa70c6f62a6ca91ee0862329d2ab2730c2
Size (wabt-1.0.33.tar.gz) = 1204437 bytes
BLAKE2s (wabt-1.0.34.tar.gz) = f2f347836c2bf6f707661fcfd29926a98af22208c11fce38d841b920726c8edd
SHA512 (wabt-1.0.34.tar.gz) = 93be77d18b2311276af2abff8a954f3d029b1689ba8c89e1c3f0d199ddc0af505ffaa8489fbe0df4fc8beae1a37c645971d63794ff440e305042ff1b94bd83ef
Size (wabt-1.0.34.tar.gz) = 1226317 bytes
SHA1 (patch-CMakeLists.txt) = e65ad4657be060a20273e88014dc3279cfe1e230
SHA1 (patch-src_c-writer.cc) = ada8263e188d127c0a109b7d94fcd772afd46c03

View file

@ -0,0 +1,23 @@
$NetBSD: patch-src_c-writer.cc,v 1.1 2023/10/25 09:05:25 adam Exp $
Fix build: when C++ extensions are enabled, 'typeof' is a keyword.
--- src/c-writer.cc.orig 2023-10-25 09:00:25.236147060 +0000
+++ src/c-writer.cc
@@ -2957,14 +2957,14 @@ void CWriter::Write(const Func& func) {
template <typename Vars, typename TypeOf, typename ToDo>
void CWriter::WriteVarsByType(const Vars& vars,
- const TypeOf& typeof,
+ const TypeOf& type_of,
const ToDo& todo) {
for (Type type : {Type::I32, Type::I64, Type::F32, Type::F64, Type::V128,
Type::FuncRef, Type::ExternRef}) {
Index var_index = 0;
size_t count = 0;
for (const auto& var : vars) {
- if (typeof(var) == type) {
+ if (type_of(var) == type) {
if (count == 0) {
Write(type, " ");
Indent(4);