Rudimentary support for Sun Studio on x86.

This commit is contained in:
sketch 2009-01-26 15:01:56 +00:00
parent 58627bc5ce
commit f9d1523a14
3 changed files with 29 additions and 1 deletions

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.3 2008/12/22 02:46:52 jmcneill Exp $
$NetBSD: distinfo,v 1.4 2009/01/26 15:01:56 sketch Exp $
SHA1 (libatomic_ops-20081024.tar.gz) = 70dcc68c89ea8ce8b8e6c936ea337eca31f13662
RMD160 (libatomic_ops-20081024.tar.gz) = a9194631fafc2d4ce68cea93dbc212d7212cab13
@ -6,3 +6,5 @@ Size (libatomic_ops-20081024.tar.gz) = 193399 bytes
SHA1 (patch-aa) = bf53ad892ba270b1d7a9bd1fa14012ca83ab5323
SHA1 (patch-ab) = 74674124fff34faf2aae0d694566c66ffaf9df25
SHA1 (patch-ac) = 40eeac276e322ea6f28743c183c11e92b1ab8de5
SHA1 (patch-ad) = 5952b7a292a381b00b8e101bdf48452555a5a660
SHA1 (patch-ae) = 5fe403a33d8b49e0ac3f21aaa65ea42d5e656251

View file

@ -0,0 +1,16 @@
$NetBSD: patch-ad,v 1.1 2009/01/26 15:01:56 sketch Exp $
--- src/atomic_ops.h.orig Wed Oct 22 02:12:17 2008
+++ src/atomic_ops.h Mon Jan 26 14:48:46 2009
@@ -251,7 +251,10 @@
# endif
#endif
-#if !defined(__GNUC__) && (defined(sparc) || defined(__sparc)) \
+#if defined(__SUNPRO_C) && defined(__i386)
+# include "atomic_ops/sysdeps/sunc/x86.h"
+# define AO_CAN_EMUL_CAS
+#elif !defined(__GNUC__) && (defined(sparc) || defined(__sparc)) \
&& !defined(AO_USE_PTHREAD_DEFS)
# include "atomic_ops/sysdeps/sunc/sparc.h"
# define AO_CAN_EMUL_CAS

View file

@ -0,0 +1,10 @@
$NetBSD: patch-ae,v 1.1 2009/01/26 15:01:56 sketch Exp $
--- /dev/null 2009-01-26 14:55:50.000000000 +0000
+++ src/atomic_ops/sysdeps/sunc/x86.h 2009-01-26 14:48:08.246647402 +0000
@@ -0,0 +1,5 @@
+#include "../all_aligned_atomic_load_store.h"
+#include "../ordered_except_wr.h"
+#include "../test_and_set_t_is_char.h"
+#include "../standard_ao_double_t.h"
+#include "../ao_t_is_int.h"