Reimport of package namazu from japanese/namazu1 into textproc/namazu1.
This is part of the japanese category retirement. Pathnames to japanese/ adjusted.
This commit is contained in:
parent
c3b498ceff
commit
fa0f6e46a7
7 changed files with 215 additions and 0 deletions
18
textproc/namazu1/DEINSTALL
Normal file
18
textproc/namazu1/DEINSTALL
Normal file
|
@ -0,0 +1,18 @@
|
|||
#!/bin/sh
|
||||
#
|
||||
# $NetBSD: DEINSTALL,v 1.1.1.1 2002/05/31 13:01:39 seb Exp $
|
||||
#
|
||||
|
||||
case "$2" in
|
||||
DEINSTALL) cat <<EOF
|
||||
|
||||
=============================================================
|
||||
Note that namazu configuration (@CONFDIR@/*), index
|
||||
files (@INDEXDIR@/*) are not removed in the
|
||||
de-installation process. You should remove those by hand,
|
||||
if you no longer need them.
|
||||
=============================================================
|
||||
|
||||
EOF
|
||||
;;
|
||||
esac
|
9
textproc/namazu1/DESCR
Normal file
9
textproc/namazu1/DESCR
Normal file
|
@ -0,0 +1,9 @@
|
|||
Namazu is a full-text search system intended for easy use. Not only it works
|
||||
as a CGI program for a small or medium scale Web search engine, but also works
|
||||
as a personal use search system for your pile of email.
|
||||
|
||||
(The Japanese word `Namazu' means `catfish' in English.)
|
||||
|
||||
Note: Namazu's newer version already exists. Since index file format has
|
||||
changed, this pacakge is provided for users who want to continute to use
|
||||
existing index files.
|
27
textproc/namazu1/INSTALL
Normal file
27
textproc/namazu1/INSTALL
Normal file
|
@ -0,0 +1,27 @@
|
|||
#!/bin/sh
|
||||
#
|
||||
# $NetBSD: INSTALL,v 1.1.1.1 2002/05/31 13:01:39 seb Exp $
|
||||
|
||||
PKGNAME=$1
|
||||
STAGE=$2
|
||||
|
||||
case ${STAGE} in
|
||||
PRE-INSTALL)
|
||||
;;
|
||||
POST-INSTALL)
|
||||
cat <<EOF
|
||||
|
||||
=============================================================
|
||||
If you customize namazu configuration, copy
|
||||
@DOCDIR@/namazu.conf-dist to
|
||||
@CONFDIR@ and edit them.
|
||||
=============================================================
|
||||
|
||||
EOF
|
||||
;;
|
||||
*)
|
||||
echo "Unexpected argument: ${STAGE}"
|
||||
exit 1
|
||||
;;
|
||||
esac
|
||||
exit 0
|
60
textproc/namazu1/Makefile
Normal file
60
textproc/namazu1/Makefile
Normal file
|
@ -0,0 +1,60 @@
|
|||
# $NetBSD: Makefile,v 1.1.1.1 2002/05/31 13:01:39 seb Exp $
|
||||
# FreeBSD Id: Makefile,v 1.1.1.1 1999/03/31 11:52:07 flathill Exp $
|
||||
|
||||
DISTNAME= namazu-1.3.0.11
|
||||
PKGREVISION= 1
|
||||
CATEGORIES= japanese textproc
|
||||
MASTER_SITES= http://www.namazu.org/stable/
|
||||
|
||||
MAINTAINER= tech-pkg-ja@jp.netbsd.org
|
||||
HOMEPAGE= http://www.namazu.org/index.html.en
|
||||
COMMENT= Namazu is a search engine software intended for easy use
|
||||
|
||||
DEPENDS= kakasi>=2.3.1:../../textproc/kakasi
|
||||
DEPENDS+= nkf-1.7:../../converters/nkf
|
||||
.if !defined(WITH_CHASEN) || ${WITH_CHASEN} != NO
|
||||
DEPENDS+= p5-Text-ChaSen>=1.0:../../textproc/p5-Text-ChaSen
|
||||
.endif
|
||||
|
||||
CONFIGURE_ARGS+= --with-cgi-dir=${LOCALBASE}/libexec/cgi-bin
|
||||
.if defined(WITH_CHASEN) && ${WITH_CHASEN} == NO
|
||||
CONFIGURE_ARGS+= -without-chasen
|
||||
.else
|
||||
CONFIGURE_ARGS+= -with-chasen
|
||||
.endif
|
||||
|
||||
DEINSTALL_FILE= ${WRKDIR}/DEINSTALL
|
||||
INSTALL_FILE= ${WRKDIR}/INSTALL
|
||||
|
||||
USE_PERL5= yes
|
||||
GNU_CONFIGURE= yes
|
||||
|
||||
CONFLICTS+= namazu-[0-9]*
|
||||
|
||||
WRKSRC= ${WRKDIR}/${DISTNAME}/src
|
||||
CONTRIBDIR= ${WRKDIR}/${DISTNAME}/contrib
|
||||
|
||||
CONFDIR= ${LOCALBASE}/etc/namazu
|
||||
DOCDIR= ${LOCALBASE}/share/namazu/doc
|
||||
INDEXDIR= ${LOCALBASE}/libdata/namazu
|
||||
|
||||
post-build:
|
||||
@${SED} -e 's|/usr/bin/perl|${LOCALBASE}/bin/perl|g' \
|
||||
< ${CONTRIBDIR}/bnamazu > ${WRKDIR}/bnamazu
|
||||
@for FILE in \
|
||||
${PKGDIR}/DEINSTALL \
|
||||
${PKGDIR}/INSTALL; \
|
||||
do \
|
||||
${SED} -e 's|@CONFDIR@|${CONFDIR}|g' \
|
||||
-e 's|@INDEXDIR@|${INDEXDIR}|g' \
|
||||
-e 's|@DOCDIR@|${DOCDIR}|g' \
|
||||
< $${FILE} > ${WRKDIR}/`basename $${FILE}`; \
|
||||
done
|
||||
|
||||
post-install:
|
||||
@cd ${WRKSRC}; ${MAKE} install_cgi
|
||||
@${INSTALL_SCRIPT} ${WRKDIR}/bnamazu ${LOCALBASE}/bin
|
||||
@${TEST} -d ${LOCALBASE}/etc/namazu || ${INSTALL_DATA_DIR} ${LOCALBASE}/etc/namazu
|
||||
@${SH} ${WRKDIR}/INSTALL ${PKGNAME} POST-INSTALL
|
||||
|
||||
.include "../../mk/bsd.pkg.mk"
|
44
textproc/namazu1/PLIST
Normal file
44
textproc/namazu1/PLIST
Normal file
|
@ -0,0 +1,44 @@
|
|||
@comment $NetBSD: PLIST,v 1.1.1.1 2002/05/31 13:01:39 seb Exp $
|
||||
bin/bnamazu
|
||||
bin/clnmz
|
||||
bin/gcnmz
|
||||
bin/gtnmz
|
||||
bin/mailutime
|
||||
bin/mknmz
|
||||
bin/namazu
|
||||
bin/rvnmz
|
||||
bin/vfnmz
|
||||
bin/wdnmz
|
||||
@exec ${MKDIR} %D/etc/namazu 2>/dev/null || /usr/bin/true
|
||||
@dirrm etc/namazu
|
||||
@exec ${MKDIR} %D/libdata/namazu 2>/dev/null || /usr/bin/true
|
||||
@exec ${MKDIR} %D/libdata/namazu/index 2>/dev/null || /usr/bin/true
|
||||
@dirrm libdata/namazu/index
|
||||
@dirrm libdata/namazu
|
||||
libexec/cgi-bin/namazu.cgi
|
||||
share/namazu/doc/COPYING
|
||||
share/namazu/doc/ChangeLog
|
||||
share/namazu/doc/ToDo
|
||||
share/namazu/doc/en/README.en
|
||||
share/namazu/doc/en/intro.html
|
||||
share/namazu/doc/en/manual.html
|
||||
share/namazu/doc/ja/FAQ.html
|
||||
share/namazu/doc/ja/README.ja
|
||||
share/namazu/doc/ja/history.html
|
||||
share/namazu/doc/ja/intro.html
|
||||
share/namazu/doc/ja/lynxcgi.html
|
||||
share/namazu/doc/ja/manual.html
|
||||
share/namazu/doc/ja/nmz_files.txt
|
||||
share/namazu/doc/ja/security.html
|
||||
share/namazu/doc/namazu.conf-dist
|
||||
share/namazu/template/NMZ.body.en
|
||||
share/namazu/template/NMZ.body.ja
|
||||
share/namazu/template/NMZ.foot.en
|
||||
share/namazu/template/NMZ.foot.ja
|
||||
share/namazu/template/NMZ.head.en
|
||||
share/namazu/template/NMZ.head.ja
|
||||
@dirrm share/namazu/template
|
||||
@dirrm share/namazu/doc/ja
|
||||
@dirrm share/namazu/doc/en
|
||||
@dirrm share/namazu/doc
|
||||
@dirrm share/namazu
|
5
textproc/namazu1/distinfo
Normal file
5
textproc/namazu1/distinfo
Normal file
|
@ -0,0 +1,5 @@
|
|||
$NetBSD: distinfo,v 1.1.1.1 2002/05/31 13:01:39 seb Exp $
|
||||
|
||||
SHA1 (namazu-1.3.0.11.tar.gz) = 6fca105ad77e1a2940bbfa4e0d74073fd602f411
|
||||
Size (namazu-1.3.0.11.tar.gz) = 343632 bytes
|
||||
SHA1 (patch-aa) = de27b5877c85c581bfb5b459da96caec1433c7b2
|
52
textproc/namazu1/patches/patch-aa
Normal file
52
textproc/namazu1/patches/patch-aa
Normal file
|
@ -0,0 +1,52 @@
|
|||
$NetBSD: patch-aa,v 1.1.1.1 2002/05/31 13:01:39 seb Exp $
|
||||
|
||||
--- Makefile.in.orig Wed Jan 26 22:38:51 2000
|
||||
+++ Makefile.in
|
||||
@@ -21,18 +21,16 @@
|
||||
|
||||
BASEDIR = @prefix@
|
||||
CGIDIR = @CGIDIR@
|
||||
-NAMAZUDIR = $(BASEDIR)/namazu
|
||||
-BINDIR_SYS = $(BASEDIR)/bin # install 'namazu' 'mknmz' command.
|
||||
-BINDIR = $(NAMAZUDIR)/bin
|
||||
-INDEXDIR = $(NAMAZUDIR)/index
|
||||
-DOCDIR = $(NAMAZUDIR)/doc
|
||||
-LIBDIR = $(NAMAZUDIR)/lib
|
||||
-CONTRIBDIR = $(NAMAZUDIR)/contrib
|
||||
+BINDIR = $(BASEDIR)/bin
|
||||
+CONFDIR = $(BASEDIR)/etc/namazu
|
||||
+INDEXDIR = $(BASEDIR)/libdata/namazu/index
|
||||
+DOCDIR = $(BASEDIR)/share/namazu/doc
|
||||
+LIBDIR = $(BASEDIR)/share/namazu/template
|
||||
|
||||
##################################################################
|
||||
## Pathname of namazu.conf
|
||||
|
||||
-OPT_NAMAZU_CONF = $(LIBDIR)/namazu.conf
|
||||
+OPT_NAMAZU_CONF = $(CONFDIR)/namazu.conf
|
||||
|
||||
##################################################################
|
||||
## Programs' pathname
|
||||
@@ -307,19 +305,13 @@
|
||||
if [ ! -d $(LIBDIR) ]; then \
|
||||
mkdir -p $(LIBDIR); \
|
||||
fi
|
||||
- if [ ! -d $(CONTRIBDIR) ]; then \
|
||||
- mkdir -p $(CONTRIBDIR); \
|
||||
- fi
|
||||
- if [ ! -d $(BINDIR_SYS) ]; then \
|
||||
- mkdir -p $(BINDIR_SYS); \
|
||||
- fi
|
||||
cp mknmz wdnmz rvnmz clnmz namazu vfnmz mailutime gcnmz gtnmz $(BINDIR)
|
||||
cp ../COPYING ../ToDo ../ChangeLog $(DOCDIR)
|
||||
cp ../README.ja ../doc/ja/* "$(DOCDIR)/ja"
|
||||
cp ../README.en ../doc/en/* "$(DOCDIR)/en"
|
||||
- cp ../lib/* $(LIBDIR)
|
||||
- cp ../contrib/* $(CONTRIBDIR)
|
||||
- cp namazu mknmz $(BINDIR_SYS)
|
||||
+ rm -f ../lib/*.bak
|
||||
+ cp ../lib/NMZ.* $(LIBDIR)
|
||||
+ cp ../lib/namazu.conf-dist $(DOCDIR)
|
||||
|
||||
clean:
|
||||
$(RM) $(TARGET) *.o config.cache config.log config.status
|
Loading…
Reference in a new issue