Add patches to disable autoresize plugin of TinyMCE since it cause

unexpected redisplay with large editing area.

This change is derived from TYPOlight's SVN repository.
(http://dev.typolight.org/projects/typolight/repository/revisions/317

Bump PKGREVISION.
This commit is contained in:
taca 2010-04-17 18:23:35 +00:00
parent eadc6401ee
commit fa1a7ee318
5 changed files with 81 additions and 2 deletions

View file

@ -1,8 +1,9 @@
# $NetBSD: Makefile,v 1.5 2010/03/16 16:02:21 taca Exp $
# $NetBSD: Makefile,v 1.6 2010/04/17 18:23:35 taca Exp $
#
DISTNAME= typolight-${TL_VERSION}
PKGNAME= typolight${TL_VER}-${TL_PKGVER}
PKGREVISION= 1
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=typolight/}

View file

@ -1,5 +1,8 @@
$NetBSD: distinfo,v 1.5 2010/04/13 15:43:59 taca Exp $
$NetBSD: distinfo,v 1.6 2010/04/17 18:23:35 taca Exp $
SHA1 (typolight-2.8.2.tar.gz) = fb7ef801f7ba2ca3f8eae0a1fb67ce24ed1913a1
RMD160 (typolight-2.8.2.tar.gz) = 37dcc66fae2d9b7df0f13939178182b3c2223463
Size (typolight-2.8.2.tar.gz) = 4115345 bytes
SHA1 (patch-aa) = 496bf7952367116feccdcc18cd458b4749a92ae6
SHA1 (patch-ab) = 0013ae42904856d483a7e6b46b7e1fffd57654fc
SHA1 (patch-ac) = c85d80c2283de642ba8ce0952d7dd0b8eae3f917

View file

@ -0,0 +1,25 @@
$NetBSD: patch-aa,v 1.1 2010/04/17 18:23:35 taca Exp $
* Remove autoresize plugin from TinyMCE.
(r317 from http://svn.typolight.org/trunk)
--- system/config/tinyFlash.php.orig 2010-04-10 12:43:13.000000000 +0000
+++ system/config/tinyFlash.php
@@ -36,7 +36,7 @@
<script type="text/javascript">
<!--//--><![CDATA[//><!--
tinyMCE_GZ.init({
- plugins : "autoresize,autosave,directionality,inlinepopups,legacyoutput,paste,save,searchreplace,spellchecker,tabfocus,template,typolinks",
+ plugins : "autosave,directionality,inlinepopups,legacyoutput,paste,save,searchreplace,spellchecker,tabfocus,template,typolinks",
themes : "advanced",
languages : "<?php echo $this->language; ?>",
disk_cache : false,
@@ -67,7 +67,7 @@ tinyMCE.init({
save_on_tinymce_forms : true,
save_callback : "TinyCallback.cleanHTML",
onchange_callback : "TinyCallback.getScrollOffset",
- plugins : "autoresize,autosave,directionality,inlinepopups,legacyoutput,paste,save,searchreplace,spellchecker,tabfocus,template,typolinks",
+ plugins : "autosave,directionality,inlinepopups,legacyoutput,paste,save,searchreplace,spellchecker,tabfocus,template,typolinks",
spellchecker_languages : "<?php echo $this->getSpellcheckerString(); ?>",
extended_valid_elements : "b/strong,i/em",
content_css : "<?php echo TL_PATH; ?>/basic.css,<?php echo TL_PATH; ?>/system/themes/tinymce.css",

View file

@ -0,0 +1,25 @@
$NetBSD: patch-ab,v 1.1 2010/04/17 18:23:35 taca Exp $
* Remove autoresize plugin from TinyMCE.
(r317 from http://svn.typolight.org/trunk)
--- system/config/tinyMCE.php.orig 2010-04-10 13:54:18.000000000 +0000
+++ system/config/tinyMCE.php
@@ -36,7 +36,7 @@
<script type="text/javascript">
<!--//--><![CDATA[//><!--
tinyMCE_GZ.init({
- plugins : "advimage,autoresize,autosave,directionality,emotions,inlinepopups,paste,save,searchreplace,spellchecker,style,tabfocus,table,template,typolinks,xhtmlxtras",
+ plugins : "advimage,autosave,directionality,emotions,inlinepopups,paste,save,searchreplace,spellchecker,style,tabfocus,table,template,typolinks,xhtmlxtras",
themes : "advanced",
languages : "<?php echo $this->language; ?>",
disk_cache : false,
@@ -72,7 +72,7 @@ tinyMCE.init({
advimage_update_dimensions_onchange : false,
external_image_list_url : "<?php echo TL_PATH; ?>/plugins/tinyMCE/plugins/typolinks/typoimages.php",
template_external_list_url : "<?php echo TL_PATH; ?>/plugins/tinyMCE/plugins/typolinks/typotemplates.php",
- plugins : "advimage,autoresize,autosave,directionality,emotions,inlinepopups,paste,save,searchreplace,spellchecker,style,tabfocus,table,template,typolinks,xhtmlxtras",
+ plugins : "advimage,autosave,directionality,emotions,inlinepopups,paste,save,searchreplace,spellchecker,style,tabfocus,table,template,typolinks,xhtmlxtras",
spellchecker_languages : "<?php echo $this->getSpellcheckerString(); ?>",
content_css : "<?php echo TL_PATH; ?>/basic.css,<?php echo TL_PATH; ?>/system/themes/tinymce.css",
event_elements : "a,div,h1,h2,h3,h4,h5,h6,img,p,span",

View file

@ -0,0 +1,25 @@
$NetBSD: patch-ac,v 1.1 2010/04/17 18:23:35 taca Exp $
* Remove autoresize plugin from TinyMCE.
(r317 from http://svn.typolight.org/trunk)
--- system/config/tinyNews.php.orig 2010-04-10 12:43:13.000000000 +0000
+++ system/config/tinyNews.php
@@ -36,7 +36,7 @@
<script type="text/javascript">
<!--//--><![CDATA[//><!--
tinyMCE_GZ.init({
- plugins : "advimage,autoresize,directionality,emotions,inlinepopups,paste,save,searchreplace,spellchecker,style,tabfocus,table,template,typolinks,xhtmlxtras",
+ plugins : "advimage,directionality,emotions,inlinepopups,paste,save,searchreplace,spellchecker,style,tabfocus,table,template,typolinks,xhtmlxtras",
themes : "advanced",
languages : "<?php echo $this->language; ?>",
disk_cache : false,
@@ -73,7 +73,7 @@ tinyMCE.init({
onchange_callback : "TinyCallback.getScrollOffset",
external_image_list_url : "<?php echo TL_PATH; ?>/plugins/tinyMCE/plugins/typolinks/typoimages.php",
template_external_list_url : "<?php echo TL_PATH; ?>/plugins/tinyMCE/plugins/typolinks/typotemplates.php",
- plugins : "advimage,autoresize,directionality,emotions,inlinepopups,paste,save,searchreplace,spellchecker,style,tabfocus,table,template,typolinks,xhtmlxtras",
+ plugins : "advimage,directionality,emotions,inlinepopups,paste,save,searchreplace,spellchecker,style,tabfocus,table,template,typolinks,xhtmlxtras",
spellchecker_languages : "<?php echo $this->getSpellcheckerString(); ?>",
content_css : "<?php echo TL_PATH; ?>/newsletter.css",
event_elements : "a,div,h1,h2,h3,h4,h5,h6,img,p,span",