Changes 3.1.10:
* Bug 3121: memory leak in DigestAuth: AuthUser object is locked twice * Bug 3113: Consuming too much memory when uploading files * Bug 3110: 'reply_body_max_size none' does not work with x-forwarded-for * Bug 3096: Consuming too much memory when delaying traffic * Bug 3091: Bypassed ICAP errors are not counted as service failures * Bug 3090: Polish FTP login error handing * Bug 3068: cache_dir capacity and usage overflows * Bug 3028: Permit wbinfo_group.pl to authenticate Kerberos users with NT domain * Bug 427: HTTP Compliance: Support If-Match and If-None-Match requests * Fix memory leak in adaptation_access * Fix /dev/poll and poll() selection priority * Fix PREFIX/var/run creation during install * Fix cachemgr http_port config report display * Add upgrade help process for obsolete options * Accept RFC 2965 Set-Cookie2 / Cookie2 headers as 'known' * HTTP/1.1: entry is stale if request has max-age=0 * HTTP/1.1: do not forward TRACE with Max-Forwards: 0 after REQMOD * Toolchain update to support newer auto-tools * ... and updated error page translations * ... and updated documentation * ... and some code optimization/simplification polish
This commit is contained in:
parent
8cb5ce92e7
commit
fa35ce488f
7 changed files with 38 additions and 35 deletions
|
@ -1,6 +1,6 @@
|
|||
# $NetBSD: Makefile,v 1.27 2010/11/03 10:18:26 tron Exp $
|
||||
# $NetBSD: Makefile,v 1.28 2011/01/15 10:32:08 adam Exp $
|
||||
|
||||
DISTNAME= squid-3.1.9
|
||||
DISTNAME= squid-3.1.10
|
||||
PKGNAME= ${DISTNAME} # Necessary for "pkgsrc/www/squid/options.mk"
|
||||
CATEGORIES= www
|
||||
MASTER_SITES= http://www.squid-cache.org/Versions/v3/3.1/ \
|
||||
|
@ -21,11 +21,11 @@ GNU_CONFIGURE= yes
|
|||
CONFIGURE_ARGS+= --with-default-user=${SQUID_USER}
|
||||
CONFIGURE_ARGS+= --with-pidfile=${VARBASE}/run/squid.pid
|
||||
|
||||
EGFILES+= errors/errorpage.css
|
||||
CONF_FILES+= ${PREFIX}/${EGDIR}/errorpage.css ${PKG_SYSCONFDIR}/errorpage.css
|
||||
EGFILES+= errors/errorpage.css
|
||||
CONF_FILES+= ${PREFIX}/${EGDIR}/errorpage.css ${PKG_SYSCONFDIR}/errorpage.css
|
||||
|
||||
SQUID_BACKENDS?= ufs
|
||||
SQUID_NTLM_AUTH_HELPERS?= fakeauth
|
||||
SQUID_BACKENDS?= ufs
|
||||
SQUID_NTLM_AUTH_HELPERS?= fakeauth
|
||||
.include "../../www/squid/options.mk"
|
||||
|
||||
post-build:
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
@comment $NetBSD: PLIST,v 1.4 2010/06/21 12:12:46 sborrill Exp $
|
||||
@comment $NetBSD: PLIST,v 1.5 2011/01/15 10:32:08 adam Exp $
|
||||
bin/squidclient
|
||||
libexec/cachemgr.cgi
|
||||
${PLIST.da_ldap}libexec/digest_ldap_auth
|
||||
|
@ -35,9 +35,8 @@ share/doc/squid/RELEASENOTES.html
|
|||
share/doc/squid/debug-sections.txt
|
||||
share/examples/rc.d/squid
|
||||
share/examples/squid/cachemgr.conf
|
||||
share/examples/squid/errorpage.css
|
||||
share/examples/squid/mime.conf
|
||||
share/examples/squid/msntauth.conf
|
||||
share/examples/squid/squid.conf
|
||||
share/examples/squid/errorpage.css
|
||||
share/examples/squid/msntauth.conf
|
||||
share/squid/mib.txt
|
||||
|
|
|
@ -1,9 +1,9 @@
|
|||
$NetBSD: distinfo,v 1.25 2010/11/03 10:18:26 tron Exp $
|
||||
$NetBSD: distinfo,v 1.26 2011/01/15 10:32:08 adam Exp $
|
||||
|
||||
SHA1 (squid-3.1.9.tar.bz2) = d80045c7ab0cadbaeafdcae42d9dd7d1861fc4c1
|
||||
RMD160 (squid-3.1.9.tar.bz2) = ea2388f5f2a8e39227b8e0c3eea4b8f44315e08f
|
||||
Size (squid-3.1.9.tar.bz2) = 2432312 bytes
|
||||
SHA1 (patch-ad) = cb2591bebcbcf22f6cb1858f243b0c808d3db589
|
||||
SHA1 (patch-ae) = 88fbc7fb1a47b1baf48f7cd0f0b66cbf51e3b24b
|
||||
SHA1 (patch-aj) = 349b5d49dec49430cff2a170ad53d3a16f2a4c76
|
||||
SHA1 (patch-al) = 6dd09cf75ed53a92616f4eed9f3e290232ff54a5
|
||||
SHA1 (squid-3.1.10.tar.bz2) = f9968c8e9708273c5b27962c97853bf3786acc6d
|
||||
RMD160 (squid-3.1.10.tar.bz2) = f5328bd291a81b112e92c998bbc8c32b77797d36
|
||||
Size (squid-3.1.10.tar.bz2) = 2501825 bytes
|
||||
SHA1 (patch-ad) = 2e8c05f220374240e5681efdd46379851c6bb50e
|
||||
SHA1 (patch-ae) = 944c24b28cf11f7a876150f8f0e131af5f3e354d
|
||||
SHA1 (patch-aj) = 9f250b7f645b2ee77243a617c1a7faa5c7956339
|
||||
SHA1 (patch-al) = 6fec093f8969aed96cb8ffb115d96f9d21ac1f63
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
$NetBSD: patch-ad,v 1.5 2009/07/19 23:05:38 tron Exp $
|
||||
$NetBSD: patch-ad,v 1.6 2011/01/15 10:32:08 adam Exp $
|
||||
|
||||
--- tools/Makefile.in.orig 2009-07-19 06:11:36.000000000 +0100
|
||||
+++ tools/Makefile.in 2009-07-19 15:20:43.000000000 +0100
|
||||
@@ -805,7 +805,7 @@
|
||||
--- tools/Makefile.in.orig 2010-12-22 05:47:59.000000000 +0000
|
||||
+++ tools/Makefile.in
|
||||
@@ -1008,7 +1008,7 @@ info: info-recursive
|
||||
|
||||
info-am:
|
||||
|
||||
|
|
|
@ -1,17 +1,17 @@
|
|||
$NetBSD: patch-ae,v 1.5 2009/09/27 20:06:37 tron Exp $
|
||||
$NetBSD: patch-ae,v 1.6 2011/01/15 10:32:08 adam Exp $
|
||||
|
||||
--- errors/Makefile.in.orig 2009-09-27 04:28:48.000000000 +0100
|
||||
+++ errors/Makefile.in 2009-09-27 13:26:44.000000000 +0100
|
||||
@@ -432,7 +432,7 @@
|
||||
--- errors/Makefile.in.orig 2010-12-22 05:47:42.000000000 +0000
|
||||
+++ errors/Makefile.in
|
||||
@@ -473,7 +473,7 @@ install-dvi: install-dvi-am
|
||||
|
||||
install-dvi: install-dvi-am
|
||||
install-dvi-am:
|
||||
|
||||
-install-exec-am: install-exec-local
|
||||
+install-exec-am:
|
||||
|
||||
install-html: install-html-am
|
||||
|
||||
@@ -540,7 +540,7 @@
|
||||
@@ -589,7 +589,7 @@ install-data-local: translate
|
||||
done; \
|
||||
$(INSTALL_DATA) $(srcdir)/TRANSLATORS $(DESTDIR)$(DEFAULT_ERROR_DIR)/TRANSLATORS; \
|
||||
$(INSTALL_DATA) $(srcdir)/COPYRIGHT $(DESTDIR)$(DEFAULT_ERROR_DIR)/COPYRIGHT; \
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
$NetBSD: patch-aj,v 1.4 2009/06/07 08:36:36 tron Exp $
|
||||
$NetBSD: patch-aj,v 1.5 2011/01/15 10:32:08 adam Exp $
|
||||
|
||||
--- src/Makefile.in.orig 2009-05-23 13:31:24.000000000 +0100
|
||||
+++ src/Makefile.in 2009-06-06 18:13:15.000000000 +0100
|
||||
@@ -4284,12 +4284,12 @@
|
||||
--- src/Makefile.in.orig 2010-12-22 05:47:54.000000000 +0000
|
||||
+++ src/Makefile.in
|
||||
@@ -4616,14 +4616,14 @@ info: info-recursive
|
||||
|
||||
info-am:
|
||||
|
||||
|
@ -11,6 +11,8 @@ $NetBSD: patch-aj,v 1.4 2009/06/07 08:36:36 tron Exp $
|
|||
|
||||
install-dvi: install-dvi-recursive
|
||||
|
||||
install-dvi-am:
|
||||
|
||||
install-exec-am: install-binPROGRAMS install-libexecPROGRAMS \
|
||||
- install-sbinPROGRAMS install-sysconfDATA
|
||||
+ install-sbinPROGRAMS
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
$NetBSD: patch-al,v 1.4 2009/06/07 08:36:36 tron Exp $
|
||||
$NetBSD: patch-al,v 1.5 2011/01/15 10:32:08 adam Exp $
|
||||
|
||||
--- helpers/basic_auth/MSNT/Makefile.in.orig 2009-05-23 13:31:17.000000000 +0100
|
||||
+++ helpers/basic_auth/MSNT/Makefile.in 2009-06-06 23:29:51.000000000 +0100
|
||||
@@ -542,11 +542,11 @@
|
||||
--- helpers/basic_auth/MSNT/Makefile.in.orig 2010-12-22 05:47:43.000000000 +0000
|
||||
+++ helpers/basic_auth/MSNT/Makefile.in
|
||||
@@ -718,13 +718,13 @@ info: info-am
|
||||
|
||||
info-am:
|
||||
|
||||
|
@ -11,6 +11,8 @@ $NetBSD: patch-al,v 1.4 2009/06/07 08:36:36 tron Exp $
|
|||
|
||||
install-dvi: install-dvi-am
|
||||
|
||||
install-dvi-am:
|
||||
|
||||
-install-exec-am: install-libexecPROGRAMS install-sysconfDATA
|
||||
+install-exec-am: install-libexecPROGRAMS
|
||||
|
||||
|
|
Loading…
Reference in a new issue