chat/centerim: #include <unistd.h>

Fixes out-of-scope errors seen on gcc 4.7.x
This commit is contained in:
marino 2012-11-23 20:48:04 +00:00
parent 72d7b63bcf
commit fa3696fb92
2 changed files with 14 additions and 1 deletions

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.4 2009/12/15 08:29:35 jnemeth Exp $
$NetBSD: distinfo,v 1.5 2012/11/23 20:48:04 marino Exp $
SHA1 (centerim-4.22.9.tar.gz) = ebe9f4ee2064a2fa10f1084ce26083ccd295673e
RMD160 (centerim-4.22.9.tar.gz) = 253007e466a211ec740f7843538e4f686ab95cad
@ -8,3 +8,4 @@ SHA1 (patch-ac) = 4ef992ed632a57e921661b1b0054beff0c0aa587
SHA1 (patch-ad) = bfe19ca98facfbb23a87dd28a176980fb4e986de
SHA1 (patch-av) = 05758183016fb1bb297c9c3d2c0606e6a66f9901
SHA1 (patch-bb) = 7312d496cdde7f619eff6bfef6025fe9be14529d
SHA1 (patch-libicq2000_libicq2000_sigslot.h) = a812915ad5b329a6c82ff90835d26f73552eeebb

View file

@ -0,0 +1,12 @@
$NetBSD: patch-libicq2000_libicq2000_sigslot.h,v 1.1 2012/11/23 20:48:05 marino Exp $
--- libicq2000/libicq2000/sigslot.h.orig 2009-08-27 11:16:41.000000000 +0000
+++ libicq2000/libicq2000/sigslot.h
@@ -82,6 +82,7 @@
#ifndef SIGSLOT_H__
#define SIGSLOT_H__
+#include <unistd.h>
#include <set>
#include <list>