This commit is contained in:
joerg 2012-11-16 20:06:08 +00:00
parent ee1074cddd
commit fa57813f94
4 changed files with 49 additions and 3 deletions

View file

@ -1,10 +1,12 @@
$NetBSD: distinfo,v 1.36 2012/03/21 21:14:47 markd Exp $
$NetBSD: distinfo,v 1.37 2012/11/16 20:06:08 joerg Exp $
SHA1 (digikam-2.5.0.tar.bz2) = 6cadb838669d1bdcbd6abb677889f7d68d696383
RMD160 (digikam-2.5.0.tar.bz2) = 4ff1b5fbc2cc4a8cb9994f7c7796086418dd43fb
Size (digikam-2.5.0.tar.bz2) = 54976375 bytes
SHA1 (patch-CMakeLists.txt) = be9b2c8df31e20b4d051c2bdaf92d0a0dff573b8
SHA1 (patch-core_digikam_album_albummanager.h) = 1933ade39e080f1dda996683a6edf47b125a9acf
SHA1 (patch-core_libs_3rdparty_kmemoryinfo_kmemoryinfo_backend.cpp) = 78f2e7a35d7ddae3c8f685414112bd6aebec2855
SHA1 (patch-core_libs_database_imagehistory_imagehistorygraph_boost.h) = 4a7eb391a392ad2dbbf42a0fb06c157ce79d5177
SHA1 (patch-core_libs_database_imagehistory_imagehistorygraph_boost.h) = 18aead6282798bfb20d43ec2a6b8a6a73bc9d065
SHA1 (patch-core_libs_dimg_filters_icc_iccmanager.h) = 96eb80ae73184d95efb52d01ede8e25b607158a0
SHA1 (patch-core_utilities_setup_setupplugins.cpp) = c15907a93144d33905d1dd33f604362b79e89690
SHA1 (patch-doc_CMakeLists.txt) = 5b4ba1daa49607b8773c3903d953e11bebc4d661

View file

@ -0,0 +1,13 @@
$NetBSD: patch-core_digikam_album_albummanager.h,v 1.1 2012/11/16 20:06:08 joerg Exp $
--- core/digikam/album/albummanager.h.orig 2012-11-16 17:03:39.000000000 +0000
+++ core/digikam/album/albummanager.h
@@ -831,7 +831,7 @@ public:
{
foreach(T* t, list)
{
- append(AlbumPointer<T>(t));
+ this->append(AlbumPointer<T>(t));
}
return *this;
}

View file

@ -1,4 +1,4 @@
$NetBSD: patch-core_libs_database_imagehistory_imagehistorygraph_boost.h,v 1.1 2012/03/21 21:14:47 markd Exp $
$NetBSD: patch-core_libs_database_imagehistory_imagehistorygraph_boost.h,v 1.2 2012/11/16 20:06:08 joerg Exp $
boost148.patch from ArchLinux - build with recent boost.
@ -22,6 +22,24 @@ boost148.patch from ArchLinux - build with recent boost.
// Invert the default compare method: With greater, we get the longest path
distance_compare(std::greater<int>()).
// will be returned if a node is unreachable
@@ -1362,7 +1362,7 @@ protected:
template <typename VertexType, typename GraphType>
void discover_vertex(VertexType u, const GraphType&) const
{
- record(u);
+ this->record(u);
}
};
@@ -1373,7 +1373,7 @@ protected:
template <typename VertexType, typename GraphType>
void discover_vertex(VertexType u, const GraphType&) const
{
- record(u);
+ this->record(u);
}
};
@@ -1384,14 +1384,15 @@ protected:
template <class GraphType, typename VertexLessThan>
class lessThanMapEdgeToTarget

View file

@ -0,0 +1,13 @@
$NetBSD: patch-core_libs_dimg_filters_icc_iccmanager.h,v 1.1 2012/11/16 20:06:08 joerg Exp $
--- core/libs/dimg/filters/icc/iccmanager.h.orig 2012-11-16 18:20:53.000000000 +0000
+++ core/libs/dimg/filters/icc/iccmanager.h
@@ -129,7 +129,7 @@ public:
static void transformToSRGB(QImage& qimage, const IccProfile& inputProfile);
/** Transforms the given QImage from sRGB to given display profile. */
- static void transformForDisplay(QImage& qimage, const IccProfile& displayProfile = displayProfile());
+ static void transformForDisplay(QImage& qimage, const IccProfile& displayProfile = IccProfile());
protected: