Fix build with newer GCC

This commit is contained in:
joerg 2011-12-06 19:52:57 +00:00
parent b08b4d4eef
commit fa5d57a5c6
3 changed files with 28 additions and 1 deletions

View file

@ -1,7 +1,9 @@
$NetBSD: distinfo,v 1.14 2010/06/15 14:31:09 wiz Exp $
$NetBSD: distinfo,v 1.15 2011/12/06 19:52:57 joerg Exp $
SHA1 (spamprobe-1.4d.tar.gz) = fbcd65eb21097cd860d5e5ee2c4c2524c717a237
RMD160 (spamprobe-1.4d.tar.gz) = 4a9e098b92e6900d8b03d7ed5e8d052f2b2e8c56
Size (spamprobe-1.4d.tar.gz) = 262761 bytes
SHA1 (patch-aa) = 1a139882a9913537663a0d03b645e014b488ecbe
SHA1 (patch-ab) = da2cd2cbc3b37e529e45b67eb7eea127afcaa07c
SHA1 (patch-src_includes_MultiLineSubString.h) = bd6def3ef4e261ee4fe56d58447c89d7fce8e9e3
SHA1 (patch-src_includes_util.h) = 5c7f02ac7f3852c6d751afd07df752cef7a1f06e

View file

@ -0,0 +1,12 @@
$NetBSD: patch-src_includes_MultiLineSubString.h,v 1.1 2011/12/06 19:52:57 joerg Exp $
--- src/includes/MultiLineSubString.h.orig 2011-12-06 16:26:43.000000000 +0000
+++ src/includes/MultiLineSubString.h
@@ -32,6 +32,7 @@
#define _MultiLineSubString_h
#include "AbstractMultiLineString.h"
+#include <climits>
class MultiLineSubString : public AbstractMultiLineString
{

View file

@ -0,0 +1,13 @@
$NetBSD: patch-src_includes_util.h,v 1.1 2011/12/06 19:52:57 joerg Exp $
--- src/includes/util.h.orig 2011-12-06 16:26:03.000000000 +0000
+++ src/includes/util.h
@@ -42,6 +42,8 @@
#include <cassert>
#include <iostream>
#include <cstdio>
+#include <cstdlib>
+#include <cstring>
#include "Ptr.h"
#include "Ref.h"