Added a patch for SunPro.
This commit is contained in:
parent
ce39afb356
commit
fa766fc022
2 changed files with 35 additions and 1 deletions
|
@ -1,6 +1,7 @@
|
|||
$NetBSD: distinfo,v 1.13 2006/02/27 22:31:56 joerg Exp $
|
||||
$NetBSD: distinfo,v 1.14 2006/11/28 20:11:07 rillig Exp $
|
||||
|
||||
SHA1 (xffm-4.2.3.tar.gz) = f1d4ddd9377c241ee94bc373d7f9b8ef58a79ca2
|
||||
RMD160 (xffm-4.2.3.tar.gz) = 6de5cca2375c364b86d82ec3701db61248d72c66
|
||||
Size (xffm-4.2.3.tar.gz) = 5117799 bytes
|
||||
SHA1 (patch-aa) = 06f2eabaad3d7901243d547e65f1737c29ba42a6
|
||||
SHA1 (patch-ab) = a2f8f23527945056cd4ba2f6acc53ba5c1fb7bfc
|
||||
|
|
33
sysutils/xfce4-fm/patches/patch-ab
Normal file
33
sysutils/xfce4-fm/patches/patch-ab
Normal file
|
@ -0,0 +1,33 @@
|
|||
$NetBSD: patch-ab,v 1.1 2006/11/28 20:11:08 rillig Exp $
|
||||
|
||||
SunPro says: Functions of type void cannot return a value.
|
||||
|
||||
--- libs/modules.c.orig 2005-11-05 18:13:43.000000000 +0100
|
||||
+++ libs/modules.c 2006-11-28 21:08:48.504015056 +0100
|
||||
@@ -104,7 +104,7 @@ void unload_module(const gchar *module_n
|
||||
}
|
||||
|
||||
G_MODULE_EXPORT
|
||||
-void unload_xfc(void){ return unload_module("xfce4_combo");}
|
||||
+void unload_xfc(void){ unload_module("xfce4_combo");}
|
||||
G_MODULE_EXPORT
|
||||
xfc_combo_functions *load_xfc(void){
|
||||
xfc_combo_functions *xfc_fun = (xfc_combo_functions *)load_module("modules","xfce4_combo");
|
||||
@@ -114,7 +114,7 @@ xfc_combo_functions *load_xfc(void){
|
||||
}
|
||||
|
||||
G_MODULE_EXPORT
|
||||
-void unload_mime_icon_module(void){return unload_module("xfce4_mime_icons");}
|
||||
+void unload_mime_icon_module(void){ unload_module("xfce4_mime_icons");}
|
||||
G_MODULE_EXPORT
|
||||
xfmime_icon_functions *load_mime_icon_module(void){
|
||||
xfmime_icon_functions *xfmime_icon_fun=(xfmime_icon_functions *)load_module("modules","xfce4_mime_icons");
|
||||
@@ -122,7 +122,7 @@ xfmime_icon_functions *load_mime_icon_mo
|
||||
}
|
||||
|
||||
G_MODULE_EXPORT
|
||||
-void unload_mime_module(void){return unload_module("xfce4_mime");}
|
||||
+void unload_mime_module(void){ unload_module("xfce4_mime");}
|
||||
G_MODULE_EXPORT
|
||||
xfmime_functions *load_mime_module(void){
|
||||
xfmime_functions *xfmime_fun=(xfmime_functions *)load_module("modules","xfce4_mime");
|
Loading…
Reference in a new issue