-add portability fixes, avoid picking up bash

-update to 5.12 -- too many changes to list here, see the Changelog
This commit is contained in:
drochner 2011-07-08 11:44:02 +00:00
parent acda5774f0
commit fa80c2eb64
6 changed files with 107 additions and 23 deletions

View file

@ -1,9 +1,9 @@
# $NetBSD: Makefile,v 1.30 2010/03/24 19:43:22 asau Exp $
# $NetBSD: Makefile,v 1.31 2011/07/08 11:44:02 drochner Exp $
DISTNAME= autogen-5.9.5
PKGREVISION= 3
DISTNAME= autogen-5.12
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=autogen/}
#MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=autogen/}
MASTER_SITES= ftp://ftp.gnu.org/gnu/autogen/rel5.12/
EXTRACT_SUFX= .tar.bz2
MAINTAINER= kristerw@NetBSD.org
@ -12,11 +12,14 @@ COMMENT= The Automated Text and Program Generation Tool
PKG_DESTDIR_SUPPORT= user-destdir
USE_TOOLS+= gmake makeinfo
USE_TOOLS+= gmake makeinfo perl:run
GNU_CONFIGURE= yes
USE_LIBTOOL= yes
INFO_FILES= yes
CONFIGURE_ENV+= POSIX_SHELL=/bin/sh
MAKE_ENV+= PERL5=${PERL5} POSIX_CAT=${CAT}
INSTALLATION_DIRS= include/autoopts
.include "../../lang/guile/buildlink3.mk"

View file

@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.13 2009/06/14 17:48:34 joerg Exp $
@comment $NetBSD: PLIST,v 1.14 2011/07/08 11:44:02 drochner Exp $
bin/autogen
bin/autoopts-config
bin/columns
@ -7,9 +7,7 @@ bin/xml2ag
include/autoopts/options.h
include/autoopts/usage-txt.h
info/autogen.info
lib/libguileopts.la
lib/libopts.la
lib/pkgconfig/autoopts.pc
man/man1/autogen.1
man/man1/autoopts-config.1
man/man1/columns.1
@ -37,25 +35,46 @@ man/man3/streqvmap.3
man/man3/strneqvcmp.3
man/man3/strtransform.3
share/aclocal/autoopts.m4
share/aclocal/liboptschk.m4
share/autogen/aginfo.tpl
share/autogen/aginfo3.tpl
share/autogen/agman-lib.tpl
share/autogen/agman-cmd.tpl
share/autogen/agman.tlib
share/autogen/agman1.tpl
share/autogen/agman3.tpl
share/autogen/agmdoc-cmd.tpl
share/autogen/agpl.lic
share/autogen/agtexi-cmd.tpl
share/autogen/autoopts.m4
share/autogen/confmacs.tpl
share/autogen/bits.tpl
share/autogen/cmd-doc.tlib
share/autogen/confmacs.tlib
share/autogen/conftest.tpl
share/autogen/fsm-macro.tpl
share/autogen/fsm-trans.tpl
share/autogen/fsm-macro.tlib
share/autogen/fsm-trans.tlib
share/autogen/fsm.tpl
share/autogen/getopt.tpl
share/autogen/libopts-31.1.6.tar.gz
share/autogen/optcode.tpl
share/autogen/opthead.tpl
share/autogen/gpl.lic
share/autogen/gplv2.lic
share/autogen/lgpl.lic
share/autogen/libopts-35.0.10.tar.gz
share/autogen/liboptschk.m4
share/autogen/man2man
share/autogen/man2mdoc
share/autogen/man2texi
share/autogen/mbsd.lic
share/autogen/mdoc2man
share/autogen/mdoc2mdoc
share/autogen/mdoc2texi
share/autogen/optcode.tlib
share/autogen/opthead.tlib
share/autogen/options.tpl
share/autogen/optlib.tpl
share/autogen/optmain.tpl
share/autogen/optlib.tlib
share/autogen/optmain.tlib
share/autogen/rc-sample.tpl
share/autogen/stdoptions.def
share/autogen/usage.tpl
share/autogen/texi2man
share/autogen/texi2mdoc
share/autogen/texi2texi
share/autogen/tpl-config.tlib
share/autogen/usage.tlib
share/pkgconfig/autoopts.pc

View file

@ -1,5 +1,8 @@
$NetBSD: distinfo,v 1.10 2008/05/26 14:50:19 wiz Exp $
$NetBSD: distinfo,v 1.11 2011/07/08 11:44:02 drochner Exp $
SHA1 (autogen-5.9.5.tar.bz2) = b83961796a060f91ed30584eaffacd046368ba28
RMD160 (autogen-5.9.5.tar.bz2) = 17f5fc8288f03663d27a7031e65173311d6bab92
Size (autogen-5.9.5.tar.bz2) = 1007798 bytes
SHA1 (autogen-5.12.tar.bz2) = 3212cf32da9ba2866e1566e78dac3867ee247ac2
RMD160 (autogen-5.12.tar.bz2) = b00ab61cf0b47fb53039fa680071382c34b51f65
Size (autogen-5.12.tar.bz2) = 1059162 bytes
SHA1 (patch-ab) = 095ad72ef6ac6b1f3677a9898d8788c5ff60f4e0
SHA1 (patch-ac) = 2a37cc72d2affbb8d99d3d23d0e6782a013cfec4
SHA1 (patch-ad) = 3bb19c5e15768335bf5ae11be3803b2587298fa3

View file

@ -0,0 +1,23 @@
$NetBSD: patch-ab,v 1.3 2011/07/08 11:44:02 drochner Exp $
--- autoopts/mk-tpl-config.sh.orig 2011-06-06 15:08:10.000000000 +0000
+++ autoopts/mk-tpl-config.sh
@@ -70,7 +70,7 @@ do
st=`sed 1q $f`
case "$st" in
- */perl ) echo '#!' `which perl`
+ */perl ) echo '#!' ${PERL5}
sed 1d $f
;;
@@ -87,7 +87,8 @@ done
while :
do
\unalias -a
- unset -f command cat which
+ unset -f command cat which || true
+ test -x "$POSIX_CAT" && break
POSIX_CAT=`which cat`
test -x "$POSIX_CAT" && break
POSIX_CAT=`

View file

@ -0,0 +1,24 @@
$NetBSD: patch-ac,v 1.1 2011/07/08 11:44:02 drochner Exp $
fmt(1) options portability: width=75 should be default
--- autoopts/tpl/optcode.tlib.orig 2011-05-03 21:08:02.000000000 +0000
+++ autoopts/tpl/optcode.tlib
@@ -171,7 +171,7 @@ ELSE =][=
"#define zLicenseDescrip zCopyright\n"
(begin
(set! ext-text (string-append (shell (string-append
- "fmt -w 75 <<_EOF_\n" ext-text "\n_EOF_" )) "\n" ))
+ "fmt <<_EOF_\n" ext-text "\n_EOF_" )) "\n" ))
(sprintf "static char const zLicenseDescrip[%d] =\n%s;\n"
(+ (string-length ext-text) 1)
@@ -448,7 +448,7 @@ s/^@item *$/\
/[=
(define patch-text-sed
- (sprintf "sed %s <<\\_EODetail_ | fmt -w 75\n"
+ (sprintf "sed %s <<\\_EODetail_ | fmt\n"
(raw-shell-str (out-pop #t)) ) )
(define patch-text (lambda (t-name)

View file

@ -0,0 +1,12 @@
$NetBSD: patch-ad,v 1.3 2011/07/08 11:44:02 drochner Exp $
--- configure.orig 2011-05-06 14:06:58.000000000 +0000
+++ configure
@@ -13518,6 +13518,7 @@ $as_echo "$ac_cv_path_SED" >&6; }
while :
do
+ test -x "$POSIX_SHELL" && break
POSIX_SHELL=`which bash`
test -x "$POSIX_SHELL" && break
POSIX_SHELL=`which dash`