pkgsrc changes:
* Remove unnecessary patches to strip /usr/local from -L and -I paths. * Makefile style nits. * Specify dependency on howl's mDNSResponder in the rc.d script. Ride the version and PKGREVISION from mjl's commit an hour ago.
This commit is contained in:
parent
a2c0ed43c3
commit
fa84583330
5 changed files with 27 additions and 38 deletions
|
@ -1,4 +1,4 @@
|
|||
# $NetBSD: Makefile,v 1.7 2005/01/08 05:22:36 mjl Exp $
|
||||
# $NetBSD: Makefile,v 1.8 2005/01/08 06:44:41 schmonz Exp $
|
||||
|
||||
DISTNAME= daapd-0.2.3d
|
||||
PKGREVISION= 2
|
||||
|
@ -12,16 +12,14 @@ COMMENT= Server for DAA protocol (iTunes)
|
|||
|
||||
USE_LANGUAGES= c c++
|
||||
USE_BUILDLINK3= yes
|
||||
USE_PKGINSTALL= YES
|
||||
USE_PKGINSTALL= yes
|
||||
USE_GNU_TOOLS+= make
|
||||
MAKEFILE= makefile
|
||||
|
||||
RCD_SCRIPTS= daapd
|
||||
EGDIR= ${PREFIX}/share/examples/${PKGBASE}
|
||||
|
||||
# PKG_SYSCONFSUBDIR= ${PKGBASE}
|
||||
|
||||
CONF_FILES= ${EGDIR}/daapd.conf ${PKG_SYSCONFDIR}/daapd.conf
|
||||
CONF_FILES= ${EGDIR}/daapd.conf ${PKG_SYSCONFDIR}/daapd.conf
|
||||
|
||||
post-install:
|
||||
${INSTALL_DATA_DIR} ${PKG_SYSCONFDIR}
|
||||
|
|
|
@ -1,6 +1,5 @@
|
|||
$NetBSD: distinfo,v 1.4 2005/01/08 05:22:36 mjl Exp $
|
||||
$NetBSD: distinfo,v 1.5 2005/01/08 06:44:41 schmonz Exp $
|
||||
|
||||
SHA1 (daapd-0.2.3d.tgz) = 3ca12f0cb608a0be2d8351dbc341aa7d2a4f08f8
|
||||
Size (daapd-0.2.3d.tgz) = 202317 bytes
|
||||
SHA1 (patch-aa) = b1ec33f2e7ea7672762017077d9c9178b0a061bc
|
||||
SHA1 (patch-ac) = a3e203dcf6e7686795f8348fef5cc2272abdfc48
|
||||
SHA1 (patch-aa) = 69c97c6b384ff2795d68254805181e77f45d9509
|
||||
|
|
|
@ -1,27 +1,18 @@
|
|||
#!@RCD_SCRIPTS_SHELL@
|
||||
#
|
||||
# $NetBSD: daapd.sh,v 1.2 2005/01/06 14:43:09 mjl Exp $
|
||||
# $NetBSD: daapd.sh,v 1.3 2005/01/08 06:44:41 schmonz Exp $
|
||||
#
|
||||
|
||||
# PROVIDE: daapd
|
||||
# REQUIRE: DAEMON LOGIN
|
||||
# REQUIRE: DAEMON LOGIN howl
|
||||
|
||||
. /etc/rc.subr
|
||||
|
||||
name="daapd"
|
||||
help_name=$name
|
||||
rcvar=$name
|
||||
command="@PREFIX@/bin/${name}"
|
||||
required_files="@PKG_SYSCONFDIR@/daapd.conf"
|
||||
command_args="-c $required_files 2>&1 > /dev/null &"
|
||||
|
||||
#if ps auxww | grep -v grep | grep -q mDNSResponder ; then
|
||||
# echo "Runs: mDNSResponder"
|
||||
# :
|
||||
#else
|
||||
# echo "Starting mDNSResponder"
|
||||
# /usr/pkg/bin/mDNSResponder
|
||||
#fi
|
||||
|
||||
load_rc_config $name
|
||||
run_rc_command "$1"
|
||||
|
|
|
@ -1,22 +1,29 @@
|
|||
--- makefile.orig 2004-09-08 03:17:58.000000000 +0200
|
||||
+++ makefile 2005-01-08 06:12:42.000000000 +0100
|
||||
@@ -4,3 +4,3 @@
|
||||
--- makefile.orig 2004-09-07 21:17:58.000000000 -0400
|
||||
+++ makefile
|
||||
@@ -2,7 +2,7 @@
|
||||
|
||||
HOWL_ENABLE = 1
|
||||
ZLIB_ENABLE = 1
|
||||
-MPEG4_ENABLE = 1
|
||||
+MPEG4_ENABLE = 0
|
||||
|
||||
@@ -16,6 +16,6 @@
|
||||
|
||||
# no need to touch anything below this line
|
||||
@@ -14,16 +14,16 @@ TARGET = daapd
|
||||
DEPS = daaplib_ libhttpd_
|
||||
OBJS = daapd.o db.o dboutput.o songcache.o parsemp3.o
|
||||
LIBS = -ldaaplib -lhttpd-persistent -lid3tag -lz -lpthread
|
||||
-LIBPATH = -L. -L./daaplib/src -L./libhttpd/src -L/usr/local/lib
|
||||
-INCPATH = -I. -I./daaplib/include -I./libhttpd/src -I/usr/local/include
|
||||
+LIBPATH = -L. ${LDFLAGS} -L./daaplib/src -L./libhttpd/src -L/usr/local/lib
|
||||
INCPATH = -I. -I./daaplib/include -I./libhttpd/src -I/usr/local/include
|
||||
-DEPLOY = /usr/local
|
||||
-CFLAGS = -Wall -Wno-multichar
|
||||
+LIBPATH = -L. ${LDFLAGS} -L./daaplib/src -L./libhttpd/src
|
||||
+INCPATH = -I. -I./daaplib/include -I./libhttpd/src
|
||||
+DEPLOY = ${PREFIX}
|
||||
+CFLAGS += -Wall -Wno-multichar
|
||||
|
||||
@@ -23,5 +23,5 @@
|
||||
# HOWL
|
||||
ifeq ($(HOWL_ENABLE),1)
|
||||
- HOWLDIRS := $(sort $(wildcard /usr/local/include/howl*) )
|
||||
+ HOWLDIRS := $(sort $(wildcard ${PREFIX}/include/howl*) )
|
||||
|
@ -24,8 +31,14 @@
|
|||
-$(error howl not found in /usr/local/include. Install howl or disable it in the makefile)
|
||||
+$(error howl not found in ${PREFIX}/include. Install howl or disable it in the makefile)
|
||||
endif
|
||||
@@ -76,4 +76,2 @@
|
||||
HOWLRECENT := $(word $(words $(HOWLDIRS)),$(HOWLDIRS) )
|
||||
INCPATH := $(INCPATH) -I$(HOWLRECENT)
|
||||
@@ -74,8 +74,6 @@ clean:
|
||||
rm $(OBJS) $(TARGET)
|
||||
|
||||
install: $(DEPS) $(TARGET)
|
||||
- cd libhttpd && $(MAKE) install
|
||||
- cd daaplib/src && $(MAKE) install
|
||||
cp $(TARGET) $(DEPLOY)/bin
|
||||
chmod a+rx $(DEPLOY)/bin/$(TARGET)
|
||||
cp $(TARGET).8 $(DEPLOY)/man/man8
|
||||
|
|
|
@ -1,12 +0,0 @@
|
|||
$NetBSD: patch-ac,v 1.1.1.1 2004/06/05 19:07:51 nathanw Exp $
|
||||
|
||||
--- libhttpd/Site.mm.in.orig 2004-06-04 14:51:42.000000000 -0400
|
||||
+++ libhttpd/Site.mm.in 2004-06-04 14:52:05.000000000 -0400
|
||||
@@ -37,5 +37,5 @@
|
||||
# Any other CFlags required
|
||||
EXTRA_CFLAGS=
|
||||
|
||||
-CFLAGS= -g -I$(TOP)/ -I/usr/local/include $(EXTRA_CFLAGS) -D$(OS_TYPE)
|
||||
-LDLIBS= -L/usr/local/lib -L$(TOP)/lib @LIBS@ $(EXTRA_LIBS)
|
||||
+CFLAGS= -g -I$(TOP)/ $(EXTRA_CFLAGS) -D$(OS_TYPE)
|
||||
+LDLIBS= -L$(TOP)/lib @LIBS@ $(EXTRA_LIBS)
|
Loading…
Reference in a new issue